Question about Lanzar VIBE266 Car Audio Amplifier

1 Answer

Power light doesn't stay on...

Hey, I recently, in fact just yesterday, purchased a Lanzar Vibe266 2000w Car Amp. I hooked it up, and got it running great and smoothly with no problems. Then after driving around for the day listening to the bass, it cut out. Gave it some time and then after a while it started playing again. I didn't think anything of it until I parked my car for probably an hour, came back to it and it was completly dead, and wouldn't start. I figured my battery just couldn't push enough power to keep the Amp running, so I would go buy a Capacitor today. Well the amp still worked for a bit, but again cut out. I thought my battery would just be too low t run it, but since then, and still now, When I turn my car on, the power light comes on, and then goes right over leaving the protection light on. Any ideas as to why it's doing this now, but before it got power fine, just used to much.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 148 Answers
Re: Power light doesn't stay on...

Caps are NEVER a solution to ANYTHING in a car audio system. If your car is lacking in power, you need a high output alt. All caps do is mask the problem until eventually your car's charging system is toast. Check this out:

Posted on Aug 17, 2006

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

My lanzar mini max amp keeps loosing power at medium to high volume why is this

first off you need to find out if your subs are 2 ,4,6 ohm . then check what ohm your amp will run if it is cutting off it's pulling to much power or it's over heating it.there are certen ways to hook up your subs.

Jun 12, 2011 | Lanzar MNX250 2Channel Car Amp

1 Answer

Subs Won't work when wired


Based on your post/description, pls try:
1. running the amp's power without the capacitor;
2. manually trigger the amp with the head unit off. Run it an determine if the backfiring still will occur (even with the head unit off);
3. temporarily interchange the left/right wiring;
4. temporarily interchange the + and - speaker wires;
5. run the amp normally trioggered by the headunit but remove the RCA connectors towards the amp.

If your concern has not been corrected or diagnosed which is at fault (wiring, amp, source) after completion of the above procedures, the amp may require an internal look and see.

Hope this be of initial help/idea. Pls post back how things turned up or should you need additional information.

Good luck and kind regards.

Thank you for using FIXYA.

Feb 15, 2008 | Lanzar VIBE266 Car Audio Amplifier

1 Answer

The amp won't turn on

try hooking a wire from your mane hot to your remote and see if it comes on if so then your remote wire is bad from your radio

Jun 14, 2010 | Lanzar VIBE286 Car Audio Amplifier

1 Answer

My amp doesnt work

their may be a short some ware check your power line and your ground i had the same problome with mine

Apr 29, 2010 | Lanzar VIBE241 Car Audio Amplifier

2 Answers

I have a Lanzar Vibe 235 amp. the green power light is not coming on, but the red "protect" light is. how do i solve this problem??

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to purchase an old school Lanzar Opti Drive. Any of them. The 50 will kill some 12" subs .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-vibe-235-amp-green-power-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

Mar 11, 2010 | Lanzar Vibe 235 Car Audio Amplifier

2 Answers

Lanzar 800 watt amp protect mode stays on

protect mode usaully means that something has disrupted the power of feed lines to the subwoofer/speakers possibly fuse is blown in amp or amp is blown in which we hope not. see if you have a warrenty if blown and send back or bring it to where you purchased it from.

Aug 01, 2009 | Lanzar VIBE266 Car Audio Amplifier

2 Answers

Lanzar Vibe 1200D protection light

You will need to show it to a service technician as it seems the output section has blown so it remains in protect mode. One reason (could be) that the input to the amp was high and may have been clipping for some time before the amp decided it could take it no more

Jan 14, 2008 | Lanzar Vibe 1200D Car Audio Amplifier

1 Answer

Lanzar amp

If it keeps blowing fuses then #1 its internally damaged or "blown" .. Or #2 i would make sure you have the battery power hooked up to the + terminal and the ground wire running from the car body to the - terminal.. so if its hooked up correctly and keeps blowing fuses then it requires repair.. I wish i had better news but thats all it can be...

Aug 20, 2007 | Scosche Industries Scosche High...

1 Answer


Go to this website page and see if any of this applies to your problem.

Aug 11, 2007 | Lanzar HTG244 Car Audio Amplifier

1 Answer

My vibe 286 4000 watt lanzar amp wont stay on..

Check your speaker load. It probably should be 4 ohms per channel. Also, if you are bridging then you must double your ohms load. It may be that your old amp could tolerate a lower impedence (ohms load) than the new amp. Do this now so you don't fry your amp. Good luck.

Mar 03, 2007 | Lanzar VIBE266 Car Audio Amplifier

Not finding what you are looking for?
Lanzar VIBE266 Car Audio Amplifier Logo

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lanzar Car Amplifiers Experts

Joe Alexander
Joe Alexander

Level 2 Expert

64 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Are you a Lanzar Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides