Question about Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

P3001 amp may be fried

About a week ago i bought a P3001 amp, got it installed by a friend at bestbuy, anyways i have 2, 10" alpine type E subs, and when i hooked the amp up and started her it would blow the fuse on the amp once any power hit the subs. We went through about 7-8 fuses rewiring, bridging the subs etc, finally we tried another Sub, a 12" sony sub and it wouldn't blow any fuses but there wouldn't be any power going to the sony sub, unless we played around with the cable from the sub to the amp. So i bought a Lightning audio 600W max amp, which is grossly underpowered for my subs, anyways it all works fine right now, but i can't turn up my subs at all. I have my P3001 opened up but theres no defects that stick out right away, I'm wondering if this is fixable or if i should just buy a new amp altogether?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 148 Answers

Check this out: http://www.techlore.com/article/14696/

Posted on Aug 17, 2006

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just installed a new xo vision x349nt dvd receiver in my car . My rockford fosgate p3001 amp turns on but the subs doesnt come on but when i would take the base control out and put it back in i can hear...


Make sure and check the RCA wires in the back of your radio that send audio to the amp and make sure that they're connected to the OUTPUT/SUBS RCA's and not an input rca's. Also, check your ground and make sure no speaker wires in the subs are shorted. Try one speaker at a time see if that helps.

May 18, 2011 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

I had Rockford Fosgate P300-1 Amplifier installed professionally with a Kicker CVR10 10 in Subwoofer in 2010 Comaro. My problem is that it causes an odor in my car. I took it back to Mothers window tint...


your kicker cvr subwoofer should have a max power of 1600 watts therefore your amp is not too much for the sub because the p300-1 amplifier has a max output of 900 watts. if anything your amp would not be enough to produce max power out of your subwoofer. your sub should not produce an odor unless you have your amplifier bridged which doubles the watts pushed to your subwoofer and if that is the case your amp is pushing 1800 watts to a 1600 watt sub which could be causing it to fry or possibly blow soon. other than that if thats not the case there shouldnt be a problem.

Dec 31, 2010 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

P3001 problem


if amp is mounted to back of the box try and move to in front of box near subs or port. the air movement of the sub will help keep the amp cooled. or you can orer some 12v cooling fans and take back plate of the amp and cool it that way. or you can buy higher quality audio, your choice

Feb 20, 2010 | Rockford Fosgate P3001 Car Audio Amplifier

3 Answers

How do I hook up one sub to my rockford fosgate p3001 amp


Hey i have looked over many rockford manuals,(i own a 300.1 my buddy owns a 325.1) and for there mono(.1) amps there hooked together on the inside so channel A+ and B + are cencted on the inside the amp. So you ither hook one 2ohm sub to channel A or you can hook 1 4ohm subs to channel A and 1 4ohm sub to channel B. There 2ohm stable so any lower will eventualy burn the amp out.

Jan 08, 2010 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

I have 2 alpine r type 12's hooked up to a kicker crossover and a NRG 2200 800 watt amp. they are wired series and parallel. when i turn it up the subs sound like the are fluttering. what is going on.


well my friend either your amp is not powerful enough to push your subs or you have a sub that is shorting out cause i just had the same problem with my 2 15 kicker cvr competition subs

Nov 04, 2009 | Alpine Type-R SWR-1242D Car Subwoofer

1 Answer

Hello i just recently bought alpine speakers for my eclipse 2003


mostly because the subs in the back are probley using more amps than the ones in the front in the front should be used mostly for vocals and your bass in the trun so maybe trying to unhook the ones in the front from the sub and just leave then hooked up to the cd player where you can hear the vocals really good and leave your subs in the back hooked up to the amp

Jul 27, 2009 | Alpine SWS-1223D Car Speaker

2 Answers

System Cuts Off


your amp is tripping out because the subs a drawing to much power get a better amp alpine subs demand a lot of power try a high current amp

Jun 30, 2009 | Alpine Type-R SWR-1222D Car Subwoofer

1 Answer

What Hz do i use


The best way to set up an amp is to start with everything on 0 Turn your gain all the way off, then turn the stereo up as loud as u would normally listen to it. With the stereo on, slowly turn the gain up until it sounds the way you want it. As for the Hz settings, for a sub you should have the crossover set to lpf, and the z knob adjusts what frequency your sub will play. Since you have a 10" sub, I wouldn't put it much below 125, because tens can't produce ultra low bass and it could damage the sub. Hope his helps :)

May 02, 2009 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

Sub cutting out


Check the 12v wire running from the battery to the amplifier. Also the sony explode is a garbage subwoofer compared to the Alpine.. sony (they say 1200w max but its more like 100w to power the thing) Amp could be going. Is the amplifier hot when running. If there is a burnt smell comming from the amp, its the amplifier

Mar 27, 2009 | Alpine Type-R SWR-1222D Car Subwoofer

Not finding what you are looking for?
Rockford Fosgate P3001 Car Audio Amplifier Logo

Related Topics:

342 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

seankane89

Level 1 Expert

54 Answers

Mike Duncan
Mike Duncan

Level 2 Expert

219 Answers

Marvin
Marvin

Level 3 Expert

83940 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...