Question about Abit Computers & Internet

1 Answer

Motherboard won't boot past cmos

I have a Abit motherboard model #SG-80DC which I'm certain is causing the computer not to boot past the bios test screen. The computer is a white box special running a Seagate Barracuda 7200 rpm 80gig ide hard drive. Ram is supplied by 2x1gig of Kingston Hyperx(KHK3200A). The cpu is a dual core pentiumD. Tried the ram, hdd, optical drive in an identical setup and each performs its job.The unit sat for almost two years. Before taking its nap it ran fine. Almost positive the bios is corrupted. .

Posted by on

  • Bill Freedman
    Bill Freedman Feb 08, 2012

    Prathamesh,

    I've tried each removable part, piece by piece and in total in a similar computer. Each time with the same result. The PC won't go past the cmos screen. No blue screen, the monitor is receiving a signal, it won't go past the bios screen. I tried a "fix" on an earlier post. When the Windows screen reads,"do you need to install a raid or sata..press F6" the post suggested pressing F5 and a sub-screen would appear and a fix could be found. Not for me! I've downloaded a much later version of the bios firmware. Now, I need step by step instructions, how to flash the firmware to the motherboard.

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 31 Answers

You are pretty much right it may be a corrupt bios, however before we come to a conclusion try isolating both Seagate Barracuda 7200 rpm 80gig ide hard drive and optical drive only and then see if it at least goes past the bios screen, if yes then the bios is ok and just needs to be resetted to defaults. dont expect it to load windows even if it goes past bios check as hard disk which helps to boot to windows would be removed. also in case if you are using 2 ram slots try connecting only 1 ram chip in 1 slot and then see if it goes past the bios test screen. do reply with results. Good luck.

Posted on Feb 08, 2012

Testimonial: "Based on Prathamesh's diagnosis I'm going to flash the motherboard with a latter version of its firmware."

  • joecoolvette
    joecoolvette Feb 11, 2012

    When you do, make SURE you use the option to save the old BIOS also. I would also like to ask; Have you checked the Electrolytic Capacitors on the motherboard, for visual signs of failure?http://www.capacitorlab.com/visible-fail...

×

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad
bunnydawg
  • 5158 Answers

SOURCE: I WANT TO KNOW WIRING

everything you need should be here

http://www.abit.com.tw/page/en/motherboard/motherboard_detail.php?DEFTITLE=Y&fMTYPE=LGA775&pMODEL_NAME=SG-80DC

Robert

Please take a moment to rate this solution.. thanks

Posted on Jan 21, 2009

  • 35 Answers

SOURCE: I am looking for the driver for my ABIT SG-80DC

You can find the drivers for you motherboard HERE.

Posted on Mar 10, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sg-71 motherboard it's no playbacksound


http://drivers.softpedia.com/get/MOTHERBOARD/ABIT/Abit-motherboard-SG71.shtml

Dec 22, 2012 | Abit SG-71 Motherboard

1 Answer

I got trouble on the BIOS setting of my Abit SG-72 board. I reset CMOS and then I can't boot anymore(No screen). There are a long beep, two short beep. Why?


You could try removing the video card and re-seating it. It looks like a video problem.
Try reset bios by jumpers.

If this helps orsolves the issue, please rate it and give a testimonial for myresponse.

Feb 26, 2011 | Abit SG-72 Motherboard

1 Answer

My sound system is not working...my sound driver is not working on a my new window 7 ultimate


make a sure that you have the correctly driver, check with everest ultimate software

Aug 05, 2010 | Abit SG-80DC Motherboard

2 Answers

Cant find a 9pin usb location on this board


It is located just beside the outermost Pci slot. I can provide you better picture, i don't have another photo of this motherboard, but somehow it may help you. f85d7e1.jpg
Good luck..

May 19, 2010 | Abit SG-80DC Motherboard

1 Answer

I looking for motherboard system AC97 ,


http://download.cnet.com/Realtek-AC-97-Driver-Windows-98-Me-2000-XP-2003/3000-2120_4-10238712.html

Oct 05, 2009 | Abit SG-80DC Motherboard

1 Answer

No sound,please help!!


try to download the sound driver from here  http://74.125.153.132/search?q=cache:http://www.sis.com/products/sis661fx_benefits.htm  . if it fails again then try to install windows xp with sp2 not sp3 ok.

Jun 14, 2009 | Abit SG-80DC Motherboard

1 Answer

VGA Error


I'm thinking that you might be getting an error that infers that you should have a higher service pack for windows. It's up to SP3 now.
Also, not seeing the original question, have you installed all the most current motherboard drivers for that computer?

Mar 10, 2009 | Abit SG-80DC Motherboard

1 Answer

Abit sg-80 1.0 bios driver


go web site dl bios make floppy show su on site how to do it or maby flash tool tanks nick

Oct 10, 2008 | Abit SG-80 Motherboard

Not finding what you are looking for?
Computers & Internet Logo

Related Topics:

1,031 people viewed this question

Ask a Question

Usually answered in minutes!

Top Abit Computers & Internet Experts

Alun Cox

Level 3 Expert

2678 Answers

David
David

Level 3 Expert

781 Answers

Jerry Umali

Level 3 Expert

979 Answers

Are you an Abit Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...