Question about Car Audio & Video

Open Question

Vr3 200watt amplifier red light problems

Red light stays on.... running 8 gauge good ground to frame of care (sanded paint off) good fuses i get nothing when i bridge the 2 channels when i use channel 1 i get random feedback still a red light though. i dont know what to do from here... iv tried all the basics

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: reality vra2.0 works fine but doesnt work fine

The built in cross over sounds fried.

Posted on Mar 26, 2007

Cerfer39
  • 709 Answers

SOURCE: confused

Hi jimmyjames,

 

How do you have the wires hooked from the sony reciever to the inputs on the mtx? 

 Sounds like your Remote wire is way too big. it should be 14 guage.  It only sends a low voltage low amp signal.

 

Another thing that could be messing up the sounds is the routing of the wires.  you should have the power supply wires separate from the Audiop signal wiring.  Power should run down the Driver side and Audio down the passenger side.

 

When you answer I may be able to tell you more.

 

Posted on Oct 19, 2007

pjstanley
  • 185 Answers

SOURCE: QSC 2450 Power amplifier

i have a pyle pro 1000 watt max 2 channel mono and 2 channel stereo and when i get that thing loud the little red light cums on basically what i mean is that the amp on channel one is cooked i myself i wouldn't even use it y cause more damage

Posted on Apr 07, 2008

  • 631 Answers

SOURCE: Amp Power light will not go on. Protection light is lit- Thump sound in speakers

It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Posted on Nov 02, 2008

  • 149 Answers

SOURCE: jl audio 1000/1 low voltage -keeps shutting off at high volume

You should definitely upgrade the power wire to the sub amp to 4 gauge -absolutely your choking your amp its starving for current-poor thing is starving !!!!!!!

Posted on May 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Red and blue light stays on but it cuts on and off, what's the problem? It comes on and works but the red light stays on along with the blue light..when the speaker cuts out, it acts like its trying to...


hi there
The reason for this is the ground is weak to the amp make sure that the post that your ground wire is screwed down to is tight also make sure that is touching bare metal if there is paint on bottom side use wire brush to get the paint off so it is bare metal a weak ground can mess the amp up and make it not work at all hope this helps you have a wonderful day

Aug 23, 2011 | Kenwood KAC-7204 Car Audio Amplifier

1 Answer

When i try to ground my amp the red light stays on i tried diffrent grounding areas and it flickers on but than turns red again. how do i keep it grounded


A proper ground should be a solid connection to the vehicle chassis in a PAINT-FREE location (the ground wire should be connected to an exposed part of the chassis, meaning it should be metal, not plastic or carpet). You may have to sand down the place you plan to ground the wire to in order to get the paint off. Make sure it is connected to the chassis though, it will not be sufficient to find any random metal part to connect to. To actually connect the wire, drill a hole through the metal surface and put a nut and bolt through the hole, pinning the ground lead under the bolt. Also, be sure not to drill through anything important (gas tank, electrical wires, fluid tubes/pipes, etc).

Mar 07, 2011 | Formula MACH5000 Car Audio Amplifier

2 Answers

Everything did work but kept blowin fuses by the battery. Now a red light stays on, on the amp & the blue/green power lights dont *** on. What should i do?


Check all of your power connections, your speaker connections and battery connections. if all are good and clean (no shorts/wires touching) then try unhooking your speakers and see if the lights come back, if that helps then you have problems with your speakers, if not then amp is bad. I hope this helps ya.

Randy

Feb 17, 2011 | Phoenix Gold Titanium 800.1 Car Audio...

1 Answer

Need a wiring diagram for a american pro 1406


Very simple :

12V+ = Red 8 Gauge Wire to positive battery terminal with a 30 Amp fuse

Ground = Black 8 Gauge wire to non painted surface on chassis of car.

Remote Turn on = Blue / white thin wire from radio's blue/white , this will turn on your amp.

A set of RCA cables which are self explanatory. Out to In or In to Out
Radio to Amp under carpet to back of vehicle along with your blue wire.

Then you have your speaker wires, you hook these up to your subwoofers.

Hope this helps, good luck.

Lex..

May 21, 2010 | American Pro VS1406 Car Audio Amplifier

2 Answers

I just installed a sony xplod 700 watt 4 channel amp and i was driving and my sound just went out, I could see that the deck was still playing and eq was still jumping but no sound, I checked the amp and...


loose connection to the power line and or ground. ground good be grounded poorly. best ground is to scratch the paint off the car frame under the carpet in the trunk and put a eyelet on the wire and screw it to the frame.also check your inline fuse on the power line from the battery if you dont have one you should. and also make sure you are using the right gauge wiring for your amp,

Mar 23, 2010 | Car Audio & Video

1 Answer

My amp is the zrs1502 and the protectant light keeps coming on what could that be. every time the bass should come in the red light com on


check your ground wire. if it is grounded to a painted section of the body of the car, then sand it down and ground it to bare metal.

Feb 15, 2010 | Cadence Z9000 Car Audio Amplifier

1 Answer

I think i have a bad ground i smell voice coils after its only played a short while


More than likely yes. Just make sure that you have it grounded to the frame and you have sanded of the paint were you have it grounded.

Oct 20, 2009 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

The protection light stays on and the ground is hooked up, the power wire is hooked up, the speaker wires are good, the audio cables are good, the remote wire is good. but the light stays on when the radio...


The ground wire must be bare metal to bare metal and it must be tight. If this is new installation I would start by looking at the spot where the ground wire is bolted to the frame. If the paint on the frame was not removed in that area, remove it and reattach the ground wire.

Apr 11, 2009 | Power Acoustik PS4-800 Car Audio Amplifier

1 Answer

Jenson a300hlx 300 watt amp


DISCONNECT THE GROUND WIRE. SAND ALL THE PAINT FROM THAT AREA AND REGROUND IT. WHAT I WOULD RECOMMEND IS DRILLING A HOLE THROUGH THAT TRUNK, SAND THE PAINT AWAY FROM WHERE THE GROUND WIRE WILL GO AND BOLT THE GROUND WIRE TO THE TRUNK BOTTOM. THE PAINT WILL CAUSE THE AMP NOT TO GET A SOLID GROUND

Feb 21, 2009 | Jensen A300HLX Car Audio Amplifier

1 Answer

JL Audio e1200 Red protect light on


it sounds like you have a bad ground make sure its on the frame or body and any rust or paint is scraped off

Feb 11, 2008 | Jl Audio E1200 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...