Question about Craftsman 17.5 hp 42 in. Deck Lawn Tractor - CA Model

1 Answer

I have replaced my battery twice inthe last few months. I have replaced the starter and the starter selonid and the cables are clean and tight. When I try to start it The starter drags and it blows the ignition 20 amp fuse. What should I do ?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Craftsman Master
  • 76,673 Answers

I would suspect the starter is not grounded properaly or the engine is not properly grounded, run a new calbe to the engine from the battery negative post.

Posted on Feb 06, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Starter problems, Suggestions???


Starters tend to fail intermittently. Yes, if it started after a "whack", I woul suggest replacing your starter. Make sure all connections are tight and of course clean terminals and cables.

Sep 03, 2016 | Cars & Trucks

2 Answers

TRIED TO START 2002 DYNA LOW RIDER. turned key on,run switch to run and hit satr it turned over and fired once then nothing ,did not click or turn over when hitting start. waited a while and tried again...


Make sure battery has a full charge and both positive and negitave battery connections are clean and tight.Make sure unit is in nuteral and try to crank. If engine wont crank check starter selonid or relay. MAKE SURE BATTERY HAS A FULL CHARGE.

Mar 16, 2014 | 2002 Harley Davidson FXDL Dyna Low Rider

1 Answer

Yukon battery drainHave a 2012 Yukon SLE, twice now in the last three months the vehicle won't start after running into the convenience store. Won't jump start on the battery side of the mega fuse, have to...


Have the batter load tested as there may be a faulty bridge inside the battery. Never jump start from any point other that the battery post positive with the negative cable attached to the engine If you continue to jump the way you described then sooner or later you will cause a power surge which will fry the CPU.. Check all cables are shiny clean and tight all the way from the battery posts to the starter.

Feb 09, 2014 | 2012 GMC Yukon SLE 4dr SUV 5.3L V8 FFV...

1 Answer

1999 Buick Lesabre, won't start, good battery power, only clicks when you try to start it. Just started, no indication of a problem leading up to this. Made sure vehicle was in park and also tried...


STARTER SELONOID OR DIRTY BATTERY CABLES OR LOOSE CONNECTION ON STARTER.iF YOU REPLACE STARTER REPLACE WITH COMPLETE UNIT NOT JUST SELONID GOOD LUCK.PS BE SURE BATTERY IS UP TURN LIGHTS ON AND HAVE SOMEONE WATCH THEM AS YOU TRY AND START TO BE SURE THEY DON`T GO OUT IF THEY DO--- GO TO CONNECTIONS ON BATTERY OR TRY JUMPING GOOD LUCK

Jul 23, 2011 | 1999 Buick LeSabre

1 Answer

Will not maintain electrical charge. It works fine for a few months and then one day it has no power to start the engine. I hook up jumper cables and it instantly has power to hood light door beepers etc....


Check that all battery cables are clean and tight.

Check the date/age of battery, and compare to the rated life of the battery. If anywhere near the end of the rated life, suspect the battery. Suspect battery if all terminals are clean and tight.

Dec 21, 2009 | 2000 Jeep Grand Cherokee

1 Answer

In the last 6 monthes the car has breakdown in front of stop sign, and the battery icon shew on the panel, then I shift to "P" and off ignition, then I start again and shift to "D" and the car running away...


Replace the fuel filter first thing. Remove the battery cables and clean the cable connections and the battery connections. Check all electrical connections under the hood to insure they are tight and secure. Look at all wiring for any wire that may be shorting out as in a bare wire touching metal.

Nov 10, 2009 | 2003 Cadillac Deville

1 Answer

1998 Acura. Wants to start. Replaced battery 6 months ago. Clicking,lights on dash flashing. Eventually it starts after quite a few tries 130.000 miles. I have never really had any maintenance done tune up...


do a tune up. replace the spark plugs, spark plug wires, air filter, pcv valve, clean up the throttle body plates, clean the mass air flow sensor that comes from the throttle body to the air filter assembly. Check your positive and negative battery cables. Make sure the cables are clean and tight on the battery and the grounds and also the starter relay on the starter as well.

Oct 12, 2009 | 2004 Acura TSX

1 Answer

A month ago I bought A used 2000 elantra it used to start fpr the first try In the same time I changed the engine oil and Trying to put a good battery when I finished it did not start.


Verify (test) the battery is good/charged. Verify good, clean cable connections (positive & negative, correct polarity). Inspect positive and negative cables for loosness (positive cable condition to starter connection - clean/tight) negative cable condition to ground connection clean/tight). Replace/repair/clean/tighten cable(s) as needed. Did you remove/disconnect any components from the engine when you replaced the battery? If so, did you remember to put/reconnect them back?

Apr 22, 2009 | 2000 Hyundai Elantra

1 Answer

I took the HOTT battery cable off and put it back on and now it will only click i think its the starter relay its a 2000 mercury sable 24v


First clean your cables and the posts on the battery make sure they are tight and clean also check the positive cable going to your selonid it could be loose and at the starter

Mar 17, 2009 | 2000 Mercury Sable

Not finding what you are looking for?
Craftsman 17.5 hp 42 in. Deck Lawn Tractor - CA Model Logo

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Craftsman Garden Experts

Wade Mobley
Wade Mobley

Level 3 Expert

475 Answers

Dean Gruber

Level 2 Expert

110 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Are you a Craftsman Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...