Question about Sterling Audio ST59 Microphone

Open Question

My sterling audio St59 has a lot of static on my imac os x connected to digi design mbox 2. How can I decrease the static?

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Pt wont see my mbox


need driver for ct4670 sb!tnx!

Oct 09, 2009 | Digidesign Mbox External Sound System

1 Answer

Mbox2 mini digidesign buzzing


Are you running passive speakers if so try using a ground loop isolator this should stop any noise interferance.

Jan 22, 2009 | Digidesign Mbox External Sound System

2 Answers

HELP!!Setting up my Mbox1 as general sound output in my mac!!


I've had the same problem. I got it to work using Soundflower and LineIn.
Soundflower:
http://www.apple.com/downloads/macosx/audio/soundflower.html

LineIn:
http://www.versiontracker.com/dyn/moreinfo/macosx/18987

After installing soundflower, it should show up like a virtual soundcard in your sound prefs. Send your audio output to the soundflower 'card' in sound prefs. Then use LineIn to route the outpout from soundflower to the Mbox like this:

Input from: Soundflower (2ch)
Output to: Digidesign HW ( Mbox )





Dec 28, 2008 | Digidesign Mbox External Sound System

1 Answer

Macbook pro does not detect digi 002 rack


yeah i have an intel imac and had the same problem. I upgraded to pt le 7.4 and now pro tools recognizes the 002 rack and it works fine, but still the core audio manager does not recognize the hardware. It says in "use" when I first turn on the 002 rack, then it says not connected after about 20 seconds. I don't think this really matters though because I have beeen able to do everything fine without having the core audio managr recognizing the 002 rack. I hope that helps

Dec 04, 2008 | Computers & Internet

1 Answer

Mbox


This means that your firmware on the Mbox and the drivers need to be updated. I had the same problem afte updating my protools from version 6.7, Did you recently do any protools upgrades? You can go to Digidesign>My Digi>downloads>Mbox>firmware updates or>driver updates

Oct 17, 2008 | Digidesign Mbox External Sound System

1 Answer

Mbox problem (no input,output)


i'm running os 10.5.6 w/ protools 8.0 and the original mbox. i had the same problem. protools opened and seemed to work except there was no sound from either analog outputs or headphones. this worked for me:
1. shut down computer
2. unplugged all usb cables except keyboard/mouse
3. restarted computer
4. re-plugged usb cable from computer to mbox
5. opened protools session
6. hit play and now i'm hearing sound and everything seems normal.

i hope this helps everyone else

Oct 03, 2008 | Digidesign Mbox External Sound System

2 Answers

Digidesign Mbox on Vista


same here but when i pull up protools the mbox does not power on !!I have the imac g5

Jun 21, 2008 | Digidesign Mbox External Sound System

Not finding what you are looking for?
Sterling Audio ST59 Microphone Logo

Related Topics:

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sterling Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

The Knight
The Knight

Level 3 Expert

74473 Answers

Are you a Sterling Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...