Question about Electrical Supplies

1 Answer

Sears 4000W 8HP doesn't idle up under load

I bought this unit about 1992 from Sears and worked fine until recently. Now it will idle but only puts out proper voltage under load when it is manually adjusted for engine speed. The linkage to the carb is ok and throtle on carb works fine.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 169 Answers

I posted an answer to a similar question here. You probably have a broken current transformer or a bad idle control board.

Rate me?

Posted on Dec 03, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I get a powermate 8hp brigs and Stratton generator to idle. I bought it and it wouldn't start. I cleaned the carb and it started on 1st pull, now it won't idle it run wide open all the time.


You have jet clogged, or still some obstruction in the carb. Hopefully you have a good inline filter .I'd take it back apart all the Jets and seats & Chem soak or a cheap complete rebuild.

Feb 09, 2016 | Coleman Powermate 4000 Watt Generator...

1 Answer

I have a eu 6500is generator inverter that will run perfectly for any amount of time, then with no warning just stop generating and idle. No overload alarm. No oil alarm. Nothing will just idle. If you...


this sounds like a capasitor/resistor that is getting hot under load once it is switched off and cools down it works until it gets hot again similar to that of a cars ignition coil which will get hot and cut the vehicle out but once it cools it will start again.

Dec 07, 2013 | Honda EU6500iS Inverter Generator

1 Answer

My Woolf 900 generator starts fine initially. When put on load (600w) it is reluctant to get up to speed (45secs) but eventually gets there. When load is taken off it doesn't go back to idle and event


Does it have and automatic idle? If so cut it off and see if engine can run at 3600rpm no load. If still stalls, your jets(brass tube) have something blocking holes and carb needs either a real good clean in a dip, rebuilding, or replacing.

Jul 09, 2013 | Electrical Supplies

2 Answers

Honda EU3000is. 2 year old unit used by electric start at least 5 days a week. My gen has recently stopped staring by the electric start, it turns over but just not as strong as when new, what i mean by...


I have a 5 year old EU300is that would not start with or without the battery. I went through all the usual such as gas, plug, oil, etc. The battery showed 12 volts, however, when tested further it would not hold a load. I bought a new American made battery and now the unit runs fine.

Jan 29, 2011 | Honda 6370C - Parallel Power Kit For ...

1 Answer

Have a EB5000X generator which has staring problems, aprx 8 yrs old and not used a great deal until hurricane Ike came thru here and it ran for several days with minimal down time. Afterwards I changed the...


If I understand the problem correctly, it runs fine after you cleaned the carb, but the auto idle will not engage when you put a load on it. First if it has a switch to turn the auto idle off try that. if it does not rev up, then the magnetic controller is stuck. There is a magnetic coil which is connected to the throttle and this either pulls or releases the throttle when load is applied. My guess is that this is hung up a bit. Look for a small round coil with wires coming off it that is connected to the throttle assembly. You could also try tracing the wire from the auto idle switch backwards. This may just be stuck in the idle position by corrosion. especially if you live in a humid area or one near the ocean. gently try to work it a bit by hand (when the generator is not running) and try a bit of wd40 or the like.

Jan 02, 2011 | Honda Mmd 5000 Watt Electric Start...

2 Answers

Eu2000i lopes while idling. If i slide the choke


This is NOT uncommon when no load is on the units.

The "gain" of the govenor is designed for maintaining speed under load and will "hunt" a bit without a load on the unit.

Apr 02, 2010 | Electrical Supplies

1 Answer

My yamaha 2400 gen.does not run smooth at idle, but under a load it runs fine.


I'm not quite sure if your issue may relate to most inverter and auto-load sensing generators or some gas-powered equipment.
Most power cutters/grinders such as Stihl or Husqvarna, specially the higher cc models do sound crappy without load, you'd think there's something wrong with it from day 1. This is normal. Well, some of these machines lack the load sensing capability thus does not adjust throttle variably according to load.
Modern generators, specially the inverter ones along the 1000 to 3000 watt range where the Yamaha 2400 falls into category, have a switch where you can choose to let the unit sense and adjust throttle according to load. If this is off, the unit might sound like its not running smoothly on idle. Depending on you, this can be alarming or not. On a Honda EU2000is, for example, it is noticeable when the auto-load sensing button is off but not be like its choking or sputtering.
Anyhow if it is idling roughly, I can only come up with 2 possible causes, if I may suggest:
1.) the cable that gradually pulls the throttle (to open wide or close) on the carburetor - normally called governor cable (although it has different configurations on different engine types) needs to be adjusted/tightened. Or replaced, if worn out. Before new cable, put lithium grease on cable - it helps a lot.
2.) throttle adjustment might be necessary. At most Yamaha servicing dealers, it is included when you have a carburetor tune-up. They will check the diaphragm for blockage or holes, gaskets for leaks and filters, well, the entire integrity of your carburetor. This resolves most rough idling issues.
I know it would probably save you at least $65.00 if you have to check this yourself and buy the spare parts. However, going to a servicing dealer may be the best solution but always be sure the repairs are warratied. Hope this helps.

Aug 16, 2009 | Yamaha Electrical Supplies

1 Answer

Coleman Powermate only puts out 110V


If you haven't seen it yet, here is a page that may help with a manual or parts list.

This problem sounds kind of bad, generators don't do well when the engine stops under load.
Start by checking the circuit breakers in the distribution box (outlet panel) - you need ot do this with an ohm meter. After that check the power windings of the stator with the ohm meter, be sure to check between the 2 windings (should be open), and from each one to ground with the winding isolated.
Whining, a burning varnish smell, and breakers that trip all the time are indicators of long term overload problems. This could happen if you had most of the load on one winding for a significant amount of time, or if the one winding mostly powered motor-like loads with high startup currents.

You may want to look at this answer I posted some time ago.

Regards,
Carl

Jan 06, 2009 | Coleman Powermate Powermate 5000W...

1 Answer

Yamaha ef1000 will only idle and produce 12 vac


Hi, I have the same generator and I pull the load and it is fine. The engine RPM is controlled by the 
governor. The voltage will not come up until the RPM is at full. First see what the RPM problem is and then check the voltage. Open the cover and look to see if the carb linkage is hooked up , if it is you mite have carb problem and address that first. Hope that helps.  

Dec 17, 2008 | Yamaha 2500 Watt Industrial Inverter...

Not finding what you are looking for?
Electrical Supplies Logo

Related Topics:

138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrical Supplies Experts

Steve

Level 3 Expert

3287 Answers

ken skalski

Level 2 Expert

150 Answers

Gene Haynes

Level 3 Expert

5080 Answers

Are you an Electrical Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...