Question about Infinity 7540A Car Audio Amplifier

1 Answer

No sound when my amp first turns on all three lights blink in a row for maybe a minute. Then the clip light stays on fo another minute. Then the power light stays on but i cannot get any sound. i am trying to run 2 sets of component 6 1/2s off of it. I did everything myself so there is a chance i screwed up somwhere. i ran a 4 wire from the battery to the back with a 100 amp fuse. That goes to my distribution block and i have a 8 wire coming out of there to the amp. the block has a 50 amp fuse. Reason fo all that is future amp. my ground wire is installed under the seat belt in the back with the paint scraped away. I feel i did everything right but apperently not. One more thing i got the amp used but was told functioned 100%. I am hoping i did not get jerked. Pleas help....

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers
Re: no sound

I would try it without the slot for the additional amp. However, there is a chance that it is fried. When its powering up I would check the voltages with a multimeter to make sure everything there is in order.

Posted on Jul 02, 2006

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Amp never shuts off and protect light will come on when turned up

Just to make sure I understand you, when the protect mode turns on the amp still stays on? If so my guess would be that you are pushing the subs so hard that the amp is just starting to clip (distort) because you are pushing either the amp or the subs or amp and subs to their limits. Clipping is not a good thing, but at the same time it usually sounds the best just before clipping. You may need larger gauge wire or a capacitor to help the amp get higher voltage. I will post a link on clipping.

I'm not sure this is your problem just my guess.

Hope this helps.

Feb 17, 2011 | Orion HP4600 Car Amp

1 Answer

Pioneer GM-7200M power problem

Check your GROUND wire might be touching something and making bad contact.

Jun 09, 2009 | Pioneer GM-7200M Car Audio Amplifier

2 Answers

Three blue lights blink

check you speakers and power source make sure all connection is correct

May 26, 2009 | JBL CS300.1 Subwoofer Mono Amp - 200W CS...

1 Answer

Amp keeps kicking off

hey unplug your amps and waiting 15 minutes and plug them in...the amp went to protect mode to keep it from blowing...should work unless you have a amp that only the factory can reboot but most amps just reset themselves if you do what i just told you

Apr 06, 2009 | Eclipse (EA2000) Car Audio Amplifier

1 Answer


Overload maybe. If the amp is run at an improper impedence, the amp will shut down. If you are "CLIPPING" speakers / subwoofers the light will blink to indicate a hard clip . Example: 4ohm/2ohm stable amp with 4 ohm subs wired at 1 ohm.

Jan 28, 2009 | Infinity Reference 7541a Car Audio...

2 Answers

JL 300/2 v2 Power Light Blinks, No sound out of Sub. Works in friends Car HELP

Are you sure you don't have any shorted wiring or defective speakers?

Sep 30, 2008 | Jl Audio 300/2 Car Audio Amplifier

1 Answer

QSC 2450 Power amplifier

i have a pyle pro 1000 watt max 2 channel mono and 2 channel stereo and when i get that thing loud the little red light cums on basically what i mean is that the amp on channel one is cooked i myself i wouldn't even use it y cause more damage

Apr 03, 2008 | QSC RMX-2450 Car Audio Amplifier

3 Answers

Problems with Infinity Amp 611A

are you running a large ground wire directly to the battery negative terminal?

Jun 03, 2007 | Infinity Reference 611a Car Audio...

1 Answer

Clip light

A shorted speaker, a pinched speaker wire or a short in the amp, itself. Try to disconnect the speaker wire from the amp. Did the clip light go out? No?? Ok take out the amp and send it to the service center as unless your a tech, there are no user serviceable parts inside as its all solid state. Good Luck

Jun 30, 2006 | Infinity 7540A Car Audio Amplifier

Not finding what you are looking for?
Infinity 7540A Car Audio Amplifier Logo

Related Topics:

209 people viewed this question

Ask a Question

Usually answered in minutes!

Top Infinity Car Amplifiers Experts

xxxxxx xxx

Level 3 Expert

4679 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Terry Ive
Terry Ive

Level 1 Expert

11 Answers

Are you an Infinity Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides