Question about Audio Players & Recorders

Open Question

Amplifier how to plug speakers inn technics suz1

Icant plug inn speakers technics suz1

Posted by on

1 Suggested Answer

  • 4234 Answers

SOURCE: Technics SU-G95 Amplifier and no sound on left speakers

Usually this is a defect in the output amp IC. If you have no experience with repairs of these types of units, have it checked by a service shop. If the output AMP IChas failed, it will cost about $75 for a replacement. This unit uses an RSN3306P IC .

Dan

Posted on Mar 15, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speakers for Technics SU X933?


check given link for speakers
http://www.fixya.com/myhome.aspx#Answers

Jun 05, 2012 | Technics SU-G75 Amplifier

1 Answer

Hi I just got a Technics SU V2 amp and can't get sound from the speakers. What size speakers would suit this amp? What is the correct method to connect the speaker leads to the back of this amp,...


Being a 500W amplifier, you need to connect speakers with 300W each. The correct method to connect speakers is red terminal of speaker should be connected to red terminal of amplifier & black to black. The left side to left side speaker & right to right speaker. There may be main & remote terminals. Main speakers are the speakers at local place of the amplifier & remote for remotely placed speakers. I do have Technics SU-V85A which is somewhat similar. Enjoy! A nice piece to listen.

Oct 22, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

My su-g95 technics Stereo integrated amplifier wont play any noise. and when i adjust the volume it makes a popping/crackling noise. i am 100% sure all the speakers were hooked up correctly.


Well it sounds like your amplifier IC's are working correctly since you are hearing that pop. I have the same amplifier and every 10db increment it pops. Have you tried every input? Possibly try starting at a low volume, plug an RCA plug into CD or any other input, and touch the center prong of the other end of the cable. You should get a 60hz hum if your in the USA, otherwise it will be 50-55hz. Regardless it should make noise.

Sep 29, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

SURROUND AND CENTER SPEAKERS WORK FINE BUT NO SOUND COMING FROM FRONT SPEAKERS. WHAT COULD BE THE PROBLEM?


Can you fill in something about the speakers and how you have them attached? Since this is a stereo amplifier one wonders how you have anything but the front speakers powered unless you're using THIS amp for just the one pair and driving it from an AV receiver pre-out.

http://www.hifi-pictures.net/amplifiers-home/Technics%20SU-V500/amp.htm

What else is missing from this problem description?

Feb 02, 2011 | Technics SUV500 2-Channel Amplifier

2 Answers

Su-v55a technics amp cuts off when volume up to 2


usually meens it is protecting itself from destruction
check your wires and speakers for problems

Feb 09, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

Technics su-Z750 Intergrated Amplifier stays in Standby


HI...
This happens when one or more components in the power amplifier section has failed.

The protect circuit keeps large DC voltages off the speakers.

The only thing you can check for before finding a tech is that the speakers are firmly connected at both ends. If they are ok, you need a tech

PLease rate my help if this helps

Nov 05, 2009 | Technics Audio Players & Recorders

1 Answer

Technics Integrated amplifier su-v85a speaker volume fluxuates and speaker left shuts down some times what is the problem?


test you speaker maybe there is a bad connection some where is the spk. box its self ,try changing speakers left to right .
it the spk. are ok open amp see all the connections within the amp .
if this dose not work contact me by mail: starilaz@net.hr

Oct 12, 2009 | Technics SUV500 2-Channel Amplifier

2 Answers

Sound cuts when volume is turned up


check that power amplifier rating(how many watt)must be more than total speaker rating by 20% at least..
exampel:if speakers watts are 100 watt-amplifier watt must be 120 watt.

Mar 14, 2008 | Technics SUV500 2-Channel Amplifier

1 Answer

Technics SU-X955 amplifier. which speakers ?


Helo you have to use speaker of the same wattage you have now chage crossover to get new clear digital soud

Feb 11, 2008 | Technics SUV500 2-Channel Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

573 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

98796 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69745 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...