Question about Rockford Fosgate 800.2 Car Audio Amplifier

1 Answer

Rockford 800.2 I fried a 18" elemential designs DVC and now the amp stoped working and the ground wire melted the plastic coating about 4" from the terminal. thankx

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

What gage power wire are you running sounds like you need a smaller gage wire i have mine hooked up to a 4 gage wire and its working great

Posted on Nov 08, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rockford 801s.The ground terminal melted off but still worked when i disonnected it.


It's more than likely melted to the frame of the amp. Since it's melted, you really need to send it in to be fixed or pickup a new amp. It's VERY dangerous to not have it correctly grounded. It could potentially cause a fire.

Apr 19, 2011 | Rockford Fosgate Punch 801S Car Audio...

2 Answers

Amp worked fine one day and the next day i get nothing. the red light on the side is on but i dont get any sound. i took the subs that were wired on that amp and wired them on the other punch 800 i have...


did you check all fuses on amp and coming from battery power wire? also check the ground and rca cables connecting to the unit and make sure the remote wire (small blue wire) didnt come lose thats usualy a sign for the red light

Mar 26, 2011 | Rockford Fosgate Punch 800a2 Car Audio...

1 Answer

I have a 300 Watt dual amplifier connected to one 12" kicker dvc sub at 2 ohms. Every time the volume is turned up the protect light turns on. I had 2 of these kickers wired to a Rockford amp a week...


Then you have found your problem. It's internal on the amp. Protection circuitry issue. Have it Benched at a shop with the same impedance you are running it at. If it benches ok, check your ground, it should be no longer than 18" and go directly to the floor frame, not a seat bolt. You should also be running at least
4ga power as well. Hope this helps.

Jan 11, 2011 | Dual 300W Class AB Bridgeable 2-Channel...

1 Answer

Best way to connect a 15'' kicker cvr15 4 ohm dvc [single sealed box] and a volfenhag zx-4712 1000w 12'' 4ohm+4ohm dvc to my pyle 885 1000w 4 ch. bridgeable amp and how to wire the voice coils that are in...


best way is to just run the volfenhag with a set of wires for 2 channells(one set per coil) left and right @ 4 ohms per channell. The CVRs you can parallel the coils(2 ohms) and run a set from each sub to the amp in stereo left and right. This will give the kickers a little more juice than the 12 but should be fine.

Jan 25, 2010 | Rockford Fosgate Car Audio & Video

1 Answer

Audiobahn 15s smell and stoped working


google "subwoofer wiring diagram" that will help you out,....you put in how many subs, DVC, SVC, and the ohms of the subs.....good stuff to know b4 hooking up a system....hopefully you didnt fry your subs or amp.....let me kno.....

Mar 14, 2009 | DHD NTX-6612 Car Subwoofer

1 Answer

My rockford fosgate amplifier P500 blows fuses when i turn it on


Check your amps ground and make sure it has a clean connection to the chasis. If there is paint or any kind of coating where you are trying to ground, use a steel brush to expose the bare metal. Also, make sure you are grounding the amp directly to the chasis and not to another grounded wire.

Hope that helps.

Sep 22, 2008 | Rockford Fosgate Audio Players & Recorders

1 Answer

Quick question, amp problem


make sure you ground wires arent shared, meaning run each ground wire from each amp to its own grounding point

Sep 08, 2008 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

Amp stoped working


You need to run a larger power/ground cable. If you are reading low, you are not getting the kind of voltage that the amplifier requires to run, you may have been fine before adding the other products but if you wired them all to the same power wire (say an 8 gauge) you'd encounter problems. You should probably use a 2 gauge or at least a 4 gauge power kit.

Jul 09, 2008 | Pioneer 250WX1 360X1 800W MAX CAR AMP Car...

1 Answer

Sony xplod 500w 4/3 channel


If the speaker is a 4 ohm DVC (two 4 ohm coils), you can't wire it to get a single 4 ohm load. Try connecting one coil to each of the two rear channels. It may not be as loud but the amp should operate without going into protection.

If the two 4 ohm coils are in parallel, the amp is driving a 2 ohm mono load. That's probably why it's shutting down.

Apr 25, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Melted speaker wire


Whats the size of the wire? If they are too small they will melt and even catch on fire. Let me know.

Nov 01, 2007 | Rockford Fosgate 800.2 Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate 800.2 Car Audio Amplifier Logo

Related Topics:

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...