Question about Logitech Z-560 Computer Speakers

1 Answer

LOGITECH THX Z560 NO SOUND

First the subwoofer started cutting in and out, then all the speakers stoped and no power to the controls. I see on the back of the subwoofer it has a fuse. I do not see were the fuse is. Any sugestions.

Posted by on

  • 1 more comment 
  • Anonymous Nov 02, 2008

    Ican,t find the fuse.

  • vacujet Nov 02, 2008

    I can,t find the fuse holder.

  • dkksc Dec 17, 2008

    The fuse is inside. Remove the screws from the back, around the outside only. Pry it up and it will pop off. It is a bus fuse 4amp 250V. Disconnect the sub from everything. After I replaced the fuse I pluged it in. When I turned the switch on the fuse popped. At $50 an hour to repair I decided to replace the whole unit at a price for $80. Here is a link http://www.tigerdirect.ca/applications/S...

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Im having the same problem - where is the fuse

Posted on Oct 25, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Logitech X-530 subwoofer stopped giving power to other speakers. The system worked fine for the last 4 years and then the power button would light up some times and others I would have to hit the...


check the drivers click stat control panel administation tools computer management deivice manager scroll to sound video and game controllers could be a yellow question exclamation mark? ! or a red X right click to re-install drivers click start control panel sounds and audio volume advanced speakers make sure you have selected the correct speakers also audio you will find 3 drop down lists make sure you have the correct settings there if you dont have a motherboard disk you will need to download the sound drivers
check the leads attached to the rear of the input plugs make sure the connection is good
or you might have to clean the dust from your computer dust causes static which causes your computer to overheat and all sorts of problems
also if you had to hit the subwoofer to get it to turn on check all power leads attached the to and around the subwoofer
hope this helps


Aug 03, 2011 | Logitech X-530 5.1 Surround Sound...

1 Answer

Subwoofer sound only


Try agitating the controller (w/ the power button and volume control) and the speaker(s) that was out should immediately turned back on.

Aug 02, 2009 | Logitech X-240 Computer Speakers

5 Answers

Logitech THX Z-2300 Speakers Don't work and subwoofer does


Well, just because someone at Logitech said the speakers are definitely broken doesn't necessarily make it so. They told me the same thing, yet when I read on another forum that plugging earphones into the wired remote sometimes seems to make things better, I plugged earphones into the wired remote -- and Voila! All of a sudden the blue light went on and I had sound from all three speakers. The sound continued working properly even after removing the earphone jack. IMO the problem could be with the wired remote rather than with the speakers themselves. My speakers work again!

May 07, 2009 | Logitech Z-2300 Computer Speakers

1 Answer

Missing parts


i have the subwoofer but not the speakers and sound touch control center, wires or guides due to fact that they are stolen. could you help me fix this problem? i love the old one as i do not want to buy another system.

Jul 26, 2008 | Logitech Z-560 Computer Speakers

1 Answer

Subwoofers not working on Logitech R-20 speakers; worked until recently


There must be a control on subwoofer, like a volume control. Turn it and check it. Also check the connections.

Jul 17, 2008 | Logitech R-20 Computer Speakers

2 Answers

Repair of Z560 amplifier


try fixing its amps by simple reheating it. if still doesnt work try replacing its parts... it is certain that it has a prob on the amps.

Oct 14, 2007 | Logitech Z-560 Computer Speakers

Not finding what you are looking for?
Logitech Z-560 Computer Speakers Logo

Related Topics:

1,259 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

kakima

Level 3 Expert

98829 Answers

sonic boom...
sonic boom...

Level 3 Expert

1557 Answers

masterwest

Level 1 Expert

45 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...