Question about Aiwa HT-D780 System

1 Answer

Aiwa amplifier doesn't work

Please, help me to resolve this problem, the amplifier doesn't work, just the red light when we plug it in to the wall electrical plug. i think that the amplifier took to much sun, but it worked until we shut it down. Please tell me what's wrong and if i can repair it thank you very much

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers
Re: aiwa amplifier doesn't work

The amplifier circuit is not working trying repacing the ic

Posted on Jun 20, 2006

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Only red standby light comes on,Hit power button on remote, light goes out,unit turns off and have to replug into wall to get red light on.

There would be some problem in the output amplifier stage. Thats why its going to protection mode.
If you wish to get some details; check the site linked here. Pull up older posts.

Jun 18, 2016 | Home Theater Systems

1 Answer

Panasonic plasma flashing red light

Try disconnecting all of your HDMI cables and plugging the power cord of the TV into another wall outlet. If this resolves the issue, you may have had a small power surge from either your wall outlet or one of your source devices. It is recommended to connect your TV to a surge protector if you haven't done so already.

Sep 11, 2013 | Panasonic Silver Tilt/Tilting Wall Mount...

3 Answers

My bose cinemate 1 sr has a flashing red light and no sound. does not change to green light with sound.

This is a powered sub-woofer, with a complementary sound bar. The amplifier for the sub and the sound bar, are in the sub cabinet. Because there are multiple speakers in the sound bar and sub, there are multiple amplifiers to run them. If any, or all of the amplifiers are damaged, they generally have a condition known as DC Offset. There are sensor transistors on each of these amplifiers, which will "report" a damaged amplifier condition back to a microprocessor(computer inside the Bose system). When this damaged condition is identified, the amplifier will shut down the system, and that red indicator will flash. You will need a professional, audio specific technician, as this is not a DIY repair.

If any of you are interested in having your systems repaired, please contact me from my website, Just FYI, this is not a Bose specific issue. The same problem can occur with any amplifier, any brand. Thank you.

Jan 17, 2013 | Bose Cinemate 1 Sr Speaker System

1 Answer

In need of aiwa BMZ-K7D service manual

I don't believe that those manuals are available for free anywhere. Is there a specific problem that you are attempting to resolve? Those of us that have access to these manuals are contracturally bound to not release them. We can help to guide you through a repair though.

Please update this with the problem and as many details as possible.


May 06, 2009 | Home Theater Systems

1 Answer

RCA RT2500 audio amplifier will not turn on when I push the on button. I reset all the plugs inside and checked visually the fuses they seem ok. Would like to know if there is a reset jumper on the board...

Verify 120v at wall socket. Plug 2250 into mains, if not so already.

QUICKLY unplug and plug back in the unit. That should put the unit into DEMO mode, at which point you can press the (now red) power button and the unit should function nominally.

Jan 15, 2009 | RCA RT2250 System

4 Answers

No sound from back surround speakers

We just hooked ours up and had the same problem, we switched around the s-air cards and that solved the sound problem immediatly.

Jan 11, 2009 | Sony BRAVIA® DAV-HDX576WF Theater System...

1 Answer

Russound Home Theater w/IR

Sorry about the late response, I didn't get a notification of this posting...

Can you update this with the make and model of the unit please. It sounds like this is a continuation of another posting, but I can not find the original.


Dec 19, 2008 | Home Theater Systems

1 Answer

'stereo' speaker problems

Yer man there a load of **** i've got 2 x DV290's one for the back of my studio & one powering the front,your lucky you only had 2 **** speakers i had 4 lol.
but there is light at the end of the woofer,they have to be wired together its as if one makes the other one work,so you put GRAY & BLUE in you get BASS or hum ,you put BLACK & RED in you get HIGH or top end you put all four in you get nice mixture.
I've also had it another by mistake & it worked, i put the + & - side by side instead of top & bottom so it was RED / GRAY & BLACK / BLUE if you know what i mean.then cut the plugs off the surrounds & wired them in aswell & it's all good in de hood.
oh a tip before i go,get some rubber legs off the bottom of something or the casters off an old chair or stool & GET THEM SLAPPED BETWEEN THE AMP & THE SOUND PROCESSOR for ventilation coz Fu*"*k me they don't half get hot man!
good luck pal....later

Aug 12, 2007 | Technics SC-DV290 System

Not finding what you are looking for?
Aiwa HT-D780 System Logo

Related Topics:

132 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aiwa Home Theater Systems Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Audio Service Clinic...

Level 3 Expert

924 Answers


Level 2 Expert

265 Answers

Are you an Aiwa Home Theater System Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides