Question about Washburn Amplifiers: 25 WATT Guitar Amplifier - Bad Dog - BD25R Car Audio Amplifier

1 Answer

I have not played my electric guitar for months now there is no sound coming through the amp, the amp works ok

I have not played my electric guitar for months now there is no sound coming through the amp, but the amp works ok

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 51 Answers

Probably have active pickups on the guitar.
if there's a plate on the back, get a small phillips screwdriver, take the plate off, and put a new 9 volt battery in.

Posted on Dec 04, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a peavey VIP2 amp.Can I use my acoustic/electric guitar in the electric guitar setting


You can not only play it on electric guitar setting, you can play it LOUD. Its all about what YOU do and what YOU like. Dont accept it when somebody tells you that the music you're playing doesnt sound good to them. ITS YOUR MUSIC !
Do whatever you want. And NO it wont hurt guitar or amp. Rock on or whatever it is you do.

Oct 26, 2015 | Peavey Vypyr VIP 2 40W Modeling Combo...

1 Answer

Is it the guitar or the amp


Hi, Sounds like you have a bad cable to your amp. Try swapping out the cable. If that is not the problem, The pickup maybe bad.
Hope that helps.

Jan 14, 2014 | ESP LTD MH417 7-String Electric Guitar

1 Answer

Amp not comming on until strings played hard.


Check your cables - I've had similar problems with various amps playing various guitars; the guitar electronics and the amp electronics are fine, but the cable is damaged internally and this causes the same problems as you have described. Have you tried using a different cable? Buy a different one, try it out, and see if you have the same problem. If you have a friend who plays, let them plug their cable and guitar in the amp - if it works, your faulty cable is the issue. Hope that helps!

May 01, 2013 | Genz Benz Shenandoah 150lt Acoustic Amp...

1 Answer

I bought a Fender Frontman 212R back in March of this year. It worked brilliantly for almost six months, until July 26th, when during a jam session, the audio randomly cut out. Upon inspection, it appeared...


Try using your guitar cord to plug in and out of the headphone jack several times while unit is on. There is a circuit that disconnects the speaker when using headphones and the circuit is activated when something is plugged into the headphone jack. This "switch" can get dirty and cause the can get dirty and cause the problem you describe.

Aug 26, 2011 | Fender FM212 Solid State Electric Guitar...

1 Answer

D10sce will not work when plugged into the amp. the cord is nine ( works with my electric.) battery is new. when you turn up the volume on the controll, you can hear it in the amp, just no pick up sound.t


SUBSTITUTE Change the guitar for a friends to see if the amp is really OK. Try your guitar in a friends amp to see if the guitar is OK If the guitar is at fault its either the battery, the connection cord, the little pre amp in the guitar body (you can't fix that) or you have put nylon strings on the guitar which needs stell strings for the pickup to work. Good luck

Feb 13, 2011 | Washburn WD10SCE Cutaway Acoustic-Electric...

1 Answer

I've plugged my SX RST guitar into the SX GA-1065 amp but I can't get sound to come from the amp. I've made sure everything is plugged in and adjusted, but it still won't work. Why can't I get it to play?


Test the amp cable by plugging in the guitar cable an touching the end of the cord and you should get hum from the amp if the volume controls are up.

Many guitars require a battery to operate the preamp inside them.. Verify if yours needs a battery and it is fresh and properly installed.

These batteries are turned on by plugging in the guitar cable into the guitar. Leaving the cable in will exhaaust the battery, often within a day.

Sep 01, 2010 | Sx Guitars SX SST SE CAR + GA1065 STCAD...

2 Answers

No vocal sound


It sounds like the guitar level input to the unit is too low.

NOTE: With this product you MUST use an amplified or electric guitar that has a preamp within it.

If you have a straight guitar that does not have an amp in it, buy a preamp to first run the guitar through.

Apr 26, 2010 | DIGITECH VOCALIST LIVE 2

1 Answer

Guitar truss rod dilemma


The truss rod must be too slack then.
Is the sound ok? Does it play ok?
In it's current state the truss rod is doing nothing.
If the guitar is sounding ok and playing ok, then the next time you change the strings pull the truss rod out and throw it in the garbage.lol
Seriously though...just pull it out and put it aside.
If,however,the guitar is not sounding ok then try tightening it.
If you're unsure about how much to tighten it then I suggest taking it to your local music store for help with that.

Sep 21, 2009 | Music

1 Answer

Guitar hero world tour game has no sound all


check your disk for scratches or fingerprints.

Jun 11, 2009 | Sony PlayStation® 3 (60 GB) Console

1 Answer

Guitar amp shows power but has no sound, could it be a blown fuse


Nine times out of ten, any problem with an amp having no sound coming out, it's a wiring issue. Make sure all of the wires internal to the amp are propely hooked up. Also, try switching out the quarter inch cord you are using from your guitar to your amp. Could be a bad cable. Unless you have blown the speaker completely, something is loose or not hooked up properly.

Feb 27, 2009 | Marshall Mg100dfx 100-Watt Combo Guitar...

Not finding what you are looking for?
Washburn Amplifiers: 25 WATT Guitar Amplifier - Bad Dog - BD25R Car Audio Amplifier Logo

Related Topics:

1,143 people viewed this question

Ask a Question

Usually answered in minutes!

Top Washburn Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

The Knight
The Knight

Level 3 Expert

72670 Answers

Are you a Washburn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...