Question about Hitachi 50UX26B/27K 50" Rear Projection Television

Open Question

Hitachi 50ux26b No Picture

When pushing the power button, the red led comes on and stays solid, and we can hear a relay. Pushing the magic focus button we can briefly see some text, and it fades. Pushing the service button we get rows of vertical lines that are pretty sharp, and rows of really broad/messy horizontal lines. The TV was my wife's before we got married, so I have never messed with it to know what those two screens would/should look like anyway, and the manual is also long gone.

Opening the lower front and back, the red led D975 comes on, and stays solid. 5 other green leds also come on and stay solid.

Any help on where to start would be appreciated. Also, any input on where to find a service manual, schematics, or even a parts placement diagram. I do have previous electronics background as an avionics tech in the Navy for 13 years, but after 15 years of non-use and a lack of anything but a DVM for test equipment I'm hoping a not to expensive shotgun troubleshooting approach will do it. I think about the only thing I'm still confidant about is soldering, although looking in that TV getting the board out doesn't look too entertaining.

Any help, or more detailed questions I can check and get back to you with that could help, would be greatly appreciated!!!

Posted by on

  • 2 more comments 
  • scottvc Oct 13, 2008

    Oh, a few things hit me on more detail or will likely be asked. We did try unplugging the set in an attempt to reset it multiple times. One attempt was actually for well over 24 hours even. Also, all inputs were unplugged by the time I got involved, but I am told the audio was working.

  • scottvc Oct 13, 2008

    I wish there was an edit button so I could just change the original instead of adding to the list :)



    The menu also does not display. Only thought it may be important since there is at least "something" being displayed when using magic focus or service mode. I guess my largest confusion is why all 5 green leds are lit and no clue where to start because of it.

  • scottvc Oct 15, 2008

    Another update...



    First, going into service mode the grid is now sharp, vut VERY dim. Can only just barely see it and nothing at all on about the top half.



    Second, I did find a service manual. The Hitachi instructions say to turn the TV off, then back on and observer the led's to see which turns off first. I'm assuming they just wrote that backwards since unless an led is out completely, it is when the TV is turned off the leds also go off? In that case, when turning the TV off, D953 and D954 turn off significantly quicker than the remaining 3 led's.



    If that is correct, I assume I need the 3 convergence IC's and 6 47k Ohm resistors.



    My biggest, uneducated concern then is, with no picture, no menu/OSD, and if these parts are the cause, how does Magic Focus or service mode manage to display anything at all either, even if very dim or just part of the screen?

  • scottvc Oct 15, 2008

    I removed the board this evening and checked all 4 fuses, and all are good as well :( Also checked solder joints on the bottom and didn't find anything. Also, before starting to remove the board I cycled power once more, and all led's appear to go out at the same time now when it is turned off, and all led's on when the set is on. No clue where to start. I do now have access to an O-scope if needed, but will have to wait for a weekend when it isn't needed.

×

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

techman
  • 3130 Answers

SOURCE: Hitachi 50EX20B Bigscreen TV

You can download a PDF from here: http://www.servicemanuals.net/results.aspx?type=SM&brand=0&model=50EX20B Make sure that the coolant is not leaking out onto the printed circuit boards. i have had the remote sensor cause this problem before and also I have had bad capacitors in the sweep and the main power supplies. Good Luck

Posted on Jun 14, 2007

  • 2 Answers

SOURCE: Hitachi 43FDX01B (convergence) problem

hi i have same prob iv bin told its a convergence chip an thay r £150 ! thay go bout evry 6 years an its comon .. any way there coming 2 fix mine 2day so ill let u know if it sorts it out my mail is mjoutlaw@hotmail.co.uk thanx

Posted on Feb 01, 2008

  • 1 Answer

SOURCE: Hitachi 57SWX20B 3D Effect due to green light convergence problem

I'm trying to fix the issue on my 43FDX20B. So far, I'm able to move the lines up and down, but can't get the left/right motion to fix it. The attached link has the dynamic mode instructions, so you can correct this issue yourself.

http://home.comcast.net/~leebailey00/Hitachi_DCAM_Manual.pdf

The only thing I didn't have was the screen overlay jig the manual talks about. I decided to create one myself and use the screen as a beginning template. I went to our local hardware store and picked up some home window weather covering. The roll cost about $15, is a clear strong plastic and the template was very easy to create. I used a straight edge after I put dots on the plastic and measured the lines for being square and equal after I took it off my tv. Good thing is that if you don't like what you make the first time, you have a 25' roll to use to try again (ha).

Posted on Mar 02, 2008

SOURCE: Hitachi model 55FX48B

Just had the exact same thing happen to me.

Posted on Apr 01, 2008

  • 927 Answers

SOURCE: Hitachi 50ux26b

Good day, 1gary;

Hitachi has LED’s, green ‘lights’ and a red light to determine what circuit may be the problem; after removing the back of TV, bottom only, plug TV back in and observe which LED’s come on …..BUT most important which LED’s don’t come on; locate and note number, EG; DP37 and etc.

Good luck, big IRISH. Ps let me know.

Posted on Jul 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hitachi 50ux26B keeps turning off.


There is a chance that the one of the power relays are causing the problem. They have been known to be intermittent and even work for 5 sec. or 5 days before failing. When the back is off, turn the set on and when it shuts down lightly tap the relay/s in the power supply lightly and see if the set comes on for any length of time. If it does, replace the relay
and you will fix the problem. Let me know what you find.
Hope this helps,
Skyassoc

Jun 29, 2009 | Hitachi 50UX26B/27K 50" Rear Projection...

1 Answer

Plenty of Sound, No Picture


You may have to replace the convergence IC's or the lamps. Impossible to say without having a manual inspection. Best bet is to take it in for a service repair..

Sep 27, 2008 | Hitachi 50UX26B/27K 50" Rear Projection...

1 Answer

50ux26b Hitachi


Good Day;

Sounds like the Convergence Circuit in the TV has failed. Call an Authorized Service Center and have them come out and give you a wtitten estimate B4 repair.

Good Luck, big IRISH.

Sep 27, 2008 | Hitachi 50UX26B/27K 50" Rear Projection...

1 Answer

Hitachi 50UX26B


Good day, seanhanna;

Hitachi has LED’s, green ‘lights’ and a red light to determine what circuit may be the problem; after removing the back of TV, bottom only, plug TV back in and observe which LED’s come on …..BUT most important which LED’s don’t come on; locate and note number, EG; DP37 and etc.

Good luck, big IRISH. Ps let me know.

Jul 12, 2008 | Hitachi 50UX26B/27K 50" Rear Projection...

1 Answer

Hitachi 50ux26b


Good day, 1gary;

Hitachi has LED’s, green ‘lights’ and a red light to determine what circuit may be the problem; after removing the back of TV, bottom only, plug TV back in and observe which LED’s come on …..BUT most important which LED’s don’t come on; locate and note number, EG; DP37 and etc.

Good luck, big IRISH. Ps let me know.

May 17, 2008 | Hitachi 50UX26B/27K 50" Rear Projection...

1 Answer

Compaq Presario 4400us


Either the new power supply you purchased is not functioning correctly. But, assuming it is now that you are getting some form of power to your PC, it is very likely the motherboard. Whatever fried your old power supply (or it could have just been the power supply itself) most likely fried your motherboard in the process. Probably not the CPU since the MB can't even post.

Jun 21, 2007 | Compaq (388746-001)...

1 Answer

Won't turn off


Go to the panel (on the tv set), hit magic focus on there....then hold power button for several seconds long. It should go off and fix your problem.

Jan 22, 2007 | Hitachi 46W500 46 in. TV/DVD Combo

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Televison & Video Experts

Jaime Hernandez

Level 3 Expert

2318 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

matt martin
matt martin

Level 3 Expert

1210 Answers

Are you a Hitachi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...