Question about Olympus EVOLT E-300 Digital Camera

1 Answer

SSWF Light Hi, I've had my evolt 300 for a little over 3 years and it had been working fine. I charged battery up and went to turn on the camera and there is nothing-it won't come on and (sometimes) the blue sswf light stays on? I just bought a new wide angle lense and it won't come on when I'm using the new lense either. Thanks!

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Olympus Expert
  • 479 Answers

Update the firmware of the camera to the latest update using the software that came with the camera

Posted on Oct 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My E 300 works fine with the 14-45 3.5-5.6 lens, bright viewfinder and good photos. However, with the 40-150 3.5-4.5 lens the viewfinder went dark abd photos are overexposed. Problem went back and forth...


I assume this happens while your camera is in the automatic mode. Because if the camera is in manual, you can't assume both lenses give the same light to the sensor.
But I should look if the contacts on the lens and in the camera, ale all clean and shiny. And not one of the contacts is allowed a dent. Not even a little dent. All contacts must be flexible. Then be sure the Aperture setting on the 40-150 must be correct. The camera manual does not say a thing about the settings on the lens, but I should look there too.

Feb 19, 2014 | Olympus EVOLT E-300 (Double Lens Kit)...

1 Answer

I've had my E-300 for 3-4 years now with never a problem, until this.... . Recently, whenever I try to upload photos onto my PC I click "Ok" for the "Storage" function, the red light...


Consider NOT connecting your camera to your computer.

The best way to download pictures from your camera to your computer involves removing the memory card from the camera and plugging it into a card reader (either built-in to the computer or connected via USB or FireWire). This is likely to be faster than connecting the camera to the computer, and won't run down your camera's batteries.

Once the card is plugged in, it will appear to your computer as a removable drive. You can use the operating system's drag&drop facility to copy pictures from the card to the computer's hard drive, the same way you copy any other files. Or you can use any photo cataloging program.

Dec 29, 2010 | Olympus EVOLT E-300 Digital Camera

2 Answers

Evolt e300 broken


try to formated the mem card or replaced by a new one the card is may be defective..

hope that help..
regards Alan

May 27, 2010 | Olympus EVOLT E-300 Digital Camera

1 Answer

I have an Olympus e510 that I bought new 2 years ago. The other day I got it out to use it and it will not turn on. I purchased a new battery, charged it, and it still will not work. When I removed the...


Hi, as per your information your camera 2 years old but not used much. You buy a new battery 1st time when you charged you see the gree light. But camera not working. When you try to charge the battery again you seen the red light. Its mean your charger have a problem. So what you do now? Ok try these.
Remove the power connection of the charger. then fixed the battery there slowly & properly. After that plug on the charger again. If the same thing happens then unplug the charger & plug in in different point. Then see what showing. If again red light then wait 1 hours and waiting for green signal. If there is no green signal showing then visit a service center with your charger. Tell them your problem. They will fixed the charger for you. Don't worry your camera is ok.
Your new battery or your charger one of then damaged. Thanks & waiting for your feedback.

Feb 15, 2010 | Olympus Evolt E-510 Digital Camera

2 Answers

I am trying to charge the battery. The charger is flashing a red light and the battery won't seem to charge. Placed it in the camera just in case, and it won't turn on.


Well, with my Nikon, the light flashes to show the battery is charging. It stays on when it's charged. My battery and spare battery are 2 years old and working fine. I'd say wait till it stops flashing...hour or 2 in my case, though I never let them run down all the way.

Jun 28, 2009 | Digital Cameras

4 Answers

Olympus E-300 Evolt - LCD Screen doesn't come & SSWF light stays on


My camera is working again, but the problem is not completely solved. What I did was to put on the old lens, take out the battery then turn on the camera and finally put on the battery again. And now it works. But the problem with the new lens (Zuiko digital 40-150) continues.

Jun 30, 2008 | Olympus EVOLT E-300 Digital Camera

1 Answer

SSWF ON MY E300 WONT GO OFF


Try updating the firmware on your camera to the latest version using the Olympus master software. There have been several revisions since the camera came out.

Apr 21, 2008 | Olympus EVOLT E-300 Digital Camera

1 Answer

Camera does not work when memory card is inserted


just look in the slot for a short circuit. some times it does hapen on cf cards or on xd cards.

Jan 04, 2007 | Olympus EVOLT E-300 (Double Lens Kit)...

Not finding what you are looking for?
Olympus EVOLT E-300 Digital Camera Logo

Related Topics:

296 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Digital Cameras Experts

kakima

Level 3 Expert

96683 Answers

Willem.
Willem.

Level 2 Expert

345 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Olympus Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...