Question about Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum

1 Answer

Self propel not working, burning smell

My Hoover Ultra U6430-900 suddenly got difficult to push and there is a burning smell when I try to use it. Any ideas? The flat belt still turns the brushes when I move it. I don't see any evidence of burning or melting when I take off the bottom panel.

Posted by on

  • vthokie88 Oct 25, 2008

    I did both - cleaned the brushes and replaced the belt (at a cost of $1.50 for the part) and it is working great! Simple solution! Thank you.

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Flip the vacuum cleaner over and check the roller brush. Is it full of string and hair? If so, unscrew the four phillips-head screws holding the plate on that covers the roller brush; pull out the brush, and cut off/clean off all the hair and string. Replace everything and try running the vacuum. Alternate solution: perhaps the belt that makes the brush go around is broken. If so, follow the above steps to remove the roller brush, then replace the belt.

Posted on Oct 24, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Repairman can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Repairman (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Hoover wind tunnel self propelled vacuum #U6439-900 stop working. I checked the bag,filters,clean the roller and it's still not working.


Your motor may have siezed. You may have a cut in the cord somewhere too. Need more specifics to pinpoint problem. Did it stop working suddenly? Did it smoke of smell funny the last time it worked?

Nov 16, 2016 | Hoover Vacuums

1 Answer

The wheel that connects both belts broke


The drive pulley can be replaced, however I would only recommend being service by a vac shop professional who has experience with the Hoover Self Propelled models.

Oct 20, 2014 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

I have the Hoover, self propelled vacuum. I have only used the self propel function a few times, but our babysitter used the feature and now the vacuum only works on the highest carpet setting. The middle...


Move the carpet height control switch to a higher position if the vacuum is difficult to push. If the setting is too low for the carpet being cleaned, the brushes press against the floor preventing the vacuum from moving easily.Set to a medium-high height setting then check.Slide the "Self-Propel" button to the "ON" position if the cleaner does not self-propel. -----------
The self-propel feature operates only when the cleaner switch and the self propel button are both ON. ---------- Try this settings and check.This should help.Thanks.Helpmech.

Jun 24, 2011 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

I have a windtunnel vacum cleaner. When I


It might be a slipping rubber belt, is the brush roller moving when you look underneath? If it's a self propelled machine there might be another slipping belt. Friction from fast rubbing rubber can smell like it is burning.

Jan 16, 2010 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

Self Propel wheels not enough power to move machine over carpet.


Sounds like the transmission might need an overhaul. Take it to a local vacuum repair shop and have them look at the transmission.

Sep 03, 2009 | Vacuums

2 Answers

Hoover wind tunnel u5755-900. smoke, smell. self-propel


Can you verify the model number? However, based on your posted description, it sounds like the flat belt is either broken or fell off. to access the belts turn it over and remove the bottom plate (4 screws). the Flat belt will connect to the motor shaft in the back and the large black pulley.

Mar 13, 2009 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Installing belt on hoover self propelled upright vacuum


http://geeksquad.fixya.com/ThreadView.aspx?prdid=40544&thid=641399
Installing belt on Hoover self propelled upright...
Posted by Fryeburger on Jun 02, 2008
Need help installing belt on Hoover self propelled upright vacuum

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. Hoover Ultra U6430-900 Wind Tunnel Bagged Upright. The best way to install the belt on a Hoover to replace one or both of the belts @ the same time for the best cleaning. The average belt change is every 4 to 6 months for best results. There is a tool that looks like a screwdriver that has a right or left angle on the end that serves as a belt puller and to hook the belt(s) onto the brushroll 1st and then take your puller and then pull or stretch the belt onto the motor pulley. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

http://www.a-1vacuum.com/ 1-800-657-1874 Customer Service
Thanks, Don the Vac Man
Go Ahead. Use Us.

Jun 02, 2008 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

Windtunnel self-propelled feature broken


If it is a rubber smell, then it could be belts and/or brush roll. If it is an electrical smell, then it could be the motor. Take the belts off and see if it still makes that noise, if it does, then the motor is going bad.

Apr 22, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover Ultra U6430-900 brush & propel problem


The flat belt is the problem, it has to be tight so it can turn the drive and also the pulley for the V belt.

Mar 09, 2008 | Hoover Ultra U6430-900 WindTunnel Bagged...

Not finding what you are looking for?
Hoover Ultra U6430-900 WindTunnel Bagged Upright Vacuum Logo

585 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18413 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...