Question about Heating & Cooling

Open Question

My Teco TC-20 Heater-Chiller has stopped working (no display) I have explored possibilities through TecoUS and have tried changing the fuse and also a reset using the pins as described on the following website .. http://www.tecous.com/files/TECO_Seachill_Reset_Guide_(all_models).pdf .. all to no avail. It is possible it was not turned off when the water flow was switched off. If that is so would it not have fused the fuse or is it possible it has cooked something else. Or could there be another cause? Jonathan

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

freetek
  • 5568 Answers

SOURCE: Fuse keeps blowing on 2004 Jeep Grand Cherokee

You've probably solved your problem by now but if not, you really need to buy a cheap digital multimeter. It will help you in this kind of situation and others.
Connecting it between the output side of the fuse for that circuit and ground can let you start pulling connectors until the low resistance causing the blown fuses goes away.
Experience with this kind of troubleshooting helps so you may be a little uncertain at first.

They can be had at auto-parts stores, Radio Shack, or if you are lucky enough to have a Harbor Freight tool store near you, they often have the things for $3 and while not exactly precision instruments, they are adequate for most anything one can do at home.

Posted on Jul 21, 2008

MicrowaveSvc
  • 9047 Answers

SOURCE: Panasonic nn-p295 blows buss fuse when turned on for cooking

If it went dead almost immediately after pressing the Start pad, that's usually a shorted high-voltage capacitor.

If it went dead a few seconds after pressing the Start pad, that's usually a failing high-voltage transformer. But this is likely an inverter model, so it wouldn't have one and would be some other component in the inverter I'd say.

If it goes dead or blows the breaker (or GFI) when you plug it in or open or close the door, then there's a problem with a door switch or door switch mount.

If you or someone you know decide to look into it, we have critical safety information and disassembly information at our site, and our link is at our listing here on FixYa.

Here are some links you or someone you know can use (in order given) for test help, but read the safety warnings first:

http://www.microwavedisplay.com/safety.txt

http://www.microwavedisplay.com/disassembly.txt

http://www.microwavedisplay.com/doorsw.txt

http://www.gallawa.com/microtech/cap_test.html

http://www.gallawa.com/microtech/xformer.html

http://www.gallawa.com/microtech/mag_test.html

The best place to order Sharp parts is Tritronics. Or you can call them toll-free at 866-779-5835.

We're happy to help you with free advice and we'd appreciate your thoughtful rating of our answer.

Posted on Dec 26, 2008

  • 2 Answers

SOURCE: Zboard software causes www.ideazon.com to open

take back get refund there are no mac drivers

Posted on Feb 16, 2009

  • 1 Answer

SOURCE: make the (teco speecon 7200ma ac drive parameter was not found.

inverter
out current U,V,W (amp) not equel

Posted on May 20, 2009

  • 1 Answer

SOURCE: BROKEN TECO TV

Can't solve this problem (my power supply has gone as well!) but I have a contact at head office. Unfortunately it's in Tawain. Try Company: Teco Electric & Machinery Co., Ltd.
Address: 6F., No.49, Wugong 6th Rd., Wugu Township, Taipei County 248, Taiwan R.O.C.
Contact Person: Amanda Huang ext.1301 / Sales Specialist
E-mail: amanda_huang@teco.com.tw


Anyone know where I can get hold of a new power supply without going through Teco?

Dave...

Posted on Jun 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1998 ford explorer radio does'nt work switch on sterrein wheel broke.how to fix it ?no power to the radio


You can't turn it on by the switch on the radio ? Nothing showing on the radio display ? If not check these fuses
Blown central junction box (CJB) Fuse 1 (7.5A), Fuse 20 (7.5A), Fuse 28 (7.5A), and Fuse 29 (25A) . The switch on the steering wheel should not stop the radio from being turned on at the radio !



    Even

Mar 20, 2015 | 1998 Ford Explorer

2 Answers

Teco inverter airco LT404y will not go to heat cycle anymore why not must be a valve


The thermostat may be bad or the change over valve in the outside unit has stopped working.

Oct 15, 2014 | Heating & Cooling

1 Answer

Fuse diagram scion tc


ok efi 20 a is for multi port fuel injection system/sequential multiport fuel injection, possible you have a shorted fuel injector, only way to find out is to unplug one at a time and see if fuse does, or does not blow

Mar 25, 2014 | 2009 Scion tC 5.0

1 Answer

Gree 18000 Btu Air Conditioner , f2 appears on display


F2 is an indoor pipe sensor fault. You will need an air con tech or electrician to do this as the sensor is wired into the indoor board. Gree parts can be a bit difficult to obtain but a similar sized pipe sensor from an LG or Teco unit will work. You may have to "splice" the new sensor onto the existing pipe sensor wiring as the connection to the indoor board will likely be different. Contact LG or Teco for your colsest parts outlet or buy direct from them.

Sep 07, 2013 | Gree 18000 Btu 20 Seer Ductless Mini Split...

1 Answer

Where can I buy a replacement shutoff valve for my SeaChill TR10 aquarium chiller?


Conveniently enough, their website sells replacement parts. The first link is for the specific part you requested and the second link is to the other parts you can buy.

https://www.tecous.com/replacement-parts/shutoff-valves/

https://www.tecous.com/chillers/seachill-tr10/

Aug 29, 2012 | 1topstore Fish

2 Answers

What are the recommended aquarium chiller brands available in the market?


I highly recommend you to get a USA Prime Aquarium Chiller you wouldn't be disappointed. You can also get chillers from Aqua Logic Aquarium Chillers, Deltec Eco Cooler Aquarium Chiller, Coolworks - IceProbe Aquarium Chiller, Oceanic Aquarium Chiller, TECO SeaChill Chillers and Tunze Aquarium Chiller the all solid chillers companies.

Aug 13, 2012 | Fish

1 Answer

Heater just stopped working in 1996 explorer what can i look at or what could it be?


im not sure if you mean the blower is'nt working or if you mean the blower is working but the air is cold so I'll try to answer both, if the blower is'nt working it is possibly a bad fuse, the fuse panel may list it as the heater or it may say blower, now if its blowing but the air is cold it is most likely a bad thermostat, sometimes the heater core goes out but if you havnt noticed the window fogging on the front windshield on the passenger side or smelled coolant in the cab of the vehicle the heater core is probably fine , the thermostat is a common culprit and they are fairly easy to change, one other thing before you go changing anything, check to make sure the radiator is full, with the car cool take the radiator cap off and run the car until it starts to get warm and see if you can add some coolant

Jan 12, 2011 | 1996 Ford Explorer

4 Answers

Honywell whine chiller model 88058 not working


Hello friend, i had the same problem and it was solved replacing largest capacitors on board, they are 2 x 120uF(120V). You must to check that both original capacitors be damaged, you can to see it if they are inflated on the top

Jul 23, 2010 | Honeywell Consumer Products Model...

1 Answer

1997 dodge intrepid heater/ac fuse keeps blowing


I have a 96 Intrepid, and none of the signal lights work. I tried replacing the fuse, but this did not remedy the problem. Could this be a loose connection?

Feb 11, 2009 | 1997 Dodge Intrepid

Not finding what you are looking for?
Heating & Cooling Logo

Related Topics:

194 people viewed this question

Ask a Question

Usually answered in minutes!

Top Heating & Cooling Experts

paulcarew

Level 3 Expert

2460 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Donni Steen

Level 3 Expert

659 Answers

Are you a Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...