Question about Power Acoustik LT-980/2 Car Audio Amplifier

1 Answer

No out put

I have power it starts out in protect and then the red light turns off but the green one never turns on everything else is lit blue as normal but I get no sound out the amp I assume my out put is shot where can I get it repaired and for how much?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

It sounds like the switching power supply has failed.

You need to find a local repair shop. If you don't know of any, contact the local car audio dealers to see who they use. If several recommend the same shop, they probably do good work.

If you want to try to repair it yourself, you'd have to do a bit of troubleshooting.

Let me know if you have any other questions.

Posted on Oct 09, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

60SDX88B. No video, No sound. DP06 Protection


not a solution but i have a 50gx30b doing something similar, no picture no sound, 3 green leds are lit up on the main board and then one red led lit up also on main board, front panel red led stays on for about 30 -50 seconds and then it all shuts off, I then have to unplug and replug to get the same results.

Mar 03, 2010 | Hitachi 60SDX88B 60" Rear Projection...

1 Answer

I have a 56" samsung rear projection tv that won't turn on. the red standby light is lit and when i push the power i hear two clicks and the green timer light flashes quickly then the green led stays lit...


I suspect you probably have a bad LED assembly. It could be either the red, green or blue that is bad and give you the same symptom. The problem is locating parts for it as it looks like the light engine is no longer available. I would have a technician look at the TV to verify this and what parts are needed for repair.

Nov 03, 2009 | Samsung HL-S5679W 56" HDTV

1 Answer

55" TV keeps shutting off automatically


Green light flashes 5 and then red light flashes 6

Sep 14, 2009 | Sony KDF-E55A20 55 in. LCD Television

1 Answer

LED light has gone out


Lights up blue when the Drive is powered on. Flashes red when reading or writing data. It was just stuck between color as it does not flash green,red-blue make green. Contact the company and see if it is under warranty, if not see if they will send you a new light, because
if it is not under warranty,it does not matter if you open it.

All that is inside is a hard drive, chip board. The light plugs onto the chip board same as a fan plugs onto a motherboard. I hope this helps you and it is under warranty,or at least they send you a new light if not.

Mar 24, 2009 | Acomdata 500GB External Firewire HD 500 GB...

1 Answer

Kicker kx 800.4


Generally, if a Kicker amp has the power light lit and the protection light isn't lit, it's working. Are you sure that you have signal feeding the amp?

Are you sure your speakers are OK?

Nov 04, 2008 | Kicker KX800.2 Car Audio Amplifier

1 Answer

Thumping speakers - no power light is on - wired correctly


the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.

Nov 02, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Amp Power light will not go on. Protection light is lit- Thump sound in speakers


It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Oct 31, 2008 | Visonik Dual Bass Box with Amplifier Car...

2 Answers

Will not stay on


RED light is protect circuit = do not disable !
Look for C702 near flyback transformer - might be hidden in
glue = check it = if shorted, replace 102K / 2KV with 3KV =
Sony part # 1-161-754-00 and replace E994 pico fuse.....T.

Nov 08, 2007 | Hitachi 60UX54B/55K 60" Rear Projection...

Not finding what you are looking for?
Power Acoustik LT-980/2 Car Audio Amplifier Logo

134 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

yadayada
yadayada

Level 3 Expert

70347 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...