Question about SPL Phantom DK2-1000 Car Audio Amplifier

2 Answers

SPL AMPLIFIER YES I HAVE THE SPL PHANTON DK2-1000 EVERTHING WAS GOOD UNTILL ONE DAY IT JUST QUIT ON ME. THE AMP STILLS COMES ON NO PROTECTION MODE BUT WHEN I PLUG IN MY AUX NO SOUND AND THE AMP GETS HOTTER THAN NORMAL. WHEN I PLUNG IN THE AUX WIRES I HEAR A POPPING NOISE IN MY 12'S. DOES THIS MEAN MY AUX ON THE AMP OR GONE REPLACED THE WIRES FROM CD PLAYER NEW STILL THE SAME THING. I ALSO LOOKED INTO THE AMP NOTHING SEEMS TO LOOK BAD. IF IT IS THE AUX ON THE AMP WHAT COULD CAUSE THIS PROBLEM AND HOW TO AVOID IT. THANKYOU

Posted by on

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

There could be a variaty of things wrong

I have the same exact same amp.

The amp will get a little warm but it shouldn't get hot enough to where you cant stand it. The amp is only 2ohm stable in stereo mode and 4ohm stable in briged mode.

EX: If you connect a 2 ohm sub to the amp in briged mode.
1. It will cause the amp to get hot and possibly cause the amp to stop working.
2. It can cause the voice coil(s) to get hot and detach from the voice coil former.

Check the preamp output on the RCAs on the radio and what the amp is capable of handling. If the radio is more or less than the amp can handle it can cause the circit for the RCAs inputs tobe damaged over time. If the gain/level is turned up past 3/4 of the way it can shorten the life of the amp extremly. Also if the amp is starving for power it can damage the amp. Check the peak and rms on the amp and sub(s) if the amps peak or rms is higher than the amp it can damage both the amp and sub(s).Check to make sure all the connections on the amp are tight. Then check to be sure the connections to the input termainals on the box(s) and sub(s). It can cause the sub(s) to pop.

Hope it helps if not let me know
thanks,Kris

Posted on Dec 05, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

Have you checked to see if your subs voice coils have shorted. That could cause the amp to heat up, on rare occasions the protection lights don't work. Rare, but possible.

Posted on Oct 17, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a spl fx2 1800 that i got from a guy for 40 bucks and it is frozen in the protect mode is there a way i can get it to come out of the protect mode with out sending it in to the shop


The most likely culprit when an amp goes into protection mode is the power wiring. Check your ground wire, it should be solidly connected to the vehicle chassis in a paint-free location. Then check the live power wire and make sure it has a good connection. If that doesn't work, download the user manual from retrovo.com. That should help you to decode why the amp is in protect mode.

Mar 05, 2011 | SPL FX21800 Car Amp

1 Answer

Amp goes straight to protecting


bad power supply or out put i hat to say it but spl is note a good company i would replace the amp

Jul 07, 2010 | SPL Dynamics CRM1200-2 Car Audio Amplifier

1 Answer

I have a 1000.1 kicker amp and when i have the amp


you might not have the battery power to power it or it might not be the right ohms. i just had this happen to me after i hooked up 4 cvrs to the same amp. today it just quit.i got to get it checked out to see if i blew it.

Nov 22, 2009 | Kicker ZX10001 Car Audio Amplifier

1 Answer

Amp not working


If the amp is in protect mode, it probably has shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protection - Troubleshooting

Let me know if you have any other questions.

Aug 18, 2008 | SPL Dynamics Z2X-820 Car Audio Amplifier

1 Answer

Audiobahn DUB Mag Audio 2502 Amplifier


If the protection light is on, the amplifier likely has shorted output transistors. To eliminate other possible causes, read through the following page.

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Aug 07, 2008 | AudioBahn DUB Mag Audio DUB2502 Car Audio...

1 Answer

Spl fx-1800


hmm i would start by checking the wiring in your truck. make sure nothing is grounding out (short). if still happening try hooking the amp up to a battery out side of the vehicle and see if the light is still on. if so u need a new amp

Apr 19, 2008 | SPL DK-2600D Car Audio Amplifier

1 Answer

Power on/off


solidus- Your amp is going into protection mode, try disconnecting the sub and see if the power will stay on then.If yhe power stays on,it is your sub-blown or shorted ect. But if it does the same as before,its to the repair shop. cooltek Mar,4/08

Mar 04, 2008 | Sony XM-2002GTR Car Audio Amplifier

2 Answers

Lanzar Vibe 1200D protection light


You will need to show it to a service technician as it seems the output section has blown so it remains in protect mode. One reason (could be) that the input to the amp was high and may have been clipping for some time before the amp decided it could take it no more

Jan 14, 2008 | Lanzar Vibe 1200D Car Audio Amplifier

1 Answer

Amp stoped working


You should never disconnect the ground from the amp when it has B+ and remote voltage applied. This will cause damage to the head unit ith some amplifiers.

Does the protection light come on with the ground wire connected?

Jan 05, 2008 | AudioBahn A2002T Car Audio Amplifier

1 Answer

My amp quit working


ok I thought I anwered this one but first thing to try is disconnect all your speakers and see if the light goes out if it doesnt then your gonna need a schematic and a working know how on solid state amplifiers. first check al the outputs for the speakers for dc If theres dc on an output then that output device is shorted or leaky. Ive have open drivers as well as current control transistors leaky or shorted to that made the protection come on.. Good Luck

Apr 07, 2006 | AudioBahn A6004T Car Audio Amplifier

Not finding what you are looking for?
SPL Phantom DK2-1000 Car Audio Amplifier Logo

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top SPL Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

bigdawg7299

Level 3 Expert

2357 Answers

Are you a SPL Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...