Question about GCC Technologies Elite XL 608 Laser Printer

1 Answer

Won't print from Illustrator

The Elite XL 608 will not print from the AI image I am working on. (I have an IMac 10.4) The image goes to the printer and then the light blinks as if it were going to print and then it stops the printing icon ..."timeout has occured".  It prints from other applications just fine.  I have had this printer for a long time and made "positives" (I am a screenprinter) for years.  First time this has happened.  I was up until 4 am trying to wait for it to print.  there is some lettering in the image, but that has never bothered it before.  I have a $3k job due this afternoon and I cannot make my screens.  GCC will not return my calls as they did in the past.  I am desparate!  help! EJ

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Sound like the printer has lost its pdf post script discription file.
Try this open abobe ills seperator file just right of the files picture is set descript file click on window
a set pdf to match your printer.If file is not available to may need to do a clean removal & reinstall printer software. Hope this helps

Posted on Apr 17, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Probably my .ai image is invalid


I had a lot of problem with .ai files. Last time I was searching appropriate method. Take a look at Illustrator Restore Toolbox - it was in Google, I used it, software liked me a lot, check it out.
Adobe Illustrator Corrupt File Restoration

Jan 28, 2017 | Adobe Computers & Internet

2 Answers

View content of Illustrator?


Download and test third-part software for recovery illustrator documents like a Illustrator Recovery Toolbox from https://www.oemailrecovery.com/illustrator_recovery.html

Please follow instructions if you if you want to try to recover the file itself. :
1. Check a size of file. If it smaller then 50K then projects are empty
2. Attempt to re-create files as describe here: http://helpx.adobe.com/illustrator/kb/troubleshoot-damaged-illustrator-files.html

Sep 11, 2016 | Adobe Computers & Internet

1 Answer

Adobe Illustrator file format is having difficulties


There may be a TMP file in the same folder, you can try renaming it to AI and see if this opens. Helped me on a couple of occasions but also has not worked in the past.If it useless, there is a good program: Illustrator Fix Toolbox https://www.fixtoolbox.com/illustratorfix.html

Jan 29, 2016 | Adobe Illustrator CS2 for PC

1 Answer

Adoobe Illustrator problems


Correct the offending command
1.Launch Illustrator.
2.Using File > Open, hold down Command + Ctrl + Alt + Shift (Windows), and click Open. Double click the file to open. You want the full Open dialog.
3.Your file will be blank. Close the file without saving or altering.
4.Go back to your directory. You will now have a second file with an underscore at the beginning of the filename. (myfile.aivs._myfile.ai).

Nov 03, 2014 | Adobe Illustrator CS2 for PC

1 Answer

I run windows 7 64 bit i need a driver for a ccc elite xl 608 laserprinter


If you have a Windows XP x64 CD, try the GCC SelectPress 600 or Select Press 1200 driver. The SelectPress 1200 worked for my Elite XL 20/1200. I believe the only 64-bit drivers that are available for GCC printers are on the XP 64 disc.

Dec 09, 2010 | GCC Technologies Elite XL 20/600 Laser...

1 Answer

RAM error 0x11 417FFFBC00000001


Printers use RAM to hold the received print-image, to hold the image while the printer is working on printing the page.

However, in your case, a problem with the RAM has developed.

Take the printer to a qualified printer technician, to replace the RAM.

Sep 29, 2010 | GCC Technologies Elite XL 20/600 Laser...

1 Answer

When fuser is hot (10-15 min. or so, print is smeared, has lines through it, and sometimes there is only the suggestion of an image. You can get a good image before the fuser heats up, but density is...


The thermostat on the fuser is failing. Toner requires the fuser to operate at a specific temperature range, too hot or too cold and it begins to stick to things it shouldn't and fall from things is should (like your paper)...in your case the thermostat is not stopping the fuser as it gets too hot. Not only will this eventually cause scoring and melting inside the printer, possibly fire...it means the printer only prints well as the fuser heats up through it's optimum range then you begin to get smearing.

May 07, 2009 | GCC Technologies Elite XL 608 Laser...

2 Answers

Imac / illustrator10


According to something I read in another forum:
Use migration assistant (in utilities) to copy over Illustrator 10 via firewire from your G4 to your imac. This is the only thing that might work without upgrading to a newer version of Illustrator. 

I'm planning on trying it with both Illustrator 10 and Indesign 2.0 - Photoshop 7 won't go at all no matter what one tries according to what I've read. I'll be upgrading to CS3 for Photoshop. No choice.

Jun 29, 2008 | QuarkXPress Passport 6.0 for Mac

1 Answer

Illustrator to photoshop


Here is everything you will need. I hope you will find this worthy of a FixYa rating.
Import Illustrator CS2-CS3 artwork into Photoshop CS2-CS3
What's covered In Adobe Photoshop, you can import Adobe Illustrator artwork in several different ways, each of which offers a different level of control. When you open or place AI, EPS, or PDF files created by Illustrator, Photoshop rasterizes vector artwork and removes the ability to edit transparency, fonts, layers, and paths. To retain more control over imported Illustrator artwork, Adobe recommends that you drag or paste it into a Photoshop image or export it in Photoshop format.
Drag Illustrator artwork into Photoshop Dragging Illustrator artwork is the quickest way to import it into Photoshop. By default, Photoshop creates a new layer for the dragged artwork and imports the artwork as a Vector Smart Object. (For more information, see "Smart Objects" in the Photoshop Help.) You can import dragged vector artwork as a work path, however, by holding down Control (Windows) or Command (Mac OS) while dragging. To center imported artwork in the Photoshop image, hold down Shift while dragging.
Note: To import dragged type as a work path, you must first convert it to outlines in Illustrator. For more information, see "Modifying letterforms as graphic objects" in Illustrator Help.
Paste Illustrator artwork into Photoshop When you copy Illustrator artwork, you can paste it into Photoshop and retain many Illustrator features. To do so, however, you must properly configure Clipboard preferences in Illustrator.
Clipboard preferences in Illustrator
The Illustrator Clipboard supports a variety of formats including: PICT, PDF, and AICB. Though Illustrator always copies PICT data to the clipboard, you can configure Illustrator so that it also copies PDF or AICB format. These two formats allow you to retain Illustrator features in artwork pasted in Photoshop. PDF retains Illustrator transparency, while AICB format retains Illustrator paths.
You should only select the AICB format by itself if you are going to be pasting paths in to Photoshop. In all other cases, select the PDF format or the PDF format in conjunction with AICB. The PDF format retains transparency and other features in Illustrator such as extended support for spot colors.
To configure Clipboard preferences in Illustrator:
  1. Choose Edit > Preferences > Files & Clipboard (Windows) or Illustrator > Preferences > Files & Clipboard (Mac OS X).
  2. In the Clipboard section, select the desired format.
  3. If you selected AICB, select either Preserve Paths or Preserve Appearance.
  4. Click OK.
Paste options in Photoshop
When you use the Paste command to import copied Illustrator artwork, Photoshop provides the following options in the Paste dialog box:
  • Paste as Smart Object: Pastes the art as a Vector Smart Object that can be scaled, transformed, or moved without degrading the image before it's placed into the Photoshop document. As the art is placed, its file data is embedded in the Photoshop document and the art is rasterized on a separate layer.
  • Paste as Pixels: Pastes the copied artwork in a new layer and rasterizes it at the resolution of the Photoshop image. Use this option when pasting raster objects.

    Note: When you use this option, clipping masks for raster images are not retained as paths. These masks still clip images, however.

  • Paste as Path: Pastes the copied artwork as a work path.
  • Paste as Shape Layer: Pastes the copied artwork in a new vector shape layer. Compound Illustrator shapes retain their attributes and remain editable. Multiple copied paths and clipping masks are pasted as multiple paths that use the unite attribute .

    Note: When you use this option, pasted objects use the foreground color in Photoshop, not the fill color they use in Illustrator. Likewise, transparent objects become opaque.
Export Illustrator files in Photoshop format Exporting Illustrator documents files in Photoshop format gives you the most control over Illustrator artwork in Photoshop. With this method, you can specify resolution and enable anti-aliasing for rasterized artwork. You can also retain the following Illustrator features:
  • Editable text
  • ICC profiles
  • Layers, including nested and hidden layers
  • Masks
  • Transparency
  • Compound shapes
  • Slices and image maps
Note: A compound shape must have either no stroke or a stroke with a round join that uses whole integers for the stroke weight. However, the compound shape can reside on a layer with other objects. In that situation, Photoshop places the other objects on a separate layer in the same layer set.
For more information about exporting Illustrator files in Photoshop format, see "Photoshop export options" in Illustrator Help.
Open Illustrator (AI) files in Photoshop You can open AI files in Photoshop if you save them using the Create PDF Compatible File option.
To save an AI file using the Create PDF Compatible File option:
  1. Choose File > Save As.
  2. Choose Illustrator (*.AI) as the file format, and click Save.
  3. Click Create PDF Compatible File in the Illustrator Options dialog box, and click OK.
Thanks,
Lee

Jun 18, 2008 | Adobe Photoshop 7.0 for PC

Not finding what you are looking for?
GCC Technologies Elite XL 608 Laser Printer Logo

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top GCC Technologies Office Equipment & Supplies Experts

kakima

Level 3 Expert

101545 Answers

k24674

Level 3 Expert

7993 Answers

yadayada
yadayada

Level 3 Expert

67912 Answers

Are you a GCC Technologies Office Equipment and Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...