Question about Creative Labs Gigaworks S750 Computer Speakers

1 Answer

Sub has died overnight

My Gigaworks S750 were working fine last night, never had any problems with them in the past, then I wake up this morning and they will not work. The power LED on the rear of the sub is not lit up and the control pod is also dead.

Does anyone know if there is anything I can do to fix this?

Thanks in advance!

Posted by on

1 Answer

Change the fuse - located at the 220V input. Use a knife ti release it. Then the system will work again.

Posted on Oct 17, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Creative Gigaworks S700 i have checked both fuses still no power to control box


Stupid question: does the sound still work? it could be the LED just died after continual use (rare, since they last a long time, but not uncommon).
If not... it could be the controlling circuit board died. In which case, unless you have electronics repair experience, it would be probably more worthwhile to just replace the speakers, as pricey a model as it is.

Mar 23, 2012 | Creative Labs Gigaworks S750 Computer...

1 Answer

My gigaworks s750 powers up and lights, but no sound


Hi, have you find any solution? I got the same problem. Can you please email me. mtlmw@hotmail.com. Thank you

Feb 26, 2012 | Creative Labs Gigaworks S750 Computer...

1 Answer

Creativr Gigworks S750 Subwoffer intermittent sound


The S750 system is a great sounding one but unfortunatly like many similar systems all the amplifiers and power supplies are housed inside the sub box. This means they suffer badly from heat and vibration problems (they cook themselves or shake themselves apart). I have fixed a few S750 systems in the past but due to their complexity it's not for the faint hearted.

May 26, 2009 | Creative Labs Gigaworks S750 Computer...

1 Answer

Left front speaker works the rest dont and the sub makes a hum


Either you have it configured incorrectly this time around, or the settings are defaulted back to original on your DVR........ adjust your DVR sound properties/settings. and check all wires/connections as well.

Apr 20, 2009 | Creative Labs Gigaworks S750 Computer...

2 Answers

All I need is the control pod for the Gigaworks S750


I had an extra one but I sold it. According to creative labs they do not sell any replacement parts for the speaker systems. The best suggestion that I can give is to check craigslist and ebay for the control pods.

Dec 13, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Audio control pod seems dead


You can see about getting a new control pod from ebay or craigslist but the problem is more likely inside the subwoofer. Below I have pasted a link to a forum thread about fixing the Gigaworks S750 systems. There is not much information there about control pod problems but at least the people on the thread will help as much as they can. If you are not familiar with electronics then some of the people on the forum thread can help if you are willing to ship the subwoofer box to them.

http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=1

Nov 09, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Gigaworks


I could buy your sub if you want the power system in the sub is vary complex and it normaly fails on most peoples systems but i already had a custom amp and know want to use the woofer in my system email me if you interested

Sep 11, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Gigaworks S750 Sub - Pops and Cuts Out


There is obviously a problem on the amp board with 3 STA575 amplifiers. It may be that one of the diodes is shorted or one of the capacitors has dried up or shorted. For more information I have posted a link to a forum thread that contains all of the information you would need to fix the Gigaworks S750 system. If the information has not already been posted there then you can ask on there and the people there will point you in the right direction.

http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=1

Aug 17, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Subwoofer died (again)


Read this http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=85
I was about to buy these speakers, but not after reading this

Mar 21, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Gigaworks s750


Same problem just went out after about 4 years.... weak lifespan for a 500 dollar system

Feb 12, 2008 | Creative Labs Gigaworks S750 Computer...

Not finding what you are looking for?
Creative Labs Gigaworks S750 Computer Speakers Logo

Related Topics:

324 people viewed this question

Ask a Question

Usually answered in minutes!

Top Creative Labs Audio Players & Recorders Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

618 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

Are you a Creative Labs Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...