Question about Hoover Vacuums

1 Answer

The brush rollers on my hoover mach 5 won't turn. I've cleaned everything and checked the belts and everything checks out fine. I had the vacuum for about a year.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I had the same problem. The problem is the small v-belt for the roller brush (Hoover part# 38528034). Although it looks in good shape, it's been stretched too large for the idler to keep good tension. The tension on that belt varies with the handle geometry so if you slam handle all the way down the belt gets stretched a little bit each time.

Posted on Oct 18, 2008

  • laceyt1
    laceyt1 May 10, 2012

    mine also did the same thing and i took a good look at the belts & thought they looked good, but when you turn the roller off my belt was way loose. so i started looking and the "pulley" (idk what its really called) was worn down the dumb thing is made from plastic so the belt had been wearing it down until it just got loose enough to not work. I haven't looked into fixing it or how much the part is but hope this may be helpful. I was not very happy with the cheap make and I spent $200 bucks on it.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Brush won't spin on hoover wind tunnel bag less upright when on carpet, belts are fine


The belts may look fine but may be stretched and worn. Replace them. Make sure brush spins free. Idler pulley should tighten belt tension when handle is released

Jul 25, 2014 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Where is the belt located on my hoover steam shampoer


There is probably not a belt. The brushes on the carpet cleaner head and attachments work from air and there is a roller bearing deep inside that will wear out and the brushes won't turn. I've found no way to fix this. I consider it a design defect.

Apr 20, 2011 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

The roller brush will not turn. The belt is not


Hello,

Sometimes the belt can stretch cause the roller to not turn. Also make sure the roller brush is free of any debris.

Use this link to access your vacuum to change belt or clean the roller brush.

http://www.info-vacuum-cleaner.com/hoover-vacuum-cleaners.php

Hope this helps.

Jan 27, 2010 | Hoover U5068-900 Sprint Upright Vacuum

1 Answer

The belt on my hoover cordless is not spinning when I turn it on


You need to replace the belt. Even though the belt may look fine it can be stretched and therefore it won' t turn the roller brush against the resistance of the carpet. You can get Hoover replacement belts here:

Hoover Replacement Belts

Oct 29, 2009 | Hoover Vacuums

2 Answers

Hoover mach 5 turns off after 10 minutes of use


I have had problems with the belts on my Mach 5 overheating (smell of burning rubber) and also with the motor overheating and shutting down.
I learned the hard way that one of the issues might be that the roller/brush on the bottom of the unit has a metal bearing inside the roller/brush that can become clogged with hair (both human and pet hair) which effects performance of the unit.
Another item to check is if your dust filter is not plugged up which is located behind the removable dirt cup. This is the cup that you remove that collects the dust/dirt/hair from your floor. Take the removable dirt cup out by depressing the gold button and then look behind where the dirt cup sits for filter. This can be cleaned out by washing it with soap and water in the sink but make sure you let it dry overnight before placing it back in the machine. This probably causes some of the overheating when not enough clean air is passing through the machine.
It’s fairly easy to fix.
Lay the vacuum on the floor so that you can see the roller/brush. Then remove the phillip head screws that hold the protective plastic plate over the roller/brush. (There are about 6 screws that hold this plastic protective plate in place) Also, you will be removing the (1) screw that also holds the plastic plate over the belts. There are (2) belts that you can remove and when in doubt replace these (2) belts for around $9.00.
Once you have the protective plastic plate off that covers the roller/brush disconnect the belt is around the roller. Take the roller and cut off any hair that is wrapped around the roller. Next, grab the roller by each end and twist the ends caps and (1) of the ends will unscrew. Once you have unscrewed one of the ends remove any hair or dust that is trapped under this cap. (Be careful not to lose the small metal washer that sit on top of the bearing)You will notice under this cap is a metal bearing that can become clogged and jammed with hair. The hair should come out fairly easy and allow the brush to spin fairly easy once you have screwed the end caps back in place test that it spins freely. If it doesn’t spin freely replace the roller/brush with a new one for about $23.00.
When you put the belts back on the thick rubber one (Belt # 40201-271) has probably become stretched and should be replaced for about $3.00. The small diameter belt that goes over the roller/brush probably does not usually need to be replaced and does not usually fit very tight. I have heard that people will take the small roller/brush belt and turn it upside down to get a better fit.
I just did this on my Mach 5 and it runs like a new machine. I did end up replacing the roller/brush head.
Hopefully you will find this useful.

Oct 01, 2009 | Hoover U5194-900 Mach5 Multi-Chamber...

2 Answers

My brush will not turn, and the brush control is stuck on "off"


I have had problems with the belts on my Mach 5 overheating (smell of burning rubber) and also with the motor overheating and shutting down.
I learned the hard way that one of the issues might be that the roller/brush on the bottom of the unit has a metal bearing inside the roller/brush that can become clogged with hair (both human and pet hair) which effects performance of the unit.
It’s fairly easy to fix.
Lay the vacuum on the floor so that you can see the roller/brush. Then remove the phillip head screws that hold the protective plastic plate over the roller/brush. (There are about 6 screws that hold this plastic protective plate in place) Also, you will be removing the (1) screw that also holds the plastic plate over the belts. There are (2) belts that you can remove and when in doubt replace these (2) belts for around $9.00.
Once you have the protective plastic plate off that covers the roller/brush disconnect the belt is around the roller. Take the roller and cut off any hair that is wrapped around the roller. Next, grab the roller by each end and twist the ends caps and (1) of the ends will unscrew. Once you have unscrewed one of the ends remove any hair or dust that is trapped under this cap. (Be careful not to lose the small metal washer that sit on top of the bearing)You will notice under this cap is a metal bearing that can become clogged and jammed with hair. The hair should come out fairly easy and allow the brush to spin fairly easy once you have screwed the end caps back in place test that it spins freely. If it doesn’t spin freely replace the roller/brush with a new one for about $23.00.
When you put the belts back on the thick rubber one (Belt # 40201-271) has probably become stretched and should be replaced for about $3.00. The small diameter belt that goes over the roller/brush probably does not usually need to be replaced and does not usually fit very tight. I have heard that people will take the small roller/brush belt and turn it upside down to get a better fit.
I just did this on my Mach 5 and it runs like a new machine. I did end up replacing the roller/brush head.
Hopefully you will find this useful.

Jul 05, 2009 | Hoover U5194-900 Mach5 Multi-Chamber...

2 Answers

Hoover mach6 the brushes don't turn


Replace the skinny belt, but here's the kicker. turn the belt inside out so that the writing is on the inside and sits against everything. Thats what I did and I have used it once and it worked well, Lets hope it'll keep working.

May 20, 2009 | Hoover U5194-900 Mach5 Multi-Chamber...

1 Answer

Vacuum shuts off and has a burnt smell


Hi,
Try removing the drivebelt, and try running it to test like this. The brush bar will not turn, but it should function normally without smell at this point. If it doesn't, you may need a new motor as I think the brushes may have worn down - producing an electrical type burning smell.

If it runs fine without the belt attatched, then there is probably a build-up of hair or threads at each end of the roller stopping it turning freely. With the hoover off, check it turns freely and easily. A small metal nail file or similar is usually a good tool to clear it.

If the roller is stiff, the belt will not turn easily, and overheat on the motor spindle - causing the burning smell.

Jan 08, 2009 | Hoover Vacuums

4 Answers

Brush won't spin on my Hoover Mach 5


I love this vacuum but had the same problem.

SOLUTION:
take the roller off and flip the thin belt inside out. This fixed my vac and works great again.

Oct 12, 2008 | Hoover U5194-900 Mach5 Multi-Chamber...

1 Answer

Self propel not working, burning smell


Flip the vacuum cleaner over and check the roller brush. Is it full of string and hair? If so, unscrew the four phillips-head screws holding the plate on that covers the roller brush; pull out the brush, and cut off/clean off all the hair and string. Replace everything and try running the vacuum. Alternate solution: perhaps the belt that makes the brush go around is broken. If so, follow the above steps to remove the roller brush, then replace the belt.

Oct 11, 2008 | Hoover Ultra U6430-900 WindTunnel Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

275 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18333 Answers

Roger Potts

Level 3 Expert

694 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...