Question about Sony FD Trinitron WEGA KV-21CL10 21" TV

1 Answer

Sony Trinitron KV-19TS20 Screen displays purple static or awful image.

I have a Sony Trinitron Model # KV-19TS20 Serial # 8070005 Manufactured in July 1990. For some obscure reason, when the TV is set to Cable/Analog (not the yellow/white/red back ports, all i get is purple snow, audio mixed with high pitched whining and no image, or a barely discernible image with audio mixed with the high pitched whining, which will move back and forth around the pitch.

However, it works perfectly in the yellow/white/red setting. I'm figuring it has have something to do with the cable port. The cable port was severely bent down after a stunt I pulled try to balance the TV on a pile of books, which resulted in it falling forward and almost onto me, and was stopped by the cable wire. BUT: it has had the above problem for several years before the cable port was bent. And when airplanes flew over the house, it would randomly kill the TV and all we would get is snow coupled with high pitched whining.

Help would be greatly appreciated. Hopefully this won't result in part replacement, but the way it looks, it most likely will.

NOTE: the product entered in the product box is MOST LIKELY not the right product. I'm not totally sure what product it actually is, so I went with the closest screen size.

Posted by on

  • 4 more comments 
  • DeathChain01 Oct 02, 2008

    Thanks, but I don't really have a choice of TV. It's this one or nothing. I also forgot to mention that the audio (while in yellow/white/red mode) will randomly shut off and turn back on at random intervals, but ranging around 10 - 20 minute periods, both ways. I'll try nab a tuner from a flea market or something, and see what happens.

  • DeathChain01 Oct 03, 2008

    here's another quality I forgot to mention: it works perfectly OCCASIONALLY. ie: one day I will get regular cable TV, and the next day it will give me purple snow and just whine it's high pitched whine. and some days it will do both.

  • DeathChain01 Oct 08, 2008

    I'm in East Greenwich, RI, USA. I'd appreciate a part list, so when I get some money maybe I could try to fix it.

  • DeathChain01 Oct 08, 2008

    OH! And a quick info update!: i figured out that the sound shutting off is fixable if i hold the back of the TV a certain way. I'm figuring there's a broken sauter in the audio area. but I still have no clue about the rest. so i figure I'll go check the sautering out eventually.

  • DeathChain01 Oct 09, 2008

    WELL. The first thing I noticed is how DISGUSTING it was in there. I've opened two older TV's before, but this one takes he cake. After looking around a bit more, I saw that the sauter points on the small plate that connects to the VERY back (the narrow tube with metal in it) were pretty rusted.Everything else appeared to be fine, just VERY dirty. It's too late/early (depending on how you look at 1:12 AM) to go clean it out. And I have it sitting on next to me, and I noticed that the pitch of the whine slowly decreased to a very deep throaty (sounds somewhat like an F1 car engine at a slow spped), slowly rose again til it sounded like an F1 car at top speed, the rocketed back down to the throaty whine, and then BAM. A perfect picture (for 1990's standards anyway). But it looks like a staticky image. Like there's TV snow going on in the background, while it's getting a picture. it shouldn't do that, since it's cable, right? Although it is hooked up through a partly broken VCR so I can attach to TV Cable wires together so it'll reach where the TV is. I'm also wondering if it's trying to scan the channel frequencies but something isn't letting it do so. Or I'm just stating a useless obseravtion that has absolutely nothing to do with the problem. But I do know that the CRT base sauter's are rusted, and I know that I DON'T know how to fix rusted sauters. Broken sauters, yes. Rusted, not a chance.

  • DeathChain01 Oct 09, 2008

    Quick addition to above comment: remember that it doesn't have this problem AT ALL in Video mode. But it does in Cable mode. So I just don't know.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

This unit needs a tuner. A new one from Sony will run over $70, so I doubt that it is worth it. It is possible that poor ground connections could cause something like this, but the symptoms seem a bit too severe. I think it is time to invest in a newer set.

Dan

Posted on Oct 02, 2008

  • ABRsvcs Oct 03, 2008

    Thanks for the update. I'll need to research this a bit more. Where are you located so I can give you some parts sources?



    Dan

  • ABRsvcs Oct 08, 2008

    If you can solder, you should be able to fix this yourself. Open up the unit and resolder any connections on the board that appear to be grainy or have rings. That should resolve the problem. Given the age of the set, it is likely that there are a number of poor solder connections. If some are at or near the tuner, the symptoms you describe can occur.



    Please keep me posted on your progress.



    Dan

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Standby lighy blinks tv won't turn on


error code 4 is vertical deflecton failure . replace the vertical deflection ic. and the electrolytic capacitors in the vertical circuit. Or if you are lucky just resolder the vetical IC and resolder th horizontal section too.

Sep 28, 2009 | Sony FD Trinitron WEGA KV-34HS420 34" TV

1 Answer

Sony Trinitron KV 27


Please count the blinks and post that number. That is an internal diagnostic code that will indicate the problem circuit. From that I can give you probable repair parts and costs.

Thanks,
Dan

Dec 24, 2008 | Sony FD Trinitron WEGA KV-32FS100 32" TV

1 Answer

Sony trinitron 32 " purple area on screen


Check any magnatic device near TV which causes purple color on screen. That device can be Speaker, Electronic toy, Watch like that carring piece of magnet inside. Remove that device and turn OFF your TV for half a hour, then power again. Hope the color will be fine n normal on entire screen.

May 31, 2008 | Sony FD Trinitron WEGA KV-32XBR400 32" TV

1 Answer

GREEN AND PURPLE LINES ACROSS THE SCREEN


This is a symptom of the circuit failing.
it will soon be much worse.
You need a tech.
you can verify it is the tv circuit.
remove cable or input another signal such as dvd
bring up the TV' menu. does it have the lines.

Jan 15, 2008 | Sony FD Trinitron WEGA KV-32FS120 32" TV

1 Answer

Sony Wega model # KV-36FS12 it doesn't work can u help me?


This is due to humidity in your area. Due to moisture content screen control section getting corrosion. cleanit and adjust the screen control to get the normal picture.

Aug 10, 2007 | Sony FD Trinitron WEGA KV-27FS100 27" TV

1 Answer

Sound Problem


There's a possibility that you may be experiencing problems with the audio output IC -IC404 - All serial numbers produced until July 2003 might use one of these defective IC's. So if your set was manufactured before this date, that is probably the culprit. If not, and you have it connected to a cable box that has its own volume control, it could be that its volume is turned down and by turning up the TV's volume too high that you are getting this distortion. Hope that helps.

Jan 20, 2007 | Sony FD Trinitron WEGA KV-20FS100 20" TV

Not finding what you are looking for?
Sony FD Trinitron WEGA KV-21CL10 21" TV Logo

221 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Standard (CRT) Televisions Experts

The Knight
The Knight

Level 3 Expert

68427 Answers

Jaime Hernandez

Level 3 Expert

2267 Answers

matt martin
matt martin

Level 3 Expert

1191 Answers

Are you a Sony Standard (CRT) Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...