Question about Audio Players & Recorders

Open Question

Mutant car amp NW480SP wen wired up n turned on the protection on the amp seems 2 stay on, i wud like 2 know why this is and how to stop it

Posted by on

  • Anonymous Mar 29, 2009

    safe mode



×

1 Suggested Answer

emissionwiz
  • 67911 Answers

SOURCE: mutant amp protection off

this is caused by a shorted output transistor(s) in the main amp.

Posted on Jun 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

S-protection


This means that there is a short detected on one of the amp outputs. Try disconnecting the speakers from the back of the unit and power on. If fault still persists then likely you have a bad output ic or FET (transistor). If fault goes away after removing speakers then plug them in one by one to see which is the culprit.

Jan 12, 2017 | Audio Players & Recorders

1 Answer

How do I test for a poor ground wire as opposed to a bad ground wire?


One tiny wire has very little resistance. Turn up your Ohm meter to it's highest setting. Be sure to have it calibrated exactly the same for each test (zeroed out). The very good connection should read infinite but the tiny connection should show a tiny bit of resistance. It's difficult but not impossible. Get a friend to help so the resistance in your body doesn't affect the data. Use one hand and new clips.

Jan 23, 2015 | Audio Players & Recorders

1 Answer

My radio makes popping sound when on for about 20minutes but when i turn volume up it stops but sound is disorted.any ideas on problerm


Sounds like there's wires touching and it's grounding to its self or there's a bare wire rubbing on body. Check all speaker wires in trunk or back to which are the ones easiest to vet messed up

Jan 09, 2015 | Audio Players & Recorders

1 Answer

My aftermarket radio won't play any music out but when I put my stock radio back in everything works fine the aftermarket radio worked for a few weeks but then it stopped playing music out recently Any...


think the amp may have blown this is the problem with some after market radio's with the same wiring code as yours. best just ot get the radio you want and buy the adapter kit for it.

Mar 23, 2014 | Audio Players & Recorders

2 Answers

Hi,Just purchased 2 antec gain Bluetooth receivers type bxr 100. Operating instructions are not included. Maybe it's just me, but i'm not succeeding in getting them to work. No lights at all when they


Make sure that the unit is fully charged by a micro USB the light on it will be red until it's fully charged put phone in search mode and press the center button until the light flashes red and blue after the phone finds it you should have an option to auto pair when it's not in use it will turn off when paired and working pressing either track button will start the music player then just play with the buttons and see what it does you can stop anything from the phone controls

Mar 18, 2014 | Antec BXR-100 Gry Audio...

2 Answers

Connect an active soundbar to a receiver


What if the soundbar is Bluetooth? Will I still be able to use that function and connect the active soundbar to the tv (Bluetooth) and connect the av receiver for other surround sound speakers? (they are pre-wired in the walls in the apartment I moved into)

Jan 08, 2013 | Audio Players & Recorders

1 Answer

It wont turn on, it shows 'push power protect' when you turn it on, or disconnect it and reconnect, i already attempted to disconnect the Sony Stereo MCH-EC909iP Mini Hi-Fi and it shows 'Push Power, P


The only thing I can think of is its goin into protection mode like an amplifier would, you maxed the volume out and it's protecting your speakers or you don't have the right voltage going to it, I can see you don't have it on a straight 120v plug and you might have the wiring wrong on the speakers to it might be too low of a ohm or too high

Nov 22, 2012 | Audio Players & Recorders

3 Answers

Flashing blue light


1. turn it off2. hold centre button until blinking blue and red3. briefly press volume down4. turn it off= fixed :)
From Sennheiser UK:http://www.sennheiser.co.uk/uk/home_en.nsf/root/contact_menu_technical-question_telephone_headsets_faqs_mm400_series_bluelight

Jun 19, 2012 | Sennheiser MM 550 Wireless Headphones

2 Answers

My headphones connect with the adapter, the blue light is on on both but nothing comes from the ipod. I have performed the factory reset but it still doesn't work. The headphones had worked fine and then...


I have same issue....just took my transmitter apart - the wires connecting the male jack to the silicon board are frayed, disconnected.....you might check that...it's only 2 small screws holding the outercase together....be careful though

Jul 07, 2009 | Logitech Bluetooth Wireless Headphones

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

491 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

101516 Answers

 Grubhead
Grubhead

Level 3 Expert

4751 Answers

The Knight
The Knight

Level 3 Expert

71611 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...