Question about Audio Players & Recorders

5 Answers

BMW BM54 amplifier.Has a output fault - Audio Players & Recorders

Posted by on

  • sandbacka Feb 23, 2009

    Only get sound sometimes for a short time when it is over like -15 Celsius outside. Sound gradually dies/distorts and fades away. Most likely internal amp failure. Could the amplifier parts inside be changed somehow? This would probably require some precision soldering...

×

5 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

This is generally caused by nothing more than dry solder joints. Adding more solder to the pcb 'attachments' usually works. Certainly a first step!

Posted on May 29, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Found a guy called xkalibar, who seems to know everything about these bmw bm54 Becker units. Not only did he repair the unit, but improved sound quality with larger amps, updated firmware to allow mp3 id3 tag and dynamic routing, added rca preouts and aux in.
His email is xkalibar@gmail.com

Posted on Apr 20, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My BM54 becker radio amplifier has stopped working, only a few speakers were working. I sent my Becker BM54 to BM54.com (cartronicsgb) and they repaired it and sent it back within 24hrs!

All working now.

Posted on Sep 29, 2011

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

How much did bwautorepaires.co.uk charge to repair the amp?

Posted on Jun 14, 2010

  • richard_l448 Jun 14, 2010

    how much did bwautorepaires.co.uk charge to repair your amp?


×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Had my bm54 repaired from bwautorepaires.co.uk
the amp inside had packed up

Posted on Apr 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

System on standby due to short circuit, how do i repair


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Dec 12, 2011 | Kenwood Audio Players & Recorders

1 Answer

Marantz sr6001 stanby blinking


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Dec 09, 2011 | Marantz SR6001

1 Answer

Pioneer VSX-D511 5.1 Channels Receiver over heated and now won't turn on?


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Dec 04, 2011 | Pioneer VSX-D511 Receiver

1 Answer

I have a Denon AVR 4806 that I have been told is stuck in protect mode. Pressing and holding the two direct buttons does not work to reset it. Anyy other possible solutions? Thanks


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Nov 30, 2011 | Denon AVR-4806 Receiver

1 Answer

Why do my amp shut off on standby when i turn it on


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Nov 29, 2011 | Audio Players & Recorders

1 Answer

575 ds will not power up even though standby power is present


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.If the set does not power from the standby the processor IC and allied circuit must be checked. Check the +5 rail to the processor to confirm.

Oct 30, 2011 | Onkyo TX-DS575 Receiver

1 Answer

When i turn on my kenwood kr-v990d it powers up for about 2min then shuts down


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Oct 23, 2011 | Kenwood KR-V990D Receiver

1 Answer

There's no sound with my STR-V555ES 5.1 channels and there is protector in display


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Oct 21, 2011 | Sony STR-V555ES Receiver

1 Answer

My panasonic amplifier when i switch on only f70 desplay may i know the problem pls.


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be your output drivers- the MOSFETS/IC's fitted for both the channels, Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise like a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.
You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board, maybe the protect circuit by itself is shutting off due to a faulty bias , maybe a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the protect is off then check for short on the speakers

Aug 22, 2011 | Panasonic SA-HE7 Receiver

1 Answer

Hi home audio is bad how can i fix it up..Not coming ..


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Mar 30, 2011 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

2,583 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

98694 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69654 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...