Question about Akai LCT2715 27 in. LCD Television

5 Answers

AKAI MLT168A Power Supply

Do you a schematic diagram on this Power Supply? I have bulged (bad) EC9, EC10, EC18, EC19, and EC20 Caps. I also have shorted Zener Diodes Z3, Z4 and Z5. I believe Z3 in a 27v zener, but do not know the values of Z4 or Z5. There also may be another shorted diode below HS1. Any component values or help will be appreciated.

Posted by on

5 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,296 Answers

Here are the values for the parts:
R104 and R105 are 100 ohms 5% 1 watt but you can use 2 watts.
R107 is 200 ohms 5% 1 or 2 watts.
C17 is 2200pF 10% 1Kv.

Posted on Dec 06, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

If I give you the values of Z3, Z4 and Z5, would you return the favor by telling me what are the values for R104, R106, R107 and C17?

I have posted this request 5 times for 2 months and no body gave me an answer. Would you be willing to work with me? E-mail me s69joe@hotmail.com and use MLT168A-fixya as subject
Thanks

Posted on Nov 22, 2008

  • Jones1234 Dec 11, 2008

    Hi Jaimie867... thank you very much for your post, but I'm afraid it was a bit too late... I just brainstormed and used a 1oo ohms 1 watt for R104 & R105, and since R106 was 2 K ohm, I used a 2.2 for R106... from my electronic expertise, I know that they usually have some of those resistors in parallel thus equal values... it seems to be working fine now.... I'll e-mail you if I run into other problems ...you are the man... let me know if I can help with anything...thanks again

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hey guys: i have an mlti68a that flashes the akai screen for 2 seconds and the screen goes black again.. have replaced all "big" caps on ps board to no avail:do not here "click" on power-up...fets? , relay?...diode?...
please help... thx.jim

Posted on Nov 18, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Ps. mlt168a no voltigis in secondary side

Posted on Nov 11, 2010

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 3 Answers

Hi guys,

You can find the service manuals at:
http://esi.fox-international.com
(Make sure you use Internet Explorer to access the website - it won't work with Mozilla Firefox)

I have an LCT2701TD which I've been trying to get to work with no success (yet). It has a MLT166A power supply, but I bet it's pretty similar to the MLT168A. So my question to you guys is: how do you know what to replace (other than obviously bulging capacitors)? I replaced the bulging capacitors (EC18, EC19, and EC20) and the Z3 zener diode and still no success. I have a multimeter, so should I just start removing capacitors and diodes and testing them one by one?!?! Please give me some pointers if you can.

Kris


Posted on Jan 14, 2009

  • Thiag Dec 12, 2012

    Hi... Can you let me know the values for Zener Z3, Z4 and Z5? Thanks in advance.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Delay light is flashing on tv, but wont turn on. Not sure if problem is tv or remote? Dont see light on remote when push in buttons?


The problem with the unit is power supply part number,MLT166A.If you can not find one you can try to fix yours.First you have to take out power supply,Replace 3 electrolytic caps EC18,EC19,EC20 all are 1000mf at 16 volt.Then find Z3 on same board,it is a 27 volt zener diode 1 watt,part number 1N4750A.Put board back in then unit should work.

Oct 03, 2009 | Akai LCT3701AD 37 in. LCD Television

1 Answer

Akai LCT3285TA Television won't turn on


the problem is in the power supply(they know about it good luck fighting them)but there is good news.you can remove the power supply and replace electrolytic caps,EC18,EC19,EC20 all of them are 1000mf at16 volt use 1000mf at25 volt.you can also go to shopjimmy.com enter model number you will see power supply part number MLT169B
it will be cheaper for you to replace the caps,the board cost about $80.00 from them

Sep 24, 2009 | Akai LCT3285TA 32 in. LCD Television

1 Answer

Tv shuts off when you turn it on again it will play a minute


I think this might be bad/swollen capacitors in your power supply, or something odd in the +5VDC circuits of the power supply, but I am posting all of the things I have found so far with these TVs.

Here are few possible solutions:
If you have no red light and you have a Megmeet MLT386 power supply, check these parts:
1) Swollen caps on the PS secondary circuit (may cause the red light blink or shutdown problems).
2) Blown fuse F1 (5A/250V) this is caused by a shorted FET at QA1 (20N60), you may also find that SMT cap CX23 is burned up (.001uf) which is in parallel with diode DA2 which may be damaged/shorted, replace these components.
If the power LED goes from red to green when powered up but no picture, then it might be lost +24VDC from the power supply:
3)Check fuse F2 (3.15A/250V, I put a 5A in), if it is blown, replace FET at QA2A (9N50C), replace QA2 as well (9N50C). Check SMT resistors at R233,R234,R235,R236 (.47 ohm). If open, replace with .1 ohm 1W or 2W resistor (easier to source). Also replace SMT transistor QF1 (2X4 or 2N4401 NPN transistor). And replace diodes at DS2 and DS1 (HER207), DS2 was shorted, DS1 was ok but I replaced it anyway.

I dont know as much about the Megmeet MLT169A, but it has similar problems and similar components.
4) I had to replace all of the capacitors in the secondary circuit (there are six in a 3x3 row marked EC9 (1000uf35V),EC10(1000uf35V),EC14(470uf35V) and EC18,EC19,EC20 (all 1000uf35V).

OK for the Megmeet MLT169A with red flashing LED when turned on we found that IC7 was bad. This is an SMT component on the solder side of the power supply. It is a 4407P (P channel 30V MOSFET). For testing purposes, we jumped across it to feed +5V to the TV permenently instead of allowing +5V to go into standby.

Sep 09, 2009 | Akai LCT3201TD 32 in. LCD Television

1 Answer

Can,t get it to turn on.


Does the red light come on? does it go green but no picture? Here are few possible solutions:

If you have no red light and you have a Megmeet MLT386 power supply, check these parts:

1) Swollen caps on the secondary circuit.
2) Blown fuse F1 (5A/250V) this is caused by a shorted FET at QA1 (20N60), you may also find that SMT cap CX23 is burned up (.001uf) which is in parallel with diode DA2 which may be damaged/shorted, replace these components.

If the power LED goes from red to green when powered up but no picture, then it might be lost +24VDC from the power supply:

3)Check fuse F2 (3.15A/250V, I put a 5A in), if it is blown, replace FET at QA2A (9N50C), replace QA2 as well (9N50C). Check SMT resistors at R233,R234,R235,R236 (.47 ohm). If open, replace with .1 ohm 1W or 2W resistor (easier to source). Also replace SMT transistor QF1 (2X4 or 2N4401 NPN transistor). And replace diodes at DS2 and DS1 (HER207), DS2 was shorted, DS1 was ok but I replaced it anyway.

I dont know as much about the Megmeet MLT169A, but it has similar problems and similar components.

4) I had to replace all of the capacitors in the secondary circuit (there are six in a 3x3 row marked EC9 (1000uf35V),EC10(1000uf35V),EC14(470uf35V) and EC18,EC19,EC20 (all 1000uf35V).

Sep 05, 2009 | Akai LCT3201TD 32 in. LCD Television

1 Answer

T.v. won't turn on


The following parts can be purchased at digikey.com or mouser.com web site. I am also posting all of the things I have found so far with these TVs.

Here are few possible solutions:

If you have no red light and you have a Megmeet MLT386 power supply, check these parts:

1) Swollen caps on the secondary circuit (may cause the red light blink problem, but also see below).
2) Blown fuse F1 (5A/250V) this is caused by a shorted FET at QA1 (20N60), you may also find that SMT cap CX23 is burned up (.001uf) which is in parallel with diode DA2 which may be damaged/shorted, replace these components.

If the power LED goes from red to green when powered up but no picture, then it might be lost +24VDC from the power supply:

3)Check fuse F2 (3.15A/250V, I put a 5A in), if it is blown, replace FET at QA2A (9N50C), replace QA2 as well (9N50C). Check SMT resistors at R233,R234,R235,R236 (.47 ohm). If open, replace with .1 ohm 1W or 2W resistor (easier to source). Also replace SMT transistor QF1 (2X4 or 2N4401 NPN transistor). And replace diodes at DS2 and DS1 (HER207), DS2 was shorted, DS1 was ok but I replaced it anyway.

I dont know as much about the Megmeet MLT169A, but it has similar problems and similar components.

4) I had to replace all of the capacitors in the secondary circuit (there are six in a 3x3 row marked EC9 (1000uf35V),EC10(1000uf35V),EC14(470uf35V) and EC18,EC19,EC20 (all 1000uf35V).
OK for the Megmeet MLT169A with red flashing LED when turned on I found that IC7 was bad. This is an SMT component on the solder side of the power supply. It is a 4407P (P channel 30V MOSFET). For testing purposes, we jumped across it to feed +5V to the TV permenently instead of allowing +5V to go into standby.

Aug 19, 2009 | Akai LCT3785TA 37 in. LCD HDTV

1 Answer

TV won't turn onthe red light just blinks when I push the power button.


I think this might be bad/swollen capacitors, or something odd in the +5VDC circuits of the power supply, but I am posting all of the things I have found so far with these TVs.

Here are few possible solutions:

If you have no red light and you have a Megmeet MLT386 power supply, check these parts:

1) Swollen caps on the secondary circuit (may cause the red light blink problem).
2) Blown fuse F1 (5A/250V) this is caused by a shorted FET at QA1 (20N60), you may also find that SMT cap CX23 is burned up (.001uf) which is in parallel with diode DA2 which may be damaged/shorted, replace these components.

If the power LED goes from red to green when powered up but no picture, then it might be lost +24VDC from the power supply:

3)Check fuse F2 (3.15A/250V, I put a 5A in), if it is blown, replace FET at QA2A (9N50C), replace QA2 as well (9N50C). Check SMT resistors at R233,R234,R235,R236 (.47 ohm). If open, replace with .1 ohm 1W or 2W resistor (easier to source). Also replace SMT transistor QF1 (2X4 or 2N4401 NPN transistor). And replace diodes at DS2 and DS1 (HER207), DS2 was shorted, DS1 was ok but I replaced it anyway.

I dont know as much about the Megmeet MLT169A, but it has similar problems and similar components.

4) I had to replace all of the capacitors in the secondary circuit (there are six in a 3x3 row marked EC9 (1000uf35V),EC10(1000uf35V),EC14(470uf35V) and EC18,EC19,EC20 (all 1000uf35V).

Aug 10, 2009 | Akai LCT3201TD 32 in. LCD Television

1 Answer

Can someone tell me the values of the capacitors ?


EC18, EC19, EC20 are 1000uf/16v 105c
never had to replace EC9 and EC10 but should by the same value look at the size if the same as EC18 - EC20 I would go with the same value. It should be printed on the caps. If that did not fix your dead unit replace the power supply board and same time.

Check for the parts here:

http://www.mcmelectronics.com

# NOTE - If this info was helpful to anyone please click on yes!

Jun 23, 2009 | Akai LCT2721AD 27 in. LCD Television

2 Answers

AKAI LCT2785TA TV does not turn on


look closely at the electrolytic capacitors in the power supply. If you see any with the tops bulging out, replace them. Especially the 1000mfd caps labeled EC9, EC10, EC18, EC19, EC20

Jun 21, 2008 | Televison & Video

3 Answers

Akai lct2785ta 27in lcd...


After a little consideration...I believe this is a problem with the Main Board (Part Number: E7802-004008) Because the Pwr Led is blinking..that tells me that the problem most likely is not the pwr supply, but the Main Bd which controls the turning on of the Pwr Supply. This part on Vance Baldwin will cost you $289.69...however...the part is on factory back-order..which tells me that there must be a great deal of these boards going bad in the field..for them to have none in stock.....if you are in warrantee...scream til they give you a new one...if you r not...order the board and wait a month or so until it comes in...then replace it.........good luck and remember to get all the screws back in!
mike

Jan 27, 2008 | Akai LCT2721AD 27 in. LCD Television

Not finding what you are looking for?
Akai LCT2715 27 in. LCD Television Logo

2,096 people viewed this question

Ask a Question

Usually answered in minutes!

Top Akai Televison & Video Experts

Jaime Hernandez

Level 3 Expert

2296 Answers

The Knight
The Knight

Level 3 Expert

72650 Answers

Dave Naylor
Dave Naylor

Level 3 Expert

834 Answers

Are you an Akai Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...