Question about Alpine Air XL-15 Air Purifier

1 Answer

Living Air XL (no smell)

My machine produces no smell. The fuse is good and the fan works--although I did notice that the two little lights near the glass plate doesn' come on. Can you help me?

jimbosr My XL-15 is not producing ozone. I've replaced the plate, but still no ozone. I did notice that the two bulbs inside are not lighting up when the unit is on. Any suggestions?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 148 Answers

TEST THE CONTINUITY OF THE BULB AND THE WIRING AND THE PARTS INSIDE.


DOES THE UNIT STILL WORKS NORMALLY ASIDE FROM THE BULB?

Posted on Sep 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi-I have the Living Air XL. It's out for repair because I cannot smell the distinct clean smell it normally puts out. The repair guy just called and said it's fixed and running, but the green light bulb...


He probably cleaned the unit and restored the plaques. Green light or no green light, it doesn't affect the production of ozone. If still in doubt, when you go to pick it up, have him operate fit or you before you leave the store. I've had one 7years and the green light hasn't worked for three years. I clean it regularly and it still produces ozone when needed. Regular, routine maintenance is the answer.

Mar 28, 2011 | Ecoquest Living Air Classic Air Purifier

1 Answer

My living air xl-15 prove it light does not come on anymore and it seems that the unit does not prodoce ozone. I tested the light in the normal postion set at 12:00 with the plate out but to no avail....


If you are sure that the plate is clean, in perfect condition, and inserted correctly, it would appear that the transformer is defective. This means that power is not going through the metal contact fingers into the plates.

The light probably has burned out. It is not essential to the working of the machine, so it isn't anything you need to be concerned about.

Vollara (formerly Alpine/EcoQuest) is no longer producing or servicing the XL-15. However, a newer version, called the Classic, is available. You can call Customer Service 800-989-2299 and they will tell you your options. Use #16618 if you need a referral number.

Jan 08, 2011 | Alpine Air XL-15 Air Purifier

1 Answer

I no longer smell the ozone smell that i used too.


You probably have a burned out high voltage transformer. That's what produces the ozone. Helpful hint...........the high voltage transformer is also the one used in bug zappers.

May 29, 2010 | Ecoquest Breeze AT Living Air Purifier

3 Answers

Have a Living Air XL15 > everything works motor, fan, BUT .....


look through the front grill while its "on" you should see a glow from a neon lamp inside. If its not on chances are the circuit card is dead (should have about 350VDC plate voltage).
I have a used but good board if anyone needs one.
dale.gilchrist@gmail.com

Apr 26, 2009 | Ecoquest Living Air Classic Air Purifier

2 Answers

No Ozone


Mine has a switch lower right hand side that will stop the ozone.

Aug 31, 2008 | Ecoquest Living Air Classic Air Purifier

1 Answer

Air Purification Unit Model ALP-615


Moist air reduces the efficiency of ozone production for this unit. I am not sure what the water thing is about.

Did you try cleaning the glass plate or ceramic plate ozone producing unit with soap free ammonia? Also did you try using a pencil eraser on the contact points on the glass plate? I think the ammonia cleaning and contact points on the glass plate should be your first option. Check your maintenance on the units manual.

Try the manufacturers website for their trouble shooting guide...walks you through most problems and how to fix them.

Apr 22, 2008 | Alpine Air XL-15 Air Purifier

1 Answer

Living Air XL (no smell)


pull out the plates and clean contacts that touch plates with rubber eraser then put plates back in check switch on back of screen to make sure its making contact.
~~~creekkid~~~

Dec 19, 2007 | Alpine Air XL-15 Air Purifier

1 Answer

Alpine Air Living Air XL15 not producing Ozone or Deodorizing. New plates


Confirm that the appropriate sections of the circuitry are powered up and drawing power; check the interlock switch action; toss it back to the maker because the Hi-V transformer or ladder circuit or sense or hold caps were (if testing proves) never quite functional.

Dec 03, 2007 | Alpine Air XL-15 Air Purifier

1 Answer

Fan is not turning on


The fan motor is probably locked up. You can either put a little oil to free it up (usually a temporary fix) or better yet replace the fan motor.

Oct 26, 2007 | Ecoquest Living Air Classic Air Purifier

Not finding what you are looking for?
Alpine Air XL-15 Air Purifier Logo

1,211 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Air Air Purifiers Experts

Jeff Osterhout
Jeff Osterhout

Level 2 Expert

69 Answers

Tom Chichester

Level 3 Expert

24395 Answers

Are you an Alpine Air Air Purifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...