Question about Saeco Classico Espresso Machine

1 Answer

No water Hi Johnny, I successfully pulled about half a shot on my machine before realizing the water level was too low. It seems the pump then sucked air into the tubing before I could refill the water reservoir. Now the pump cannot draw any water into the tubing! The machine still makes the same sounds as when it was working properly, but I'm afraid I've damaged the pump somehow by allowing air to enter the system. What can I do? Thanks for your help.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Saeco Expert
  • 223 Answers

Sorry for not replying you to message, I was not receiving any emails from Fixya.

I hope you were able to get your machine working again.

If you still need help, you can contact me directly at johnny@cerinicoffee.com

Thanks,

Cerini Coffee
www.CeriniCoffee.com

Posted on Nov 18, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I seem to not be able to figure out the button sequence for programming the shots.


Try pressing and holding the button until the quantity is what you want it to be. Then try it again with just the normal short press to start. If it brews the same quantity as the first one then it is now programmed.

Jun 20, 2015 | Coffee Makers & Espresso Machines

2 Answers

Shot's poor extremely fast


It is possible that the pump on the machine is not operating properly. Check gauge when making shots does it go to 9 bars?

Feb 06, 2014 | Nuova Simonelli Mac 2000 Espresso Machine

1 Answer

Double shot button runs so slow you thinkit is going to stop


hi, maybe your grind is set too fine. If the grind is too fine, the water cant flow through. If your single shot flows ok, then id make the grind a bit coarser. Have you changed the blend. All blends are different. If you have not changed anything, then your pump pressure could be low. There is no adjustment for the pump. Replace pump if pressure is low.

Oct 07, 2011 | DeLonghi Esclusivo Magnifica ESAM3300...

1 Answer

I've looked up and read many of the pump problem responses and none of them seem to match my issue. Yesterday my Rancilio Silvia worked just fine. I first want to say that I clean my grouphead often...


Typically when this issue has occurred it is the pump. The pump may still run but there is no suction. This is normal once it fails. There really isn't much else in the machine for this to happen. It's rather simple inside.

Jun 04, 2011 | Rancilio Silvia Espresso Machine

1 Answer

This is an early model livia 90 (~1994). Problem is no heating of water. Pump works but neither heating light or pump light comes on. I determined the power relay was not closing. Replaced it with new...


Hi
I would check the level probes on top of the boiler. There is a yellow wire going to the high level( left) and a green wire going to the low (right) probe. The probes get scaled and do not sense water. If there is no sensing of the right probe ( low water) it will not heat. They both need to be cleaned. There is a nut or a big nut that will allow for the removal. Clean both probes and it should go back to normal.

Dec 26, 2009 | Pasquini Livia 90 Espresso Machine

2 Answers

Starbucks Sirena. lights blink, won't heat.


johnshami had this solution on another post, and it worked for us:
  1. make sure the water in the tank is stone cold -- which is a no brainer since it will not heat h2o unless it's primed.
  2. take off steamer wand cover, turn the steamer knob clockwise till pump starts.
  3. then s*ck (as you would on a straw, with your lips sealed around the end of the steamer wand) the tip of the end of the metal tip hard until pump stops
  4. may need to do it a couple of times. yes this seems crazy, but it works! you are flushing out the vapor lock in the pump.

Jun 10, 2009 | Saeco Starbucks Sirena Espresso Machine

1 Answer

Automatic astra II pulls a few great shots then error light on


The error light usually comes on when there is no water flow through the group after about 5 - 10 seconds, indicating a clog of some sort. The fact that it happens after two shots, however could indicate an issue with the processor. The problem with the steam wand could also point to a clog situation, especially in the other wand is working. First, try running shots through the problem group with no grounds at all in the portafilter; Say five or six shots if you can to see if you get the error light. Look at the water flow in the process: The water should just pour out of the portafilter. If the water is running freely and you still get the error light, you are probably looking at a processor/sensor problem. If not, it may just be a restriction. Remove the screw from the middle of the group head (the diffuser), and remove the screen and the brass plate and check them for clogging. You really want to wait until the machine is cold before you do so as the parts will be extremely hot. As for the wand, try removing it, and check it for obstruction.

Nov 24, 2008 | Astra Mega II Espresso Machine

1 Answer

Water flow


You will have to adjust your shot timing, and possibly your grind. To program the shot timing, hold the Brew Stop button until all of the brew lights come on; That means all of the buttons are ready to program. Next, pull some grind for your portafilter and push the button you want to program. For a single, you want to pull a 1 oz shot in about 15-20 seconds; longer for a double. When you push the button, the shot will start to pull; when the shot is complete, push the button again to set it. Then do the same for the next button. Each group needs to be programed separately. Holding the the Brew Stop button again will turn out the remaining lights and save your programming to that point. As to the grind, you want to have the grind fine enough to give you a quality shot in the right amount of time. Good Luck!

Oct 13, 2007 | Astra Mega II Espresso Machine

1 Answer

Doesnt work when its warm


The pumps in these are low resolution pumps and don't seem to take a lot of stress. We ran the same machine with three groups 362 days a year. You probably need to replace the pump. You should watch your gauges and be pulling 9 - 10 bars when pulling a shot. The top side of your gauges is water pressure coming in. Sounds like a new pump. Good luck.

Nov 18, 2006 | Nuova Simonelli Premier Maxi Espresso...

Not finding what you are looking for?
Saeco Classico Espresso Machine Logo

Related Topics:

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saeco Coffee Makers & Espresso Machines Experts

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Ray Murphy

Level 2 Expert

67 Answers

eyecam

Level 2 Expert

86 Answers

Are you a Saeco Coffee Maker and Espresso Machine Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...