Question about NAD T752 Receiver

1 Answer

Can't get the tuner to work

The amplifier section works fine but I can not get it to switch to the tuner section

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 31 Answers

Hi,
I'd like a little more info, but I may be able to help anyway based on my experience with these....
Does the T752 behave this way when using the source selector knob, or just the remote, or both? If the buttons work fine, but not the remote, check the batteries in the remote and try again.
Does the remote and/or the source selector knob successfully let you select other sources? If so, the next thing to check is the sea of ribbon connector cables inside. If you've never done anything like this before, PLEASE DON'T try. Not only are there so many ribbon cables inside that you could accidently disable something else, but there is enough capacitance inside that amp to give you a REALLY nasty shock, even with it unplugged and turned off.
Now, if that hasn't scared you away and you want to check, or you want to have some info for your local tech, The tuner itself is just behind the antenna plug-in on the back of the unit, in a shiny metal-shielded box. There is a wide, thin white ribbon cable running from the tuner card down to the main board underneath. Make sure both connections are firmly seated, and are in STRAIGHT, and that the bottom connector's locking clamp is in place. Oh yes, make sure to pull up on that locking clamp before re-seating the cable. The cables are fragile, prone to lose connection, especially if the receiver has been moved recently.
If re-seating the cable doesn't cure the issue, a tech will need to check the source selector chip and circuitry.

Posted on Sep 27, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How can I connect an equalizer to my Marantz sr-66 ?


Does it have a loop through connection that is before the amplifier section of the tuner? If not I'm not sure you can. If so then you need to connect the equalizer in this section of the tuner.
The owners manual should be able to tell you more than I can find on Google

Oct 07, 2014 | Marantz Sr-66 Audio Video Surround...

1 Answer

Tuner does not work on my Tuner Amplifier


Check to see if the antenna is loose. Most amplifiers will mute the output if they don't detect a strong radio signal.

Jul 26, 2013 | Televison & Video

1 Answer

Sony MHCEC77 Shelf System TUNER STOPPED


If the rest of the set works fine then it is possible that the front end of the tuner is faulty. can be failure of the RF section , a possible failure of voltage to the TUNER/RADIO section . Check also if the logic switch is workingg to switch the TUNER and also if the processor is working to TUNE.

Oct 21, 2011 | Sony MHCEC77 Shelf System

1 Answer

I have a DC Z-92 amplifier,PD-Z82M CD player,PLZ-92 Phono deckand F-Z92l tuner, was working fine till moved house,lost manual on how to connect it back up again,can hear very faint sound from speakers but...


first make sure you have phonograph and everything else plugged in where it belongs. or better yet unplug everything and start over. plug in just one source or just use the tuner. make sure that the speaker wires are not shorting out on the back of the amp or at the speakers. if there is a speaker switch on the front (for speaker A or Speaker B) make sure speaker A is pressed in (if you hooked up Speaker A on the back (you may not necessarily have speaker switchs.) make sure when you try the tuner that it is tuned to a good solid station. If after all of the above it still doesn't work, maybe the move caused somthing to come loose inside

Mar 20, 2011 | Pioneer Audio Players & Recorders

1 Answer

When i have the stereo on radio my amp/subs work fine, but as soon as i switch the mode to USB ( built in ipod connector) it cuts out the power to the amp/subs. It only works on tuner mode (radio) why?


use the blue/white wire (amplifier remote turn on) instead of the blue wire (power antenna remote turn on) to turn your amp on. the power antenna wire shuts off when leaving tuner mode.

Mar 02, 2011 | Sony DSX-S100 Car CD/ MP3 Player

1 Answer

Broken on/off switch on Onkyo TX-822/811 Tuner Amplifier


www.oaktreent. com

might have spare onkyo parts

Mar 22, 2009 | Audio Players & Recorders

3 Answers

Service manual


These are not generally available outside of authorized service centers. What is your specific problem with the unit? Perhaps we can guide you on the repair.

Dan

Jan 22, 2009 | Nakamichi AV-10 Receiver

1 Answer

My amp works on tuner but switches off when i change it to cd


The remote turn-on wire from your amplifier is connected to a blue wire behind the head unit. That's a power antenna activation wire, so the amp only turns on when the tuner is on. Switch it to a blue/white wire from the head unit instead; that should be the amp remote turn-on output.

Jun 16, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

My Emerson NR305TT will not produce sound. Turn table works, CD Player works, FM Tuner Works, everything works except no sound comes from the unit. The on switch and volume seem to work as I hear a faint...


You have one of 3 problems:1) bad solder joints in the amplifier or preamp section 2)defective output transistors/ICs in the power amp or 3)missing or incorrect voltages to the amp section. If the unit has a headphone jack plug in a headset. If you have sound then everything is OK thru the preamp section and your problem is in the power amp. Any competent repair shop should be able to solve this one easily.

Jun 19, 2006 | Emerson NR305TT CD Shelf System

Not finding what you are looking for?
NAD T752 Receiver Logo

Related Topics:

135 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4861 Answers

The Knight
The Knight

Level 3 Expert

72670 Answers

krisefisher

Level 1 Expert

2 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...