Question about Optoma EzPro 739 Multimedia Projector

2 Answers

No power to optoma ezpro 739

I open my projector up to clean it and when i put it a back and plugged it in the was no power going to the projector (no lights on or flashing) and how do u take the top and bottom covers off.

Posted by on

  • 3 more comments 
  • papinice31 Sep 23, 2008

    Thanks but tired that and even put in a new bulb still nothing!!

  • papinice31 Sep 23, 2008

    power cord is fine. There is a fuse inside where is it located and how do I check it? make revision for all connector inside. what do you mean.

  • papinice31 Sep 23, 2008

    ok from what i can access buy taking the front and back panels off everything is connected I have I can't remove the top or bottom covers to check further you also mention a fuse is there a fuse located inside the projector?

  • papinice31 Sep 23, 2008

    thanks

  • papinice31 Sep 29, 2008

    marsrover I guess you havent found the manual yet let me know what you find.. ANY ONE out there that can add some input please do!!

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Hi,if you still have the optoma ep729 or a spare lamp i am interested on buying it. ozzyris7@hotmail.com

Posted on Jan 17, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 682 Answers

Check the door(cover) of lamp not closed firmly open it and close it firmly.

Posted on Sep 22, 2008

  • 3 more comments 
  • mohamed eltoni
    mohamed eltoni Sep 23, 2008

    check your power cord-or blown fuse inside--make revision for all connector inside.

  • mohamed eltoni
    mohamed eltoni Sep 23, 2008

    there are many connectors connect the electronics board with each other and with the other parts of the projector----confirm that all connector are connected in its place and nothing loose or disconnected.

  • mohamed eltoni
    mohamed eltoni Sep 23, 2008

    ok--it is the time for service manual befor i can answer your question-and i will search for it and inform you when i find it.

  • mohamed eltoni
    mohamed eltoni Sep 23, 2008

    do not mention.

  • mohamed eltoni
    mohamed eltoni Sep 29, 2008

    sorry i did not find the manual.



×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Over temp


The heat is generated by the lamp whether or not there is an input signal. If the unit seems to be hotter than normal, check the air input grill and be sure that it is celar of dust and debris. You can also gain access to the fan and be sue that the fan is clean.

Dan

Nov 17, 2008 | Optoma EzPro 739 Multimedia Projector

1 Answer

Projector has no power


close lamp compartement door firmly because door switch can disconnect power from projector if not closed firmly.

Aug 27, 2008 | Optoma EzPro 739 Multimedia Projector

1 Answer

LCDPROJECTOR LB10SVU POWERS UP BUT LAMP DOES NOT COME ON. REPLACED LAMP BUT DID NOT HELP.


Hi WITT

This sounds like a Ballast problem - (lamp's powersupply)

This would need replacement , rather than repair as repairs to a Ballast almost always has a come back problem a couple of months down the line.

Apr 21, 2008 | Optoma EzPro 739 Multimedia Projector

1 Answer

3M MP8625, temp warning comes on straight away


Hi there

This is normally a faulty Mainboard.

Must warn you that it is quite expensive to have replaced. Try and find a repairer rather.

Apr 15, 2008 | Optoma EzPro 739 Multimedia Projector

1 Answer

My projector has vertical lines on display; what are possible causes of lines. Projector was dropped, I reinstalled lamp, lines went away for a while, now they are back.


Hi there

This is a common problem on a faulty Mainboard of a Projector.

Not much you can do about it except repair or replace the Mainboard

Apr 09, 2008 | Optoma EzPro 739 Multimedia Projector

1 Answer

We have an optoma ep739. when you turn the lamp on, a message 'fan failure' comes on. the fan is running at what appears to be a slow speed. the red temp light goes on and then the lamp turn off.


Hi there

Try cleaning out the fan by blowing it out with a compressor. Most of the time this is only caused by dust.

If the problem stil occurs , try spraying it on the inside with a lubricant.

If the problem stil occurs you will have to replace the faulty fan.

Very cheap to have replaced.

Apr 02, 2008 | Optoma EzPro 739 Multimedia Projector

1 Answer

Optoma color wheel issue


Hi Brad

You'll have to go into the service menu and check if all the colours are showing the same percentage.

We normally set all of them on 50%

Apr 02, 2008 | Optoma EzPro 739 Multimedia Projector

2 Answers

No Power


me too anyone find a fix?

Dec 09, 2007 | Optoma EzPro 739 Multimedia Projector

Not finding what you are looking for?
Optoma EzPro 739 Multimedia Projector Logo

Related Topics:

500 people viewed this question

Ask a Question

Usually answered in minutes!

Top Optoma Multimedia Projectors Experts

color wheel light...
color wheel light...

Level 2 Expert

137 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5612 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Optoma Multimedia Projector Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...