Question about Power Acoustik TS620-2 Synchronized Lightning Pulses 2 channel 620W PLASMA SPHERE Amplifier Car Audio Amplifier

1 Answer

Amp Not working!

I just got a Power Acoustik TS620 watt amp with the lights on it. I have it hooked up to a 12 inch hi fonics 600w sub. It was hooked up and working for about a day and the next morning when I turned the car on the red "protect" light went on and it now does not work. We checked the fuses and the ground wire and theyre all fine. Please help!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If the amp goes into protect mode, it's likely due to shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

If the problems are not with the wiring, follow the link at the bottom of the page to the Amplifier Repair Primer page.

Let me know if you have any other questions.

Posted on Sep 21, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have power akoustik 12"


If you sub is dual 4 ohm voice coil, you can get a 4000 watt amp (which will give you 1700 watts RMS at 2ohms). The model number is OW-BAMF40001D. Hope this helps.

Aug 20, 2011 | Power Acoustik Power-Acoustik FUBAR-12W...

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

1 Answer

Hooking sub up


Hello missywarden,

According to the specifications, the amp is capable of "tri-mode" operation, that is, running normal speakers on the individual channels while also powering a subwoofer in bridged mode.

Your sub needs to be a minimum of 4ohms and should be relatively efficient. I'd look for a sub that has an RMS power range of from about 75 watts up to a maximum of 250 watts.

The sub connects to the leftmost speaker terminal (positive - right channel) and the rightmost speaker terminal (negative - left channel).

It's not going to be a really loud subwoofer. The power is 360 watts RMS which will be shared by the normal speakers and subwoofer.

Hope this helps.

Aug 05, 2009 | Power Acoustik TS620-2 Car Audio Amplifier

1 Answer

Sony xplod 1200 watt


i had the same ploblem with my amp then i found out i didnt have a good enough ground. Make sure you groung it to your weel well or some part of the frame. Or you mite be running with a fuse thats pushing to much power i use a 100a fuse 5 gage power cord to power my 1200w xplode and my 2 12" kicker comps. Or if your using two diff kind of subs then you amp is confused in why your asking for 500w on one side and 600w on the other this will also make your amp light come on.

Jan 19, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer

Amp getting hot and shutting off


no mine do that and its pretty much normal

Jun 06, 2008 | Insignia 600W Bridgeable Amplifier with...

1 Answer

2006 12" Kicker L7 4 ohm


first whats the range in terms of WATTS that your 12" sub can handle in 4 OHMS ? second , lets check the AMP , POWER ACOUSTIK 1800 WATTS , Now thats a lot of power to drive a single 12" sub speaker . your amp is 1800 watts , per channel is around 500 watts , if BRIDGE thats around 1600 watts rms for ONE channel , if your sub can handle that kind of wattage fine , but it will not blow the amp , what it does is shuts down , some kind of protection mode , it will come back on after a minute or so. I suggest to use one channel in stereo mode , or purchase another sub to use the other channel. i hope this helps AJ

May 06, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

Amp getting really hot


Disconnect the speaker wires and the RCA jacks from the amp.

If it still gets hot, the amp needs to be repaired.

If it doesn't get hot, check the impedance of the speakers and make sure they're wired properly.

If they are wired for the proper impedance, check each voice coil with an ohm meter to make sure none of the voice coils are shorted.

Apr 11, 2008 | Power Acoustik PS2-1600 Car Audio...

1 Answer

Wiring the coils together


For each sub, tie the DVCs in parallel ("+"s together, then "-"s together). This will make the subs look like 2 ohms to the amp. Then, put one sub on each channel of the amp. That will put about 280W rms onto each sub, the max for the amp.

Mar 15, 2008 | Power Acoustik Power-Acoustik FUBAR-12W...

1 Answer

600 watt 2 channel power acoustik sterling amp


On your amp, there should be a switch (on the side probably) that has "LP", "HP", and "FULL" or "OFF". This is a switch for the low pass/high pass filter. Switch it to "LP" as this will allow only low frequencies to go to your subs, what you want. If you don't have that switch, go to an audio store or online audio supplier and get either a low pass filter, band pass filter, or a cross-over, and follow the wiring diagram that comes with it to filter out the high frequencies before they get to your subs.

Oct 09, 2007 | Power Acoustik TS1440-2 Car Audio...

1 Answer

Power Acoustik TS620-2 Amplifier


Check the wiring at the speakers themselves. It's possible that while you were moving the box one of the speaker wires came loose and shorted against the other terminal. A shorted speaker wire or damaged speaker will cause the amplifier to go into protect mode. If you have a digital multimeter with a resistance feature, you can test the resistance between the positive and negative terminals for each speaker.

Feb 26, 2007 | Power Acoustik TS620-2 Car Audio Amplifier

Not finding what you are looking for?
Power Acoustik TS620-2 Synchronized Lightning Pulses 2 channel 620W PLASMA SPHERE Amplifier Car Audio Amplifier Logo

236 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

yadayada
yadayada

Level 3 Expert

66433 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...