Question about Electrical Supplies

5 Answers

Generator runs, but does not generate electricity

I have a Valsi GV75MG1300TV 7500 Watt generator that I purchased and used after Hurricane Katrina. The motor still runs fine and I start it every few months, but when I needed power after Hurricane Gustav, it would not generate electricity. The Voltmeter on the Generator is not registering anything. It will occasionally bump off of zero, but not for any amount of time. I checked connections and flipped breakers, but have not gotten anything out of it. Reading the manual seems to indicate that a capicator or diode coule be broken?? I have also heard others say that sometimes generators need to be reset ot "Tickled". Please help. Thanks.

Posted by on

  • 1 more comment 
  • Anonymous Sep 19, 2008

    I have the same problem with my Coleman 7500 Vertex Professional vertical gas generator. Engine runs and breakers don't seem tripped, but no juice. Perhaps a blown capacitor?

  • Charlie McIntire
    Charlie McIntire May 05, 2013

    same problem with a honda 7000

  • Anonymous Mar 28, 2014

    Have checked continuity in all coils. Checked and replaced the cap. checked the diode. All ok. have remagnitised. Still not generating any power.

×

5 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 18 Answers

Reset / tickled? There are resistors and diodes in the end of the alternators rotor (the bit in the middle that spins) If these look ok visually then change the capacitor which is a barrel shaped object usually with 4 prongs on the end. Without a capacitor the genset will not produce a voltage.

Posted on Sep 19, 2008

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Night Owl:

    An expert who has answered 10 or more questions between 12 midnight and 6am on the same day.

  • Contributor
  • 55 Answers

You can apply 12 volts to the output for a couple seconds, with the engine OFF, and it will bring back the magnetic field in the armature. If that didn't fix it, you have to rotate the shaft 180 degrees and apply the 12v to it again with the same polarity as you did the first time for a couple seconds, and it should work this time. Easy fix, done it many times.

Posted on Sep 21, 2014

Tuching small 9volt battary to brush leeds when off will recharge small exsiter

Posted on Nov 04, 2008

Yes on the 7500 series you sometimes lose the magnetic field - to correct this buy a 6 volt flashlight battery - with the unit off induce battery voltage to the brushes -then try to run - if it doesnt work try again . it may just be an exciter prob -

Posted on Oct 16, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I want to generate electricity by coupling two motor that is enough for my house hold

Posted on Jan 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Troubleshooting generators


Possibly the needle and seat valve or check for a cloggeg air filter or a tear or hole it the carb body.

Good luck,

Marty

Jul 16, 2014 | Generac GP7500E - 7500 Watt Electric Start...

Tip

Generator runs great but produces no power


On Thursday last week I had 220 amp outlet being used and a 110 amp outlet being and overloaded the generator. It turned out to be the reset breakers failed to trip and blew the capacitor. The reset breakers I would suggest replacement after 7 years very easy to do on a 5500 Valsi generator 2010 model still running and now producing electric. And of course use only regular gas non Ethanol.

on Aug 19, 2015 | Electrical Supplies

1 Answer

Looking for a manual for a pow'r gard 7500 watt generator


Go to the HONDA website and probably get one to download on line!

Dec 24, 2012 | Electrical Supplies

2 Answers

How long will it run on a full tank of gas????


Hello. W/D here.
You've posed a fine question, as it has several answers. We used one of these during Hurricane Katrina.
1. At idle, you can expect about 6 hours.
2. Fully loaded, you can expect to refuel it at about 4 hours without the tank being empty.

Your actual time will vary with the demand placed on the generator, but these times are best as I recall.
Hope that this was of some small help, --W/D--

Jan 27, 2011 | Coleman Powermate Premium Plus 6250W...

1 Answer

I own a 5700 watt McCulloch generator. Bought for Hurricane Katrina. Ran perfect , changed oil & used fresh gas regularly. Crank every couple months to keep gaskets from dry rot. When I cranked it...


Most likely the protective circuit breaker has tripped. It doesn't look like the circuit breakers in your house wiring panel -- it is often just a small button that you must press to reset. It can trip easily from a surge when you first plug in an appliance (especially one with a motor), but if it keeps tripping with nothing plugged in, then you have a short in the generator wiring. Good luck!

Aug 17, 2010 | Garden

2 Answers

I have a valsi 7500 watt 13 hp with tecumseh enduro xl/c engine-its extremely loud and wouldn't stay cranked. My ex - an ''idiot'' worked on it without my knowledge - we now have lines that we don't know...


Valsi 7500 watts/13hp tecumsa engine. Was running fine and then started surging like it was going to die and then it ran out of gas. Put fuel in it and now it wont start. Gets fire and has plenty of gas. Problem???

Jun 23, 2010 | Electrical Supplies

1 Answer

Have a VALSI 5500 watt generator that works fine but the tank has rusted out and I cant find where to purchase a new one. Can you help me find where to purchase this tank


We had problums with this one also. If you absolutely cant find a tank repair it.

A motorcycle shop in your area has no doubt had plenty failed tanks to repair. and then have it plastic coated on the inside.

The problems stem from the use of fuel with ethanol it attracts watter and dosed not work well in a gen set that spends lots of time setting.

Begin using fuel with a fuel stabiliser and keep it full, Air also has water in it.

r/
David

Jan 05, 2010 | Watts Onan Portable Generator - 4000 ,...

2 Answers

VALSI 5,500 WATT GENERATOR WILL NOT START


All generators need to be run once a month. All things from the tank to the and including the carb will get gummed up with dried out fuel. I have a whole house generator and a 5500 watt gen set on my motor home. I keep fresh fuel in the stand alone house generator in California in case of a bad earthquake. I drain the gas after every run and keep all vehicles full of fuel just in case. Run gen sets at least once a month or pay pay pay!!

Apr 05, 2009 | Watts Onan Portable Generator - 4000 ,...

1 Answer

Engine runs but won't generate any electricity


Sometimes the generator loses the magnetic field that allows it to produce power. Do a Google search on "flashing a generator field". There are many ways to do it, but I would recommend doing some reading before trying it. Your "dead" generator could produce hazardous voltage once it comes back to life.

Also, before trying any of this, make sure the circuit breakers on the generator (if equipped) are not tripped.

Good luck and be careful!

Jan 19, 2009 | Coleman 10' X 10' Sundome Tent 9160K101

1 Answer

Generator will not generate electricity.


I assume it is a hand start genset. The most common problem if it has been sat for a while is rust on the ignition timing flywheel. If you take the pullcord housing off (recoil) then you will see a big flywheel with what can only be described as a big forked prong with a couple of wires on it. This flywheel should be stainless steel and rusts when sat around for a while without use. Its job is to complete the circuit to the spark plug every time the flywheel passes the forked prong at a given spot on the flywheel, the faster the wheel turns the faster the spark hence the engine runs quicker. Clean the rust off with a releasing agent (wd 40) hey presto!!!!!!!!!!!

Sep 17, 2008 | McCulloch 13HP 338 Cc Portable Generator #...

Not finding what you are looking for?
Electrical Supplies Logo

Related Topics:

7,136 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrical Supplies Experts

Steve

Level 3 Expert

3287 Answers

Gene Haynes

Level 3 Expert

5089 Answers

Brad Brown

Level 3 Expert

14999 Answers

Are you an Electrical Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...