Question about BYTECC Computers & Internet

Open Question

Bytecc 3.5 USB enclosure only powers up when ribbon is not connected

My Bytecc enclosure was working fine for a few weeks. But recently it stopped powering up. I took it apart and through experimentation I found that it will power up if I turn it on without the ribbon connected to the drive. After it powers up, I can connect the cable and everything is fine until I power down the drive. Then it won't start again unless I follow the same procedure. Any ideas? Is the board in the enclosure done?

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 4 Answers

SOURCE: Windows won't recgonize my enclosure

The drive has to initialized through a windows program. Go to start, run type in.... compmgmt, click on disk managment, in the box where you see your other drives, scroll down till you see your usb drive.. When you right click in that box you will see a variety of options such as partition, format and assign a drive letter. Good luck.
Detailed info:  http://www.troublefixers.com/usb-pen-drive-detected-but-doesnt-show-up-in-my-computer/

Posted on Feb 03, 2009

Ad
  • 84 Answers

SOURCE: I need the drivers for the bytecc 720 enclosure

Visit the following website and get the driver to be downloaded http://www.byteccusa.com/driver.htm

Posted on Aug 23, 2009

issken
  • 1472 Answers

SOURCE: IDE hard drive in Bytecc ME-535U2 enclosure not recognized by OS

smc4

There is a couple of things that could be going on. The first thing to check is that the drive did not get bumped off its drive letter by another device. If that is the case you just the to assign it a new one. The link below will help you do this.

http://www.fixya.com/support/r4183994-change_drive_letter_in_windows_xp

The other issue is the drive may have gotten disconnected improperly. I had the same problem with one of my drive on my XP system as well. It partly has something to do with the USB controller to my understanding. Alot of times if you plug it into another computer it will detect it and ask to run a scan to repair the drive. After this you should be able to access the drive on your XP system again. Note I have the best resolutes when I plugged the drive into my Vista system. So I would recommend trying to plug it into a Windows Vista or 7 computer to attempt the repair.

Let me know if you have any more problems or questions.

Issken

Posted on Feb 23, 2010

  • 1 Answer

SOURCE: Bytecc ME 350V4 external drive

Two philips screws on the back.

Posted on Feb 10, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to open case for BYTECC Slim Mobile Drive 2.5" SATA 6G USB 3.0 External Hard Drive


you obviously want to scrap it for magnet or aluminum, so bashit with hammer and split with chisel, etc.

Jan 15, 2013 | BYTECC 2.5" USB 2.0 Slim Hard Drive...

1 Answer

IDE hard drive in Bytecc ME-535U2 enclosure not recognized by OS


smc4

There is a couple of things that could be going on. The first thing to check is that the drive did not get bumped off its drive letter by another device. If that is the case you just the to assign it a new one. The link below will help you do this.

http://www.fixya.com/support/r4183994-change_drive_letter_in_windows_xp

The other issue is the drive may have gotten disconnected improperly. I had the same problem with one of my drive on my XP system as well. It partly has something to do with the USB controller to my understanding. Alot of times if you plug it into another computer it will detect it and ask to run a scan to repair the drive. After this you should be able to access the drive on your XP system again. Note I have the best resolutes when I plugged the drive into my Vista system. So I would recommend trying to plug it into a Windows Vista or 7 computer to attempt the repair.

Let me know if you have any more problems or questions.

Issken

Feb 23, 2010 | BYTECC ME-535U2-BK Aluminum 5.25'/3.5'...

3 Answers

Windows won't recgonize my enclosure


My Setup:
Bytecc Model ME-535 hard drive enclosure with Seagate 80GB SATA drive (ST380815AS) hard drive.

My Problem:
I plugged in but didn't see anything in My Computer.

My Solution:
After Windows finds your device -> Start -> Run -> compmgmt.msc -> OK -> click on Disk Management -> a pop up will ask if you want to initialize the disk, select MBR -> OK -> your disk should show up as unallocated -> right click on that disk -> New Simple Volume -> Next -> next -> Assign drive letter: E -> Next -> Format this volume NTFS with quick format -> Next -> Finish -> It takes a minute or two to finish formatting -> Now shows up in disk management as "Disk1: New Volume (E:) -> My Computer -> see E drive now and it is working!

Jun 13, 2008 | BYTECC 1 Bay ME-350U2 USB 2.0 External...

1 Answer

Software for 500GB


I don't think BYTECC sells complete external hard drives. But they do sell the enclosures. People buy the enclosures and install a hard drive in them and, now you have a working external hard drive. I have don't this before, but I have never used BYTECC before. You can download the drivers for there enclosures at there website:

http://www.byteccusa.com/

They have several different versions, Just pick the correct one, hopefully the enclosure has some markings or a sticker identifying the model.

Nov 17, 2007 | BYTECC 1 Bay ME-350U2 USB 2.0 External...

1 Answer

Sleep i think


SOunds like a possible over heat inside the case or the power supply is not stable. Try running it with the case partially open and seeing if there is any variation on  the board.

Sep 07, 2007 | BYTECC 1 Bay ME-350U2 USB 2.0 External...

1 Answer

Problem with external enclosure ( No power)


Perhaps the gentleman at the store did not connect the power from the case to the drive itself.

Feb 11, 2007 | BYTECC 3.5" Aluminum USB 2.0 and Firewire...

Not finding what you are looking for?
Computers & Internet Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top BYTECC Computers & Internet Experts

Stan Skaggs
Stan Skaggs

Level 2 Expert

242 Answers

Raymond Lidington

Level 1 Expert

7 Answers

indiana650
indiana650

Level 1 Expert

33 Answers

Are you a BYTECC Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...