Question about Infinity BASSLINK Car Subwoofer

1 Answer

Phntom bass sounds

I have a basslink installed in a 1997 Cherokee. Works fine, except I am getting phantom bass sounds that sound like the bass to some other song cutting in, even when sub turned down. Just comes out of nowhere. Only solution is to shut off sub, which is no solution at all. I had it installed at Best Buy a few years ago.
Suggestions?

Posted by on

  • Praz Sep 23, 2008

    Hi looks like this the week for BassLinks to start doing the phantom sounds. I got my BassLink installed by Best Buy in my 08 Mazda 3. The sub started doing the same thing in the last week. I actually stopped on my way to work b/c I thought something was rolling around in the trunk. On my way back from work in the afternoon, the phantom thumps happened again and then the BassLink just stopped working. About 15 minutes later, it cut back on again and seemed to be okay the rest of the way home. I've got a 6pm appointment at Best Buy tomorrow to get them to look at it. FYI I usually play music from my iPod using the aux port and a 2 sided 3.5mm audio cable with the iPod EQ set to OFF. Plus I usually keep the sub settings pretty low (1/4 gain and boost and volume 1/4 - 1/2).

  • Praz Nov 03, 2008

    Ok an UPDATE. The last time the phantom bass sounds occurred, the sub went off for 15 min and then came back up. That was abount a month ago I guess. So it happened on Friday again, but this time the sub hasn't come back up. The servo light doesn't light up w/ the beat, but the power light is on. I took a look at the fuse but it looks ok (though I'm not sure what a blown blade-style fuse looks like) - I figure the power wouldn't come on if the fuse was blown, right?

    I have to take the car to BB to get an XM receiver installed, so I'll tell them to try thicker gauge wire for the ground wire. The one they used initially is really thin. Hopefull that helps...


×

1 Answer

Uhhh....try you change your wire setup

Posted on Sep 20, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an Infinty Bass Link hooked up to my 2002 Honda Accord sedan for extended bass response on the standard stereo. I hook it up with premium power cables, etc...according to manual. I then hooked it up...


Hi,

Does the servo led stay on? If so, you might have a fractured solder joint. Inspect the switch control PCB for fractured solder joints and check the Positive and Negative 15v outputs on the same board.

Jan 14, 2010 | Infinity BASSLINK Car Subwoofer

2 Answers

Basslink works in 'on' but not when the engine is running


check your amps ground wire i had similar prob the vibration from engine caused the wire to move interupting the current

Jul 19, 2009 | Infinity BASSLINK Car Subwoofer

1 Answer

Basslink red light on but no sound


check the all power lines and regulator .is any of them overheating?
then check the power amp ic or transistors.

nuwan.

Jan 12, 2009 | Infinity BASSLINK Car Subwoofer

2 Answers

Infinity Basslink


Hello,
That popping you hear is most likely the voice coil blown and your not going to get much out of it now. Discontinue use of the unit so it doesn't blow the amp, and you can get the sub replaced if you don't want to toss it.
Good luck, hope this helps

Aug 02, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

Basslink keeps cutting off into protection!!


From what i have heard, If you have a speaker level input connection. this sympton does occur. You buy a scosche LOC and try giving the input to Basslink, it should work fine

Jun 24, 2008 | Infinity BassLink II Car Subwoofer

1 Answer

No Sound from Basslink


Do you have speaker wiring or RCA's hooked up from AMP to Basslink? Also check the settings, make sure you are have bridged the channels on amp.

Feb 02, 2008 | Infinity BASSLINK Car Subwoofer

3 Answers

Infinity basslink is messed-up


You may have blown the fuse in the AMP. Check it and let me know.

Jan 15, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

Infinity Basslink 2


Follow these instuctions and piece together where you went wrong. Sounds like a wiring fault.

http://www.ehow.com/how_5829_wire-car-stereo.html

Dec 23, 2007 | Car Speakers & Subwoofers

1 Answer

Basslink II problem running off speaker input


Definately a wiring issue. Go to this site and backtrack to see where you went wrong. hope it helps.

http://www.ehow.com/how_5829_wire-car-stereo.html

Dec 12, 2007 | Infinity BassLink II Car Subwoofer

3 Answers

Basslink intermittant


i posted similar prob. servo lights when power is being cut to speaker (over drive) and manual shows it for purpose of tuning gain. it should flicker at highest input only...mine is on always too. infinity wasnt much help since mine is out of warranty.

Nov 13, 2006 | Infinity BASSLINK Car Subwoofer

Not finding what you are looking for?

Open Questions:

See all Infinity BASSLINK Car Subwoofer Questions

Infinity BASSLINK Car Subwoofer Logo

Related Topics:

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Infinity Car Speakers & Subwoofers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Are you an Infinity Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...