Question about Terminator Aquastar 125FX Tankless Water Heater: FX Hood Horizontal Vent

1 Answer

Burner will not always light

Unit is 5 yrs old. Turn on water 7 fan goes on, pilot lights for 2 seconds & goes out for 1 second & back on for 2 seconds & repeats the cycle but doesn't light. Some times turning faucet off & on works but not always. Some times we just wait & come back later & it works. Some times it will go out while showering ..Brrrr. Have cleaned the cold water inlet screen but may have to replace it. We are on a well. Any solution?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 25 Answers

Clean the flame sensor!!

Posted on Jan 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Whirlpool WFG510S0AS2 range - stove burners work just fine, but both the oven and broiler does not stay lit. NOTE - this unit has been converted from natural gas to LP


when the lp conversion is done , it is normally just a jet size change that is done
however the air shroud has to also be adjusted to get a clean blue burn of the flame
The just jet change results in a slightly yellow flame which is incomplete burn of the gas and that creates carbon build up at the jet and burners causing partial blockage
I would suggest that you call in an accredited gas fitter to check the problem and if necessary , clean the jets and adjust the air shroud

Dec 30, 2015 | Whirlpool WFG510S0AS

1 Answer

Our Kitchenaid Range Hood model KWCU405SSS has a code "C" in the display. What does that mean?


I just did this and it works.

1.) Make sure to turn off both the fan and the lights. If you skip this step the next step won't work.

2.) Press and hold the + button for 4 seconds until the "C" disappears.

Repeat in another 100hrs of use.

Mar 19, 2011 | KitchenAid Architect® II KWCU405SSS...

1 Answer

I have a Charmglow ventless fireplace. When I light the pilot the furnance will run properly until it reaches temp. then it shuts off the pilot goes out and requires relighting if it relights. I took your...


In any gas heating appliance there will be a thermocouple that sense if the pilot flame is lit (lighted?).
You bypass this with the regulator by holding the button temporarily and that allows you to light the main burner. If the thermocouple is bad (not uncommon- they sit in a hot seat all the time), it will disable the gas supply.
The thermocouple should normally measure nearly zero Ohms on a multimeter; if it doesn't, it's bad.
If the thermocouple checks out OK, then the regulator has failed.

Oct 24, 2009 | Terminator Aquastar 125FX Tankless Water...

3 Answers

Rangehood lights not working


I have a Fabyka Range Hood and know three other people who have had this exact problem (i.e both lights go out simulatneously but fan works fine). In my case I was able to pin it down to the transformer used by the halogen lights. This is an electronic transformer so it is less tolerant of power surges and such.

In the case of Fabyka the transformer is a black box connected to the inside of the hood with sticky tape with a black and white wire and two red wires. It is only used for the lights.

It is connected to the AC power via a black and white wire. you can disconnect this and us an LED power tester (about $2-$5 at most hardware stores) and see if you have power when you hit the switch.

In my case it is a 70W 120v to 12v halogen transformer. You can by a replacement off Amazon for about $12 including shipping or you can by a new one from Fabyka for about $30. I would suggest getting a slightly higher wattage transformer (I bought a 105watt for a dollar more).

You will need to disconnect the power before replacing but it is an easy fix.

1. Disconnect the AC power connector (black and white wires.)
2. The red wires coming out are the 12volt lines. If there is a connector, you can disconnect this, if not, you may need to cut these off.
3. Pull the tranformer off the back of the inside of the hood.
4. Cut the connectors off the old transformer. (Unless you buy Fabyka's.)
5. Connect them to the new transformer using wire connectors or crimps. (Make sure you connect black to black, white to white, and red to red.)
6. Make sure you have no exposed wires.
7. Connect to the corresponding connectors inside the hood. Connect the AC connector last.
8. Verify that the lights work properly.
9. Use sticky tape (or Gorilla tape) to attach the connector to the inside of the hood.
10. Enjoy the light.

Jul 17, 2009 | Kitchen Ranges

1 Answer

Range master 50000 exhaust fan stopped working


Extremely likely the fan motor.  get to it then , after removing fan blade,plug it in directly to a 110v  outlet ,just for a second to see if it works well( don;t touch it while prefoming this test,only the plug), or jumper out the switch(with electric disconnected) momentairly to see if the fan runs after turning the electric back on. 

Jan 07, 2009 | Rangemaster Kitchen Hood

1 Answer

Kenmore elite ranghood (series# 550) not working


unplug the unit and unscrew the bulbs. put 2 new in if they still dont work then you may have fried the control. there are usually no fuses between the control and light/fan. well i never saw a fuse between the 2.

Dec 07, 2008 | Kitchen Ranges

1 Answer

Speed control on fan


It means that the filters on the hood need to be cleaned. You simply pop them out and can wash them in the dishwasher. Once clean, dry and replaced, you hold down the fan speed button (the second button from the left or " - " minus for more than five seconds.) When you first hit the button the A will appear, hold the button when the letter disappears, the timer has been reset until time for the next cleaning. The microprocessor in the system will flash every 30 hours of operation.

May 07, 2008 | Zephyr Venezia ZVE-E30 Kitchen Hood

2 Answers

Does not take up the smoke or steam - 2nd unit


It really depends on the exit. If the duct exit has to travel really far before exiting it tends to not have as much suction. And like solution 1 said. Make sure the plate was removed

Apr 12, 2008 | Broan-NuTone Allure II QS230SS Kitchen...

4 Answers

Broan Allure II


I called Broan technical support. They said that they had heard of this issue before, but that there was no recall. I suggested that it was a frequent enough problem for it to come up 3 times in 12 mo. on one website. She was underimpressed with this statistic and said that they sell millions of them. She would not disclose the name of their supplier so that I could get some information on the actual controller unit. She did not seemed as pained as I was by having to part with $130 for a new controller.

Jan 30, 2007 | Broan-NuTone Allure II QS230SS Kitchen...

Not finding what you are looking for?
Terminator Aquastar 125FX Tankless Water Heater: FX Hood Horizontal Vent Logo

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Terminator Kitchen Ranges Experts

Dan Webster
Dan Webster

Level 3 Expert

8205 Answers

Richard Roth
Richard Roth

Level 3 Expert

9472 Answers

yadayada
yadayada

Level 3 Expert

64052 Answers

Are you a Terminator Kitchen Range Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...