Question about Crossfire VR404 Car Audio Amplifier

1 Answer

Internal malfunction? OK so this amp used to work perfectly, but now when i turn it on everything seems fine, only once i turn my CD player up past 20 (which really isn't loud or anything) it goes into protect mode. no speakers are blown or anything so i would rule that out. any ideas?

Posted by on

  • Anonymous Feb 15, 2009

    i have the same exact problem. it worked a week ago but now it is going in and out of protect mode!

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 35 Answers

Need new ground wire, possibly bigger gauge wire, may need to take cd player out and re-hook the wires up into the cd player then into the amp to make sure no wires are touching

Posted on Sep 16, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why doesn't my Receiver tell my amp to turn on


Ok get a test light and test the remote on the amp and on the back of the radio if it is good in both places then check power and ground

Apr 24, 2014 | Kenwood Remanufactured KDC-HD548U CD...

1 Answer

I have 2 amps instalkled in my car one is sony 1200w 2 channel amp for speakers and one is solid audio f2500d for 3 subs my sound and every thing was good but suddenly from yesterday im having trouble when...


First disconnect the CD head unit from the sub amp and see if the other amp works. If yes, the problem is the wires to the amp, the amp itself, or the subs/sub wiring. If no, the problem is the head unit--probably an internal short.
If the other amp works with the sub amp disconnected, reconnect the sub amp to the head unit, but disconnect the sub wires from the amp. Try the CD player. If the amp goes to protect with no speaker wires attached, the amp is bad. If the amp is OK, the problem is the subs or sub wires. Hook the wires up to the amp again, but disconnect them from the speakers. Try the player again. If the amp goes to protect, the problem is the amp wiring. If not, the problem is the subs. Check the impedance of each sub using an ohmmeter to determine which amp is out of spec.
Please let me know if you have questions, and thanks for using Fixya.

Jun 11, 2011 | Solid Audio F2500D 1-Channel Amplifier Car...

1 Answer

Amp keeps blowing fuses (alpine mrdm1001


Hello prabh_dusanj,

First make sure that the amp is not operating into too low of an impedance. If the load is OK, it's most likely a short in the output transistors.

Hope this helps.

Sep 11, 2009 | Alpine MRD-M1001 Car Audio Amplifier

1 Answer

Accidentaly switched 12v and ground on amp


NOTHING INTERNAL BUT YOU SHOULD PUT A 30 AMP FUSE BACK IN AS SOON AS YOU CAN TO KEEP THE 20 AMP FROM POPPING THATS THE WHOLE REASON FOR THE FUSE TO KEEP THE ELECTRONICS FROM BLOWING

Apr 05, 2009 | Car Audio & Video

1 Answer

CD player looks like its working but no sound. Quit during Play.


HI...CHECK TO SEE IF THE AMP IS GETTING POWER (REM) POWER-----(AMP)POWER--GROUND,, CHECK FUSES BOTH OF THEM--....YOU MAY HAVE DONE THIS ALREADY--CHECK TO SEE IF THE RADIO FUSE IS OK (POWER)..THE DISPLAY CAN STILL WORK FINE BECAUSE THE RADIO HAS 2 FUSES 1 FOR (POWER) AND ONE FOR MEMORY(DISPLAY) HARD TO SAY WITH OUT LOOKING AT IT.... GOOD LUCK

Feb 12, 2009 | Crunch BLX5520 Car Audio Amplifier

2 Answers

ZX700.5 cutting out at 60% volume


I figured out the problem, the front right tweeter wire was pinched behind the mounting bracket. everything is now working perfectly.

Sep 22, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

My amp only powers the subwoofer when the radio is on but wont when the cd player is on


The person(s) who hooked up your system made a boo boo. They wired your remote turn on lead to the power antenna lead instead of the amp turn on line (both are blue and easy to mix up). Thus when your radio is on it sends a signal to the amp and the amp turns on, but when you set to CD the signal goes away and your amp shuts down. Easy fix, just re-wire the amp turn on lead and the problem will be fixed.

Jun 24, 2008 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

Volfenhag ZX8300 on with radio, off with cd or mp3 player


You're using the wrong control wire. You're likely using a wire marked antenna control. You need to use the one marked amp control. They are both blue.

May 22, 2008 | Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

Amp turns on but doesnt power my subs


well ill need 2 know wat knobs are all on the front of your amp

Nov 07, 2007 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

Amp turns on then starts making subs go erratic with almost sounds like line nosie


hi i had the same problem people suggest checking ground thats where you start at then if it aint ground for sure, the make sure you have good rca cables. If there good this is what happen to me i had a cheap ole pioneer 70 doller cd player the actual rc jacks from that cd player was making and horrible sound travel through my speakers im talking humming whinning everything im positive that this will solve your problem email me at maggotman927@hotmail.com and let me no something if i helped or if ya need more help

Apr 04, 2007 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Crossfire VR404 Car Audio Amplifier Logo

Related Topics:

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crossfire Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6364 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Crossfire Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...