Question about Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Canon 400d Hi, I was using my camera with a Canon speedlite 530 mk2 flash when it just died,(camera not flash) replaced battery, removed battery, recharged battry, tried the on/off switch, left it for a couple of days etc etc etc. The camera is basically............dead. Any ideas. Best regards John

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 164 Answers

Such symptom indicate a malfunction on the DC/DC voltage converter circuitry, and the camera has two of them located in different boards.

In order to perform a correct diagnostics and repair of it, it is necessary to open such camera and perform it by a qualified camera repair technician.

If it's under warranty, I do recommend you to send it back to make valid the warranty.

If not, then you hav the options of pay for its repair, or do it yourself if you are willing tgo open it and perform some basic diagnostics of the failure. You will needtools to do it, which includes the usage of a soldering iron.

Best regards,

Posted on Jul 23, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Aaaaaaaaflash not firing with fresh batteries


If you try new batteries and that does not solve the problem then the problem is with the flash circuit. The flash draws most of the power because it is Xenon. If the flash isn't working, then the battery should last long and this will tell you that the flash circuit is the problem. The problem might be due to a cold solder or a bad component. But I'm pretty sure that the flash itself is good. Fixing it would cost you around $100. I wish I could do some wand trick to solve the problem but there ain't no easy fix for this. If you have any other queries then I would be glad to assist you further.

May 29, 2010 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Canon speedlite 430 EZ does not match with canon 400 D digital camera how to use the same flash with 400 D.


You can't. The metering systems are incompatable. You must use the EX range with the 400D, such as 430EX or 580EX (versions I or II)

Feb 25, 2009 | Canon EOS 400D Digital Camera

1 Answer

My camera is a Canon 400D. I put an external flash on it just few moments ago (canon speedlite 580EXII) and the flash wouldn't go off when i took pictures. So i took the flash off, but now the flash on the...


Hi Chrissy, I had observed the same problem - after an external flash had been removed from the camera, internal flash didn't pop up. Tried to look at the Google and finally found the solution. It helped me and could help you as well:
The usual reason is that the camera thinks that there's an external flash mounted on the hot shoe. Check the external flash detect switch. It's located under the right side of the shoe (there is a metalic piece which is kind of "elastic". Just try to push it and release several times, may be put the screwdriver softly under it and out... It helped me. Here is the picture of location of the detector.

Jan 11, 2009 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Error 99 in EOS 400D


Here is a link which may help you.
http://forums.dpreview.com/forums/read.asp?forum=1031&message=9598105

It may be that the contacts on the lens is dirty, follow the directions, by using a clean pencil eraser (I would also suggest to use alcohol and clean the contacts after using the eraser). Also to remove the date button battery and the other batteries, then turn on the camera (with all batteries removed).
Then put the batteries back in.

Jul 23, 2008 | Canon Rebel XT / EOS 350D Digital Camera

2 Answers

Speedlite 540EZ and EOS 400D


540EZ will not work on digital Canons in auto reading mode. It will only work on manual flash settings.

Mar 15, 2008 | Canon EOS 400D / Rebel XTi Digital Camera...

3 Answers

Canon 400D


Use a card writer and copy your pictures to the CF card on the computer.

Jan 07, 2008 | Canon EOS 400D / Rebel XTi Digital Camera...

2 Answers

Xti and Speedlite 200E


The only way to solve the problem I see is to turn the flash into non-TTL one. It can be easy done by opening four screws at the connector side of the flash, unsoldering or cutting the BROWN line and closing the connector back. The AF assist led will work.

That I did on my 200E with Canon 400D camera and all works file.
Enjoy!

Jan 06, 2008 | Canon EOS 400D / Rebel XTi Digital Camera...

3 Answers

How to switch on Auto Flash in Auto mode


Put the camera in "P" and press the flash button above the lens release. If the flash pops, than you probably just have too much light to need it when you are in auto. The flash button is not active in auto so if the xti doesn't want the flash in auto, u can't make it fire. If the flash button does not make the flash pop in "P", search this site for another post about flash not working and u will find that this could be the flash deactivation button in the hot shoe sticking. Not likely though with a new camera unless u have had a speedlite mounted alot.--

I found the answer and fixed my flash. Look on http://photo.net/bboard/q-and-a-fetch-msg?msg_id=00ODWf

This will describe how, if you have been using a speedlite alot, than the little tab under the shutter release side of the hot shoe can get bent down thus constantly pressing down (toward the bottom of the camera) the small button which deactivates the pop-up1.gif flash even when the speedlite is not attached. Just bend the tab up a little with a jewler's screwdriver, turn the camera off and on and voila!! Fixed!!! Dan describes pushing the tab down, but on the xti, the tab needs to be bent up to release the flash deactivation switch and fix the problem. Thanks to Dan D on photonet for saving me a service call.

Dec 26, 2007 | Canon EOS 400D / Rebel XTi Digital Camera

2 Answers

Old flash


at a whopping 46.6V.. yes, it would damage it.

Nov 27, 2007 | Canon EOS 400D / Rebel XTi Digital Camera...

Not finding what you are looking for?
Canon EOS 400D / Rebel XTi Digital Camera Logo

Related Topics:

57 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Cameras Experts

kakima

Level 3 Expert

98694 Answers

TC CAMERA REPAIR.Com...

Level 2 Expert

164 Answers

old marine
old marine

Level 3 Expert

1567 Answers

Are you a Canon Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...