Question about Car Amplifiers

1 Answer

Sony Xplod 2-Channel 1000 Watt Amplifier trouble shooting

I have a sony Xplod amp and it doesn't seem to be working properly. The other sony speakers in the car seem to have more base than the ones running through the Xplod. I have checked the settings on my cd player and they are set to max for the Sub. Am I missing something?

Posted by on

  • Anonymous Apr 24, 2009

    i have a 1200w sony xplod twin channel. it has been working fine since i had it. now the amp comes on when it wants to, which is for like 3 mins at a time. the red light flashes sometimes when the sub is on. i havent checkedthe fuse yet because i get high and forget about it. does anyone know whats up?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

What's the model number of the amp?

What speakers do you have on the amp?

Are the speakers moving significantly at high volume?

Posted on Sep 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i bridge a 1000 watt amp to two 1200 watt subs


a sony 1000 watt rating is an exagerration. you will blow your 1200 watt speakers far before reaching sonys claim of 1000 watts

Jul 10, 2014 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

I have a sony xplod 1652z 1000 watt amp and want to hook up 2 subs and the speakers that are already installed in the truck is that possible?


thats not a good idea because you are running too many speakers off that amp it it could possibly blow a channel or the whole amp. trust me i've done it

Jun 10, 2010 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

I Have a Sony Xplod 800 watt amp and 2 12 inch Sony Xplod subs


You should definately bridge them. Firstly, lay the 2 speakers face down next to each other. Note the connections +- +-. The first + will go to the amplifier. The next terminal(-) will be connected to the next speaker(+). Take the last(-) and connect to amplifier. Please note that your amplifier has a bridge section which is normally the first + and the last- on the two channels. Connect your woofers on the bridge.

May 28, 2010 | Sony XM-ZR1252 Car Audio Amplifier

2 Answers

Can I run 8 speakers and 1 sub through 1 1200watt 2:1 Sony Xplod?


asuming the 8s are 4ohms each; wire two in series and that gives you 8ohms then two more in series then you put those together in parallel and it gives you a 4ohm load. repeat with other four for the other side. you should then be able to bridge the sub


series; posative of one speaker to negative of other speaker and that doubles your ohms

parallel; posative to posative negative to negative and that cuts the ohms in half

Apr 06, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Sub wiring


IF THE RMS IS 800 THEN THAT IS THE MINIMUM YOU SHOULD RUN TO THEM. IF THE MAX IS OVER 1000 WATT, YOU SHOULD BRIDGE ONE SPEAKER TO EACH CHANNEL. YOU WILL PUSH THE MOST POWER TO THEM THAT WAY. MORE POWER = MORE BASS

Feb 22, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

High distortion


The head unit may be rated at 200 watts but it cannot produce more than ~20 watts of real power per channel. There's no way that it can drive the high end speakers to a level that will be needed to compete with the subs on a 1000 watt amplifier.

Apr 18, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

What size capacitor do i need?


you dont a cap is like a band aid it helps but not much look for a 600cca to a 1000cca car audio battery like a kinetiks 800

Jan 01, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Sony Xplod 1000 watt car amp quit working.


Almost all after market amps use 12v at very very low amperage to trigger the amp on. A temporary jumper from the battery plus terminal on the amp AFTER the battery and ground wires are attached should cause the amp to turn on. I would check to see if you have attached your speaker load correctly ESPECIALLY if you are bridging. Most of the blown amps that come into my shop are due to incorrect bridging loads from the speakers. Note that a 4ohm load bridged across both outputs of an amp will deliver a 2ohm load to each of the channels. When you parallel wire two 4ohm speakers together and then attached them to a bridged amp you will be putting a 1 (one) ohm load to each channel of the amp. Please don't make this mistake. It will fry your amp in about a month. Hope this helps. Good luck.

Feb 03, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

1000 watt amp sony xplod


how do you have your system hooked? What speakers do you have? There is a lot more too it then just wattage.

Jan 23, 2007 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

1,161 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...