Question about Hifonics Car Audio & Video

1 Answer

Hifonics Brutus BXi 1208d Amplifier

I Recently purchased a Hifonics Brutus BXi 1208d amplifier to power my 10' Alpine Type X. We set everything up, amplifier lit up seemed fine but we could not get the X to hit.I tried seveal different things but could not get it o work. I started troubleshooting by checking connections and eventually just swapped the amp out for a friends old pioneer. It hit right away on that so i know the sub works. After that i hooked it back up to the Brutus just the same and to no avail. I tried so many different speaker wire connections its not even funny but nothing worked. When i turn on the vehicle, the amp clicks. i dont know if thats any help. Also one of the LED's is a greenish blue tint compared to all the other dark blue ones. I dont know if that means anything. I have no clue what to do. Everything is set up correctly besides that and If anyone could help me it would be appreciated.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 35 Answers

Possibly you need to return the amp and get a new one cause that could mean an internal problem and its deffective, you could try replacing the fuses or try changing the ground wire, this problem is very unusual

Posted on Sep 16, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is the brutus amp blue led light suppose to stay on when the car is off?


No. The LED should be off when the radio is off (amp turns off as well)

It sounds like you have constant 12volts applied to your remote turn on lead. The amplifier will have 3 connections for power:

1. 12volt constant
2. chassis ground
3. 12volt switched power - this wire should come directly from your head unit. It only sends 12 volts when the radio is on allowing to amp to power up only when the radio is on.

Dec 22, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

No power but the power source is sending power


i ma having the exact same problem...cant get an answer either. let me know if you do...

Nov 24, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Will hilfonics brutus 2010d mono work??


Well with the correct powering system, heaps of paralleled 12 volt Batteries, & a Beefed up Alternator to charge them, I guess so, BUT it is only Mono, so you will need TWO to provide stereo output

Mar 06, 2010 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

Where i could buy the spare part of my hifonics brutus amp? especially the chip type powers, can I bought it here in the philippines?


The parts are probably available mail order from companies like Digikey, Mouser and others. We need a part number to help further.
Sometimes companies have the chip manufacturers put a "house number" on the part rather than an industry standard to try to hide their design... those take a bit of reverse engineering to figure what the part is.

Dec 11, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Hifonics brutus 2000 watt help??!!??


If an RCA took a dive your amp has most likely seen a very nasty input spike and may never be the same as its circuitry has been damaged.....sorry

Mar 09, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Brutus 1206D


u need at least another amp and set em at 2 ohm and then just take it to a shop aand ask thee guy to equalize it he shouldnt charge u or at least 10 bucks

Jun 18, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Brutus 1206D


yes it can only at 2 ohms never 1 ohm good luck

May 25, 2008 | Hifonics Brutus BXi 1206D Car Audio...

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp


Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Jan 01, 2008 | Hifonics Brutus BXi 1206D Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

261 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...