Question about Audio Players & Recorders

Open Question

Peavy SP5XP speaker doesn't work - Audio Players & Recorders

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I can't get my echo dot to pair with my Bluetooth speaker bw-f4. Any suggestions


Follow the instructions exactly at the link please, if that doesn't work you have a device issue. Connect Echo Dot to Bluetooth Speakers

Jan 08, 2017 | Audio Players & Recorders

1 Answer

Want to use my current speakers with a new surround sound system. Current system is 5.1 channels, rated at 100w per channel @ 8. Ohms. New System is rated 145watts, 5.2 channels at 6 Ohms. Will b ok?


Hi Ronald.
8 Ohm speakers will work just fine as replacements for the
6 ohm speakers. When fitting speakers you need to consider
The power handling capability. The impedance and the frequencies
involved. Power handling is expressed in wattage ie 100W.
Unfortunately this can be expressed in rms, max or peak music. The rms value (root mean square) is the only really relevant figure as this is the continuose handling power at 1 KHz. The impedance
is the resistance that the amp sees but is not a dc resistance and
varies with frequency. The lower the impedance the more power
will be drawn from the amp. In the event of a short circuit across
the speaker the amp will try to deliver infinite power into an infinitly
small load in an infinitesimal amount of time and will self destruct.
Using an 8 Ohm speaker draws less power than a 6 Ohm speaker.
Connecting speakers in parallel; results in the impedance beingreduced. For example two 8 Ohm speakers in parallel will result
in a 4 Ohm impedance load but in series will be 16 Ohms.
Incidentally the the .1 (5.1) is the sub woofer which only has
to handle the bass frequencies, a small percentage of the
amplifiers overall frequency response..
Connect your speakers and then power up the amp last
after double checking there are no shorts on the speaker
cables.
All the very best from Vintie.





Jan 07, 2017 | Audio Players & Recorders

1 Answer

I have a monsoon mh505 pc speaker system. i lost the power adapter.i need a manfacture phone number or the model number of power adapter.


We can provide one.
ELECTREPAIRUSA@ELECTREPAIRUSA or you can contact us at that address as we repair/renovate all items electronic and electrical old and new.

Mar 14, 2016 | Audio Players & Recorders

1 Answer

How do I open a UC-280 2.0CH USB Powered speaker system to reconnect the broken cable.


Once you open the speaker it will destroy the acoustic properties and make the speaker useless. The speakers are assembled with takp and glue and have to be pried apart.

Mar 14, 2015 | Audio Players & Recorders

2 Answers

I have a Rowe R80 jukebox and after moving it it has no sound through the speakers I am in New Zealand


Well, in addition to all the fine suggestions that are here, I would like to add the simple and easy things that may have happened during the move.

IF YOU ARE NOT GETTING A LOUD POP WHEN THE MACHINE IS POWERED ON.......

1) Make sure that the wires on the terminals below are still connected to the screws. There is one ground and one each for left and right. The lower the tap the lower the (max) volume of the jukebox.If they are not connected there will be no sound.
84c9065c-b7c6-4417-be21-0be7a6e74b41.jpg


There is a jumpers on the terminal strip where the volume control connects. Make sure that these connections are correct and tight. Also make sure that the jumpers did not fall off.
c1d72051-525d-47ec-8725-a6a8e655b20c.jpg
7a25e260-d39b-4992-8bce-8c2d2c9b07e5.jpg

If you are getting the loud pop in the speakers when the power is turned on .....

Check the plug on the side of the mechanism, just below the back of the tone are.(looks like a little tube socket) Check to see that it is connected to the mech and the CORRECT PLACE on the amplifier. It mat be possible to have this end in the wrong place. bf77613e-82a3-4e37-b8fe-cc80f4d4dbcb.jpg

Check all all your connections against the pic.

I hope this was helpful.

Mar 24, 2014 | Audio Players & Recorders

1 Answer

HMDX Jam wireless speaker cannot be paired with my computer


Go to your Bluetooth settings, go to the "Audio/Video" tab, under the "Content Protection" section uncheck the "Connect to content protection enabled headset only" and your bluetooth speaker(s) should now work.

hmdx-jam-wireless-speaker-cannot-paired-545ferrkqkuowltb2dothasu-3-0.jpg

Feb 02, 2013 | Audio Players & Recorders

2 Answers

My ipod is just playing without the sound carrying through to the speakers. I dont know how to make it work?


Verify there is nothing plugged into the headset port, including headsets, headphones, or adapters.
Original iPhone only: While on the Home screen, adjust the volume buttons. If you see the icon below, indicating that headphones are attached, there may be debris in the headset port:



To remove debris in the headset port, try connecting a pair of headphones to the headset port and then remove the headphones. Repeat this several times.
If you have paired with a Bluetooth headset that is nearby, either use the headset or turn Bluetooth off (choose Settings > General > Bluetooth).
If that doesn't work, try restarting the iPhone. Hold the Sleep/Wake button until "slide to power off" appears. Slide to power off your device. When it is off, press the Sleep/Wake button to turn it back on.
If restarting the iPhone doesn't resolve the issue, try restoring the device.

May 28, 2011 | Audio Players & Recorders

3 Answers

Front two speakers not working at all


Hit the the speakers A/B/Off button on the receiver. If you plugged the front channels speaker wire next to the center channel on the back of the receiver make sure its showing B. If you plugged them in the banana plug part, make sure its showing A.

Apr 12, 2007 | Audio Players & Recorders

14 Answers

Sound problem with JBL Creature II


I had a problem with the speakers not working properly. The green lights lit, but the amount of sound coming from the speakers compared to that of the sub was much lower.
I decided to take it the speakers apart.
I found that the magnets on the speakers had moved forward slightly in the plastic cage they sat in. I pushed them back as far as they would go, and Hey Presto! working again!
I hope this helps someone!

Feb 23, 2007 | JBL CREATURE II Computer Speakers

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

98796 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69739 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...