Question about Sony XS-L1290P5 Car Subwoofer

1 Answer

Stopped working I had recieved the Acoustik explosion subs for x-mas and the other day one of the speakers stopped working. I checked all the wires and they all work fine but when i connect it to the speaker it does not work. I beleive there is a short inside the speaker itself. Is there any way i can fix it myself or find an electronics store that could do that kind of repair. I have emailed a few places and the were no help at all. If u can please help. I would appreciate it greatly if u can tell me how to fix it or tell me what kind of place to take it to for the repair THANX Josh

Posted by on


1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert who has answered 200 questions.


    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 277 Answers

Hi sorry buddy but you burned the coil the speaker is long gone the ONLY way to fix this is to buy a new 1 good luck

Posted on Mar 27, 2006


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Onkyo ht-r530 subwoofer stopped working

Turn the out put leval down on your sub, End the reciever, I was turn up to high,End that will cause it to cut out.

Oct 20, 2012 | Onkyo Ht R530 Receiver 7.1 Surround Sound...

1 Answer

I have a power acoustik bamf 1600/4. not working 5 hours later

use a multimeter to see if the amp has good power wire and remote turn on voltage. then check the ground and make sure its a good strong ground. check the sub to make sure its not bad. make sure it reads whatever ohm its supposed to. anything less than 4 ohms will clip the amp if bridged. if alll that is good then the only thing left is the amp. it sounds like the power supply is bad but check everything else just to make sure. good luck.

Dec 29, 2009 | Power Acoustik BAMF1600/4 Car Amp

1 Answer

Hooked up the system, subwoofer worked OK for about 3 hours then stopped outputting sound. Tried troubleshooting per manual but no luck. All other speakers appear to be working. I think the subwoofer died...

to make sure its not your reciever unplug sub from pre out side of reciever and with sub on run finger over the tip of the RCA you should get some kind of electral feed back from it through your sub if not then your sub or the amp inside is most likley fried if you know how to open the sub and can access it you may have a mini fuse inside that can be replaced but make sure consult somone about that and not just take my word

Oct 26, 2009 | Definitive ProCinema 600 Speaker System

1 Answer

Rockford 12'' P2 sub, stopped workin.

It sounds like you have a bad voice coil in the speaker.You can have the speaker rebuilt, but it is very expensive. People usualy only have very high end home speakers rebuilt, because then it is worth the cost. Hope this helped.

Aug 18, 2009 | Car Audio & Video

1 Answer

Center speaker and sub stopped working

if the sub was popping that either means the sub is getting to much power and blown that normaly happens when they pop, for the center speaker could check the wires maybe it came undone that could be a possibilty

Nov 16, 2008 | Kenwood VR-606 Receiver

1 Answer

Wiring the coils together

For each sub, tie the DVCs in parallel ("+"s together, then "-"s together). This will make the subs look like 2 ohms to the amp. Then, put one sub on each channel of the amp. That will put about 280W rms onto each sub, the max for the amp.

Mar 15, 2008 | Power Acoustik Power-Acoustik FUBAR-12W...

1 Answer

Power Acoustik TS620-2 Amplifier

Check the wiring at the speakers themselves. It's possible that while you were moving the box one of the speaker wires came loose and shorted against the other terminal. A shorted speaker wire or damaged speaker will cause the amplifier to go into protect mode. If you have a digital multimeter with a resistance feature, you can test the resistance between the positive and negative terminals for each speaker.

Feb 26, 2007 | Power Acoustik TS620-2 Car Audio Amplifier

Not finding what you are looking for?
Sony XS-L1290P5 Car Subwoofer Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4899 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides