Question about Power Acoustik PS2-820 Car Audio Amplifier

3 Answers

Won't turn on

My amp gets to hot to touch. Now it won't turn on. When you first turn on the receiver the led lights red then turns off. All connections are good and intact. When I disconnect the speakers the led turns on but it's real dim. The speakers are wire in 2 ohms.

Posted by on

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Won't turn on - Power Acoustik PS2-820 Car Audio Amplifier Car Amplifiers

Are you bridging an unbridgeable amp?

Posted on Jan 18, 2007

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 3,130 Answers
Re: Won't turn on

Make sure you check to see that the power wire going to the amp dosent have a bad connector on it or the wires is a dedicated for the amp. At the power wire measure for 12.5 to 13volts at the amp while the cars running and then if alls ok there remove the speaker wires and the input wires WHILE THE AMP IS OFF. then turn back on the amp is the light brighter??? if not again turn off the amp and measure the currant draw at the amp without and speakers or input. If its over a few amps the amp needs serviceing. If not then check and make sure all your speakers are good and that ones not shorted as well. Dont forget to check the crossovers too>> You didnt say if they were passive or active types

Posted on Mar 22, 2006

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Won't turn on

Rewire it all

Posted on Jan 10, 2007

3 Suggested Answers

  • 84 Answers

SOURCE: no power to amp

you probably blew it up.

Posted on Jun 19, 2007

  • 3 Answers

SOURCE: amp getting really hot

If depends on what the amp is rated to run. If it is only rated to run 2 ohms x2ch then it can only run 4 ohms x1ch. If you run it at 1 or 2 ohms that is too low, too much current, and it will get hot and eventually blow up under hard use. Some quality amps can live that way, and it depends on the sub and what frequency you are running it at. For normal use I would not recommend it. Wire to sub at 4 ohms x1 (or 2 ohms x2ch) for that amp if that is what it is supposed to be at, I'm not sure from your description. Also enhance cooling of the amp if you can, I run fans on mine if they have a heat issue. Warm is one thing, hot is another and not good for amp.

Posted on Apr 22, 2008

  • 410 Answers

SOURCE: protection light stays on

Your output transistors (some of them) have shorted and this amp needs bench servicing. Or get the schematic and troubleshoot and repair bad components yourself.

Posted on Jul 05, 2009

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

The green light on top of the amp won't turn on

ground your amp properly make sure its bare metal

Mar 06, 2013 | Car Amplifiers

1 Answer

Kicker zx1000.1 stopped working completely. I have 3 Kicker 10" cv subs hooked to it. The first time it shut off I turned the system off. When I turned it back on it worked for a few minutes and...

First check to see if your'e getting power to the amp by using a test light and touch the main power(12V battery) connector on the amp, test light should come on since it's constant 12v supply. Now turn on the radio and test the remote wire connector on the amp and you should have 12V(test light should come on). Also make sure that you have a good connection with your ground wire, check both connection points to make sure it's good. Now if you have power where your'e suppose to and when your'e suppose to and the amp does not power up, then it may be time for a new amp. Try wiggling the connections at the amp a bit, the solder may be cold/loose.

Jul 12, 2011 | Kicker Car Amplifiers

1 Answer

The amplifier will turn on and give out put for limited time then it turns off and the red led comes on. ive rewired it twice now and the grounds are all good

Your over heating check and see if you can put in cooler spot also make sure u are getting good voltage through wires use a volt meter on pos and neg connectors at amp while radio is down and then when it is 3/4 volume should not drop more than.75 if is then go with bigger wires also if that does not work and amp is hot to touch check on installing fans

Aug 28, 2010 | Boston Acoustics GT-24 Car Amp

2 Answers

Hello, i have a nitro bmw 486 amp. i use it to power my 2 subwoofers in my trunk. its a very good amp and sure does its job, but randomly the light will turn red, which means protect, and my subs will shut...

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty D .A thumbs up would be greatly appreciated if this answer is helpful to you. nitro-lv2kkrmxrai4iihdvw4m3np2-1-0_0.jpg

Jul 31, 2010 | Nitro BMW-486 Car Audio Amplifier

1 Answer

What is wrong with my 1000w sony xplod amp?

need repairs on the inside usually when u see that fuse melt something else probably melted on the inside. something is grounding out the amp on the inside . get it checked

Jun 05, 2010 | Car Amplifiers

1 Answer

I have a boss amp CX3500D and the red light just stay on and make my subs thumps

check the ground and check rca cords they somtimes do that make sure there are no hot wires touching hear try this pull the sca cords out off amp a little and see if if the light turns green if it does replace rca cords

Nov 18, 2009 | Car Amplifiers

2 Answers

Amp Power LED Display blinks red and no sound

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. Does the voltage on either the B+ or remote pulse below ~11 volts when the LED flashes?

Jan 26, 2008 | Kicker ZX650.4 Multi-Channel Amp - 480W ZX...

1 Answer

Can't get my amp to turn on

You need to confirm that you have sufficient B+ and remote turn-on voltage.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Jan 06, 2008 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Rt 202 led light red and no sound

With the system turned off, disconnect the speaker wires from the amplifier. Turn on the system. If the light stays red, then the amplifier has an internal problem. If the light turns green, then your problem is a blown speaker, or a speaker wiring issue.

Jun 03, 2007 | MTX RT202 Car Audio Amplifier

1 Answer

No Sound coming out of amp to subwoofer

check the fuse box and make sure there is no loose connection there. also check the wire that feeds power to that amp. good luck

May 23, 2007 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

Not finding what you are looking for?
Power Acoustik PS2-820 Car Audio Amplifier Logo

Related Topics:

505 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Amplifiers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Robert marquette

Level 2 Expert

102 Answers

Are you a Power Acoustik Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides