Question about Logitech X-530 Computer Speakers

1 Answer

Creative Inspire T6100 5.1 - No Power

Hey, I just got my new speaker set. After I plugged everything up I turned the power on the right speaker (one with the little power dial) and nothing, no light, no sound nothing. Its as if there isnt any power going to the speakers. Can someone please help me.. A few things to know.: 1) Im in the Uk and yes the voltage etc is all correct, got it from a amazon.co.uk 2) I tested my old creative inspire 2.1 set right speaker (power dial) as I know it works, but again no power.. Thus I can assume that the right speaker itself isnt the problem. 3) The adapter becomes hot when plugged in..just like it normally should. Am I missing something? a on button or something silly? Please could I get some advice. Thank you

Posted by on

  • Shariff_bux Sep 09, 2008

    Edit: I also just checked and the three gold pin things on the plug that goes into the socket are slightly loose and move around. Could this be a issue? if so how do I solve it..
    thanks

  • Anonymous Nov 01, 2008

    same problem

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I am facing the same problem with my creative T 6100 speakers...Please post if any solution found.....Thanks

Posted on Mar 25, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I am getting minimal to almost no sound coming from my mic to my computer.


If you are using the fx/send port to the mic-in port (I have no idea why you would want to do that) but nevertheless, check the red fx dial and make sure it is at 12 oclock and turn the pan dial to 12 oclock also. remember if you are using mic input 1 or 2 with a mic that requires Phantom power the button needs to be locked in the down position. OK im assuming you have checked and set your gain and volume levels on the 802 prior to plugging in your mic. If not do so now.(unplug all outputs and with mic plugged in speak into the mic while turning up gain until you get distortion which is indicated by a rewd light next to the "pan" button...once you see that light turn the gain dial back slightly and you should be set) have volume at 12 oclock on both l"evel1" and "main mix: dials. Now goto your windows desktop and right click on your volume control "speaker" icon. Click on "Playback device" you should see your mic in the list on enabled devices.If you dont see your mic in list right click the screen and click show disabled devices. Enable your device. If it is already enabled right click it and make sure it is not muted. finally go back to list of playback devices and right click your mic and click "configure speakers" run through the tests. close everything.mic should be working now. If it is not I suggest you plug your mic into either the line in from the fx/send or keep it in the mic-in port and plug the other end into the head phones port.Or better yet, get an rca to mini stereo jack and use the cd/tape out jacks to send your signal to the mic port of your computer......keep playing with it...you'll figure it out.There are so many different ways to hook up your perephrials its mind numbing sometimes.

Mar 16, 2013 | Behringer Xenyx 802 8-input 2-bus Mixer W/...

1 Answer

How do I install gateway GMAX2100 speakers to gateway computer


Hi Angela, first find the green plug and connect it in to your headphone inlet (if you are using a laptop, it usually comes on its right side of, if you are using a desktop, then it could come on its back). Plug each little speaker in to the red and white plugs located at back of the largest box/speaker. Set your speakers control next to you, plug the power cord, turn on your speakers systems, adjust volume at middle turn on your computer... And enjoy it!

Sep 18, 2012 | Gateway GMAX 2100 Computer Speakers

1 Answer

Please did you have creative labs inspire T7900 power cable in store


Here is a list of all the different power adapters and specifications from creative. To buy the power cable try newegg.com, or the creative store, or call their tech support.

Mar 04, 2011 | Creative Labs Inspire T7900 Computer...

3 Answers

Problems with creative 5.1 inspire 5200 speakers won't power on


hi
can i get the diagram for the ON OFF switch and volume control? mine is damaged i like to fix it

Oct 03, 2009 | Creative Labs Inspire 5200 Computer...

3 Answers

Speakers


Plug the speakers into your iPod. Any sound?
You may need to maximize the volume-control on the iPod *AND* on your speakers, but you should hear some sound, if the speakers are working.

Try a different set of speakers on your computer.

Make sure that you have not "muted" nor "minimized" the sound on your computer.

Make sure that the speakers are plugged-in to the "green" socket on your computer.

Sep 14, 2009 | Audio Players & Recorders

1 Answer

Inspire m 4500 rear speaker does wrk.........


plug the plugging in and you would get the dialog box in which you can set the out put and input for all your speakers

Jul 28, 2009 | Creative Labs Sound Blaster Live! 5.1...

1 Answer

Speakers Plugged In Right But Wont Turn On??


If the power light on the speakers isn't on, then the power supply going to the speakers is either in a bad outlet (test the outlet with a voltage meter) or the plug isn't firmly seated. Best of luck in your new home and hope this solves your problem.
Greg

Jun 09, 2009 | Altec Lansing ADA 215 Computer Speakers

1 Answer

Creative inspire T7900 7.1 stopped workin


Power light on at the volume knob?

plugged in all the way at the soundcard?

try other speakers even a stereo set to ensure soundcard not a fault?

Apr 19, 2009 | Creative Labs Inspire T7900 Computer...

1 Answer

No sound!!


Do other speakers (that you know to work) perform correctly when you plug them in?

Let me know.

Derek

Mar 06, 2009 | Creative Labs Inspire T3000 Computer...

Not finding what you are looking for?
Logitech X-530 Computer Speakers Logo

Related Topics:

454 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

Michial Gueffroy

Level 3 Expert

1138 Answers

kakima

Level 3 Expert

102366 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...