Question about Kenwood KAC-9102D Car Audio Amplifier

1 Answer

No out put

Yesterday, we sold this amp to a friend when he took it out and tried to hook it up to his car there was no output. it was working perfectly up until he tried it

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,113 Answers

Hi - You can download the manual by clicking the link underlined in blue below:

KAC-9102D

No out put - f5d51bf.jpg

Check the installation is correct!

Please take a moment to rate this solution & let us know if the information given was useful to you - Good Luck!

Informatica

Posted on Sep 08, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Sony XM-GTR4A


contact sony .... or check your head unit is recieving

Mar 29, 2014 | Sony Car Amplifiers

1 Answer

Kenwoood kac-7202 redlight/no output


you blew the output Ic's (amps one or more ) you can fix this by replacing the output IC's

Jan 29, 2014 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

My kac 7202 amp turns on but nothing comes out with everything hooked up


Use process of elimination. Connect the speakers that are hooked up to your amp directly to the radio, if they work check your amp. Make sure the rca jacks are connected properly. Sometimes the radio has rca's that are "inputs", make sure they're connected to the "output" rca's. If those are ok, your amp may be faulty. Try the amp on your friend's car see if it works. If it doues your radio might be at fault...or just bad rca cables. like i said, use process of elimination to narrow down the faulty equipment.

Sep 14, 2009 | Car Amplifiers

1 Answer

I have power lights everything works except sound. It's a pioneer deh-p3300. Could it be programing?


Have you got it hooked up to the internal amplifier or to the rca outputs to an amp? I'm assuming you probably have it hooked up to an amp as most people do on hear but if not try the rca preamp output and see if it puts out anything. Let me knoe so I can futher assist you.

Aug 24, 2009 | Pioneer Car Amplifiers

1 Answer

Car amp has power but will not push subs


output blown on power supply - repair by tech required.

Jan 12, 2009 | Sony XM-SD22X Car Audio Amplifier

1 Answer

Power acoustik gothic ov2-1600


What are the circuit board designations (Q111, Q112, Q211, Q212...) for the parts you replaced?

Did you replace the defective parts with identical transistors?

Which transistors are heating up?

Nov 07, 2008 | Power Acoustik GOTHIC OV2-1200 Car Audio...

2 Answers

Beer Spilled on my Power Acoustik PS2-820 Amp


Hi , now that you have the amp apart , just check the underside of the printed circuit board and check for any corrosion ,rub it with a soft brush . then try connecting without speakers . see if it still blows fuse, if it does then there is a likelihood that your mosfets / outputs may have shorted the first time you reconnected it . Good luck

Mar 21, 2007 | Power Acoustik PS2-820 Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9102D Car Audio Amplifier Logo

Related Topics:

319 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pieter Vleeshouwers

Level 3 Expert

1413 Answers

Are you a Kenwood Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...