Question about Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

1 Answer

No Spray from Bissell 7920 ProHeat Pro-Tech s/n 01222111

Both tanks are seated properly. There is no spray comming out of the spray tips and there is no solution in the flow indicator. Spray DOES come out of the uphostery tool hose however.

I've checked the tubing for kinks and haven't found any. Haven't yet did a diagnostic on the flow system.






Posted by on

  • bostraw Sep 10, 2008

    Finally took the handle apart and found a clog in the tubing on the input side of the heater. The cleaner had not been used in a while so the soap residue from the last use may have solidified in the tubing. Another conributor to the clog might be that there was debris in the clean water tank that found it's way to that spot and caused a accumulation of soap residue. The debris was white & grey in color.



    Now I have another problem. I tested the flow after clearing the tubing and all was working while I had the all the covers off. Once I reassembled the machine there is flow when it's initially turned on but that stops after about 5 seconds. Maybe have an air leak?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

When you put the cover back on, was the piston on the bottom of the smart mix knob? If it was, did you have the smart mix knob in the water only setting? Sometimes the flow indicator cap may be on too tight, loosen it while it is running until fluid starts to leak out, then tighten it until it starts spinning. On the bottom of the tanks, are the seals on the tank and not sitting the the hole. You may have pinched a line when you put the top cover back on. May still have junk in the lines somewhere, try running a mix of vineager and water (not on the carpet), that mix may clean it out.

Posted on Sep 18, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bissell proheat2 Wont spray water, or the suction isn't picking up.


Hi,

Here is a tip that will give you all the information you need to fix your Bissell Proheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101

Nov 20, 2010 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

Bissell, ProHeat, ProTech won't spray water.


Hi,

Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101
895r

Jul 16, 2010 | Bissell 7920 ProHeat Pro-Tech Upright...

2 Answers

New replacement pump on Bissell ProHeat Protech not working


Not sure if I have the same model but this is what I found on mine this morning - wire to switch in the handle came off. Un-plug power cord. Unscrew top two screws on upright handle and remove the front cover above the trigger. see if wires are connected. top connector is not used - if you do solution will spray all the time. Good luck!

Jul 09, 2010 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

I have a Bissell proheat powersteamer but it will not spray the belts are not broken what can I do?


Hi,

Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101

djdj

Mar 10, 2010 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

No carpet spray


That means that you need to replace the pump belt. Here is a link to the belts you need and the manual:

Bissell 7920 Belts and Manual

Dec 21, 2009 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

I have a bissel 7920 proheat pro-tech machine but it does not spray water and shampoo


sounds like a pump problem. PIC << click

heres a website that sells it << click

i would also replace the pump belt.


other things to check

tank may not be seated properly.
pump belt may be broken.
filter maybe clogged.

Oct 08, 2009 | Bissell ProHeat Turbo Deep Cleaner Upright...

1 Answer

How do I take apart my Bissell 7920 ProHeat Pro-Tech


Normal 0 MicrosoftInternetExplorer4 /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman";} Hi,

Here is a tip that will give you all the information you need to fix your Bissell Proheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101

Jul 16, 2009 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

Bissell 7920 doesnt spray liquid


Ive oredered the pump belt and brush. after receiving and fixing them i will test the spray if it works.

Aug 18, 2008 | Bissell 7920 ProHeat Pro-Tech Upright...

Not finding what you are looking for?
Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum Logo

265 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18304 Answers

Roger Potts

Level 3 Expert

694 Answers

Brad Brown

Level 3 Expert

13577 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...