Question about Pioneer GM-X324 Car Audio Amplifier

1 Answer

Light flash power

Hello I have a GM-X324. my problem is that I left hook, one months after he stopped walking worse the light flash power any worse over checker but it's correct

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi. You most probably have a power supply problem. Check capacitors and possible dry joints.

Posted on Sep 08, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Power light flashing


This means it is blown. Whenever the power light flashes on any amp it is blown or something else is wrong with it. Most likely its blown. You can blow am amp by hooking it up to a powerful sub and blaring it, or just overheating it. Hope this helps. This can usually be fixed as well

May 07, 2013 | Pioneer Gm-d8400m 1200w Max, Class D Mono...

1 Answer

I have a pioneer gm-354 amp and the power indicater light on the front has changed from solid to flashing and no sound from the amp to the subwoofer it used to power any idea's


If it is flashing it went into the protect mode.Check that a speaker wire hasn,t come off, Or that the ground cable conection is good end all other hook up wires to it.

Oct 27, 2012 | Pioneer GM-X354 Car Audio Amplifier

2 Answers

I have a pioneer gm-d8400m the amp isnt working


flashing light could mean a few different things. 1- constant power may not be there. check with a test light or multimeter. should read around 12 volts. it would be a good idea to check all the power and ground leads. make sure u have a good ground. 2- bad sub. im assuming sub since its a monoblock amp. you can meter the subs. make sure the total ohm load is no less than 2 ohms. any lower the amp will go into protect mode. 3- bad amp. power supply may be bad. the newer pioneer amps are full of protection circuits. ive been a professional installer for a shop about 8 years and we sell pioneer. hope it helps.

Dec 25, 2009 | Car Audio & Video

1 Answer

No power with amp


make sure the remote wire has juice when the head unit is on then check ground

Nov 25, 2008 | Pioneer GM-7100M Car Audio Amplifier

1 Answer

As i turn volume up amp either cuts off or act wierd


ur pushing to much power throught the amp shutting off the amp and the light might turn yellow on the amp if so then it is that reason

Nov 17, 2008 | Pioneer GM-X324 Car Audio Amplifier

2 Answers

Amplifier won't turn on


You need to confirm that you have voltage on the B+ and ground terminals and have a good ground.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If all of that checks out, the amp probably has an internal fault (blown parts, broken connections...).

Let me know if you have any other questions.

Aug 24, 2008 | Pioneer GM-X324 Car Audio Amplifier

1 Answer

No power to amp


Are you sure it has the full voltage going to both BATT and REM? sounds like the REM signal is weak.

Aug 23, 2007 | Pioneer GM-7200M Car Audio Amplifier

1 Answer

Amp cuts off


So you have an EQ and a Pioneer amp you're trying to hook up to each other? And only some Stinger RCA cable works? And when the lightning audio RCA cable is hooked up, it doesn't turn on? The amp isn't grounding itself through the RCA cables, is it? Check your ground wire and make sure it has a clean contact that's free of rust or any paint that might be in the way. Otherwise, the RCA cables should have nothing to do with an amp turning on or not.

May 07, 2006 | Pioneer GM-X324 Car Audio Amplifier

Not finding what you are looking for?
Pioneer GM-X324 Car Audio Amplifier Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Audio & Video Experts

Michael Kovalik III
Michael Kovalik III

Level 2 Expert

117 Answers

The Knight
The Knight

Level 3 Expert

69955 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Pioneer Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...