Question about Electrolux EL1000A2 Pronto Bagless Stick Cyclonic Vacuum

1 Answer

Electrolux velocity pet lover 1800

My one month old vacuum cleaner has stopped picking up - can't find the blockage - everything else working as normal. Can you help

Posted by on

  • verbalkint Nov 08, 2008

    same problem - you need to have the nossel end over anything you are attemping to pick up and even that is not 100% successful. Checked all the filters and airways for blockages and it still doesnt pick up.

  • Anonymous Feb 15, 2009

    I have exactly the same problem with the 1900 model of the same vacuum. Got this in January so haven't even had it two
    full months yet. It suddenly stopped picking up anythinga few days ago,
    so I cleaned all the bits and pieces as usual thinking that would solve
    the problem, but no luck. The tube thingy still works just fine, but
    the brush underneath has just completely stopped turning, so it is
    essentially useless unless I start running the tiny tube nozzle over
    every inch of my carpets (since I paid the better part of £100 for the
    wretched thing I have absolutely no intention of doing this!). All it
    does when I switch it on now is make enough noise to wake the dead.



    I'm all the more disappointed because when I first got it it worked
    really well. I haven't over-used it and have followed the maintenance
    instructions to the letter, so I can only conclude that it is very
    poorly made. Add to this the fact that I waited a whole month to throw
    out the box (in case something like this happened), only for this
    malfunction to come about literally hours after the box got taken to
    the dump, and you're left with a very cheesed off customer. It seems
    I'm fated to hours and hours of telephone calls to Electrolux to get my
    money back or a replacement. I don't think -2 months is an acceptable
    lifespan for a £100 vacuum cleaner.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

We had the same problem and replaced the driver belt. The only problem is that we seem to have to replace the belt everytime we hoover!

Posted on Jul 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My electrolux vitesse pet lover 1800w has stopped working


Is the flex all right? Check it with a voltmeter or a continuity meter (available for a small sum in your local hardware or electrical shop).

Jan 19, 2015 | Electrolux Vacuums

1 Answer

Electrolux pet lover loss of suction through the hose


I would use a snake for plumbing (sinks) and feed it down the hose to find and clear this blockage if you can remove the hose compressed air may also work.

Dec 18, 2012 | Vacuums

1 Answer

My vacuum was great when I first got it a few months ago, now it won't pick anything up off of the floor. The removable hose works fine, but the main vacuum isn't working at all. I checked the hoses for...


you could have a clog at the begining of the suction port above brush roll check that and make sure the brush roll is spinning if not it wont pick up anything

Feb 16, 2011 | Eureka 3276AZ Pet Lover Bagless Upright...

1 Answer

My oxygen will not pick up pet hair out of the. The brush rotates


Your brush may not be spinning try pressing the reset button on the back of the power nozzle, it that does not work you may need to change the belt.

Bob
eVacuumStore.com

Mar 18, 2010 | Electrolux EL7020A Oxygen 3 Ultra Canister...

1 Answer

I have an Electolux Oxygen canister vacuum and the power head suddenly stopped working. It is only a few months old. Any suggestions.


1. You have to verify if it's simply the belt that has broken and the spinning brush isn't spinning because of it. Place your ear next to the top of the power head to listen for the power head motor. If electricity is getting to the head you'll hear the motor and know to inspect the belt.

2. If the motor doesn't run, look at the electrical pin connectioins in the pipe from the hose to the head. Are they burnt? If yes a new wand is needed. Also check the electrical connections in the hose handle and make sure they are not burnt.

Let me know if this helps

Oct 09, 2009 | Electrolux Oxygen Z5540 Pet Lover Vacuum

1 Answer

Electrolux vitesse pet lover 1700w. Keeps cutting out and electrical sparks in front vent


Hi there SmartAlec from NelsonVacuums.com.au here. I am sorry to be the bearer of bad news but if you can visibly see sparks and its cutting out then i would say that the motor brushes are nearly worn out. On this particular vacuum cleaner they are not sold as a spare part so i think it would need to go to a repair center for a new motor or to vacuum heaven for a replacement.
Regards Alec

Aug 23, 2009 | Electrolux Vacuums

1 Answer

I have a velocity pet lover 1900 only 2 months old


You have broken the rubber belt that drives the brush. Flip over and remove the old belt and replace it with a new one.

Jim

Jun 10, 2009 | Electrolux EL1000A2 Pronto Bagless Stick...

Not finding what you are looking for?
Electrolux EL1000A2 Pronto Bagless Stick Cyclonic Vacuum Logo

910 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Roger Potts

Level 3 Expert

694 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...