Question about Televison & Video

Open Question

Powered Subwoofer - S-DV99SW not powering up changed fuse in plug checked all wiring and still no power?

Posted by on

  • bce5412 Sep 19, 2008

    Yes I have this problem does anyone have any ideas please?

×

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 4 Answers

SOURCE: powered subwoofer hum

The input filter capacitor of ur sub may be damaged,the possibility is upto 99%.u can identify the capacitor easily as it will be the the larger capacitor in that board and is located near the power supply entrance.the component costs within a dollar

Posted on Mar 30, 2007

Ad
  • 1 Answer

SOURCE: Th-R1 no pwoer to subwoofer - transformer u/s?

my power goes to the subwoofer and the little green light comes on for just a second and the you hear a click sound and the subwoofer power goes out. I have the JVC DVD Digital Cinema System TH-C90. Can you please help???

Posted on Nov 13, 2008

  • 5 Answers

SOURCE: loud humming buzzing sound coming from subwoofer

make sure you have the speaker connection right if you do then it is a ground problem try plugging it in a different outlet

Posted on Dec 16, 2008

  • 2 Answers

SOURCE: connect powered subwoofer

  • If your receiver has a dedicated subwoofer line level output, we recommend connecting your subwoofer to this jack. Most receivers will have just one (mono) subwoofer output, while quite a few subs require two inputs. You can use an RCA "Y" adapter cord , which is a cable with one female RCA jack at one end, and two male RCA plugs at the other. Some receivers require menu settings (such as "sub-on" or "front speakers-small") that must be made before the sub output will be active.

  • Posted on Jan 07, 2009

    jhinsincity
    • 616 Answers

    SOURCE: No sound from the subwoofer

    Fuse is probably blown

    Posted on Apr 13, 2010

    Add Your Answer

    Uploading: 0%

    my-video-file.mp4

    Complete. Click "Add" to insert your video. Add

    ×

    Loading...
    Loading...

    Related Questions:

    4 Answers

    Klh powered subwoofer model ASW10-120B... when you plug in to power... it makes a loud buzzing/humming noise


    I would check the caps on the power supply. They are rather large electrolytic capacitors that will look like they burst and/or leaking. When these die, the caps ground and the sub will make a loud buzzing sound. If you are handy with a soldering iron you can replace them yourself. Replace them with the same voltage or a little bigger and same with the size.

    If the cap. says 16v 4700pF on it, for example, a 20v 5300pF or a 16v 6200mF cap. will work for this application.

    when-plug-in-power-makes-loud-buzzing-lgqxs5x4gp2eri5a2qchwtne-5-0.jpg

    when-plug-in-power-makes-loud-buzzing-lgqxs5x4gp2eri5a2qchwtne-5-1.jpg

    when-plug-in-power-makes-loud-buzzing-lgqxs5x4gp2eri5a2qchwtne-5-3.jpg

    Jan 05, 2016 | Audio Players & Recorders

    5 Answers

    Bose Acoustimass Subwoofer not working; front/center are working


    Ok, have you tryed to unplug all of the wires from the sub, including the power wire from the wall. Install of the speaker wires to the sub, and plug back in the sub. Also what are the numbers on the speakers and the sub.

    Jun 10, 2007 | Onkyo TX-SV525 Receiver

    1 Answer

    Paradigm pdr80 no sound


    If it is a powered sub, the sub power supply may have failed. There might be an open fuse.

    Dec 25, 2013 | Paradigm PDR 12 Speaker

    1 Answer

    Why won't my powered subwoofer turn on? It's not


    Have you check if the plug is good on it?

    Dec 03, 2012 | Audio Players & Recorders

    1 Answer

    My subwoofer and speakers wont draw power when i plug it in, could it be the fuse or something else?


    The Altec Lansing A425 doesn't appear to have a fuse. Check for a circuit breaker on any surge protectors it might be plugged in to and make sure they haven't been tripped. Confirm that the power cord is firmly plugged in. Additionally, you could check the wall transformer with a multimeter to make sure it is providing the correct voltage needed by the speakers. Check the back of the subwoofer for a hidden power switch. If everything is plugged in and turned on, but you still don't have power, you will either need to open the device up and troubleshoot it or replace it.

    May 13, 2010 | Dell Powered Subwoofer Set A425 Computer...

    1 Answer

    Subwoofer pre-out wires


    Sorry for the stupid question but is your subwoofer a powered sub? The subwoofer out is just a preamped signal that drives a powered subwoofer. Let me know then we can go from there.

    Jan 28, 2010 | Audio Players & Recorders

    1 Answer

    Powered subwoofer keeps blowing its fuse


    The amp is blown. You need to get it in for service. No telling exactlly what is wrong untill it is opened. 215-736-8055

    Jan 15, 2010 | Onkyo Bass Reflex Powered Subwoofer...

    1 Answer

    Infinity Interlude IL120s Powered Subwoofer (home) will not power


    Some of these Infinity Amps have an Internal Glass Fuse. Open the Case and Check for this Fuse. Please Rate My Response! Thanks!

    Feb 03, 2009 | Infinity 7540A Car Audio Amplifier

    1 Answer

    JBL TLX PS10 Subwoofer - Does not work


    If you have checked the fuses which it sounds like you have, your amp may be out. Take that RCA and plug it into the other speaker. If thar she blows, treat as warranty and call the factory. If this is helpful, please post as such.

    Jan 17, 2009 | JBL TLX PS10 Speaker

    1 Answer

    Jamo Sub300. No power. No lights


    Well it would void the warrantee, but you can take the back panel off and the power supply will only have two leads (3 if grounded) in from the plug, and out to the crossover. It sounds as if you are correct that the power supply is bad.

    Charles

    Jan 05, 2009 | Jamo SUB300BA SUB 300 Powered Subwoofer...

    Not finding what you are looking for?
    Televison & Video Logo

    Related Topics:

    88 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Televison & Video Experts

    The Knight
    The Knight

    Level 3 Expert

    74887 Answers

    Donald DCruz
    Donald DCruz

    Level 3 Expert

    17130 Answers

    Cindy Wells

    Level 3 Expert

    5266 Answers

    Are you a Televison and Video Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...