Question about Olympus Cameras

1 Answer

E-520 the display has just stop working. it comes on when the camera is turned on than after 5 secs. it goes off

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Olympus Expert
  • 479 Answers

Press the info button to see if anything changes.. else reset the camera through the custom reset in the menu

Posted on Sep 09, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My ford ranger/explorer radio won't play anymore


How old is it? Possible warranty?? You will have to take it to a radio tech unless you are one yourself.

Sep 12, 2014 | Cars & Trucks

1 Answer

How to run a diagnostic for washer model MHWE450WW01 Maytag


Starting Error History Software Version and
Diagnostic Test:
NOTE: Washer must be empty and the control must be in the
OFF state.
1. Close the door.
2. Select any one key (except "STOP/CANCEL" and "CONTROL
LOCK" and follow the steps below using the same key:
Press/hold for 2-5 seconds, Release for 2-5 sec, Press/hold for 2-5 sec, Release for 2-5sec, Press/hold for 2-5 sec
3. Upon release, all yellow/green console LED lights will turn ON
for 5 sec.
4. If there are any failure codes stored by the washer, the display
shows them.
Note: The last four errors will be displayed.
5. Press the same key to advance to the next code.
6. After the indication of error codes, the UI, CCU, and MCU SW
version will be displayed.
7. The number of cycles since last clean washer cycle is displayed.
8. All green console LED lights will turn ON for 5 seconds.
9. Next the washer begins the automated diagnostic test.
10.To cancel out of service mode, press the "STOP" button.

Apr 10, 2014 | Maytag Washing Machines

1 Answer

Hard reset Olympus E-520


1. Select P on the mode dial.
2. Open the card door and turn on the camera.
3. Hold down the Menu and the OK buttons at the same time for 5 seconds.
4. Olympus E-520 is displayed.
5. Release and again hold down the Menu and the OK buttons at the same time for another 5 seconds.
6. Reset has been done is displayed
7. Press the OK button.
8. Shut the camera off

Nov 22, 2013 | Olympus E-520 Digital Camera

1 Answer

The camera lens is stuck out,the logo comes on then it goes off


Hi there please follow the steps and let me know the result.
1. Ensure batteries are fully charged & clean the battery connector point in side the battery compartment.
2. Look carefully between the lens and the camera body for any sand, dirt or any damaged etc.
3. Try turning the camera with the lens facing down and shake to dislodge anything stuck
4. Try removing batteries and memory card, wait 5 minutes and refit the battery only.
5. Now turn on camera( with out card ) and see ,if working then fix the memory card & again turn on the camera. If working then fine . Otherwise format the memory card and fix back in camera again & try. Make sure before format the memory card take a back up all photos in your computer then format. If no luck then reset or restore the camera setting by pressing Menu key for 2 sec .. in not done the press both Menu & self time key for 2 - 4 sec.
i hope it will gives you success.

Jan 17, 2011 | Samsung S760 Digital Camera

1 Answer

Kodak camera C653. Camera will not come come on after green light blinks.then the red light blinks and the camera goes off Batteries is not the problem


Hi there please follow the steps and let me know the result.
1. Ensure batteries are fully charged & clean the battery connector point in side the battery compartment.
2. Look carefully between the lens and the camera body for any sand, dirt or any damaged etc.
3. Try turning the camera with the lens facing down and shake to dislodge anything stuck
4. Try removing batteries and memory card, wait 5 minutes and refit the battery only.
5. Now turn on camera( with out card ) and see ,if working then fix the memory card & again turn on the camera. If working then fine . Otherwise format the memory card and fix back in camera again & try. Make sure before format the memory card take a back up all photos in your computer then format. If no luck then reset or restore the camera setting by pressing Menu key for 2 sec .. in not done the press both Menu & self time key for 2 - 4 sec.
i hope it will gives you success.

Jan 17, 2011 | Kodak EasyShare C330 Digital Camera

1 Answer

Display coming for 2 sec and then it goes off


Does it work well with other computers?
If you are connecting to a laptop, try switching display modes (like you would do for a projector)

Sep 03, 2009 | Acer AL1916W 19" LCD Monitor

2 Answers

Camera turns on with a bit of a tremble but shutter locks


I have an 5D with the same problem, It looks like the Anti shake does not initialize properly, The only bypass I found that worked (except for a real repair) is to set the display light timeout for 5 seconds, The standby timout for 1 minute, Turn the camera off, and on again, Wait for 5 sec then the display goes blank, wait for 1 minute then the camera goes in standby, (light from CF card flashed red 1 time) Then touch any button to re-activate the camera and... voila... everything works, including taking normal pictures and the anti-shake !!! So it only takes a minute everytime to startup..

Jun 05, 2009 | Konica Minolta Maxxum 7D / Dynax 7D...

1 Answer

OKI 520 ELITE


Kindly check the DPI settings . May be more DPI this time.

Best Regards
Rafique

Feb 19, 2008 | OKI MICROLINE 520 Matrix Printer

2 Answers

It says "turn the power off and on again"..!!


try gently pulling and twisting the end of the lense and i mean gentle dont pull till it pops than switch it off and on again and you problem should be solved

Oct 26, 2007 | Sony Cyber-shot DSC-W80 Digital Camera

Not finding what you are looking for?
Cameras Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Cameras Experts

kakima

Level 3 Expert

101466 Answers

Willem.
Willem.

Level 2 Expert

354 Answers

Steven Wander
Steven Wander

Level 3 Expert

579 Answers

Are you an Olympus Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...