Question about Sapphire RADEON X1550 Graphic Card

2 Answers

Blank White Screen.

I Installed my new Sapphire ATI Radeon X1550, 256MB AGP Card into its slot and i only get a Blank White Screen, I Don't even see Dos. the Card specs on the box are ok for my motherbourd, AGP 8X (0.8v), 4X (1.5). I think the card may be fubard. But would like comformation or a fix. thanks Dave54

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

CONTACT MNE ON ADY_JL@YAHOO.COM IF U SOLVE THE PROBLEM PLZ

Posted on Aug 04, 2009

Cpu restart after first log on

Posted on Sep 07, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Driver


Hi,

Just click on the following link and download your driver. ATI Sapphire Radeon Drivers

All the best

Ben

May 25, 2011 | ATI Sapphire RADEON 9550...

1 Answer

So which video card do i need? i have 845gl motherboard . before installing this video card (rage XL 8mb pci) my pc plays videos and most 3d game very (even gta sanandreas) efficiently but now it is not...


Hi,

The ATI Rage XL 8MB PCI video card is a very old and low power video card.

PCI graphics cards are not as fast as AGP graphics cards so if your motherboard has an AGP slot (it's the slot closest to the CPU and is usually coloured brown) then that would give you better performance.

These days AGP has been superceded by PCI-Express but since your motherboard does not have a PCI-Express slot then the best graphics card for it would be something like this one:

http://www.play.com/PC/PCs/4-/5416296/Sapphire-ATI-Radeon-HD-3850-512MB-DDR3-AGP-8X-Graphics-Card/Product.html

Hope this helps, please rate my answer :)

Chris

Mar 02, 2011 | ATI Rage XL 8MB PCI Video Card PCI

1 Answer

I installed a new vcard Sapphire Ati Radeon HD4670. then when i play online games i screen turns black after a while it hangs.. what should i do


Hi,
Go to the bios and set the video to agp and the ram memory to the specified memory of the video card and exit after saving it.
Hope that helps you out!
Thanks for using Fixya!

Dec 12, 2010 | Sapphire ATI RADEON HD 4670,, PCI Express...

1 Answer

I installed the ATI x1650 but the monitor is blank when I turn on


Yes the card does support the screen. If you have blank screen right from turn on, chack that you have not plugged the monitor into the onboard graphics port instead of your Radeon. If you have plugged it into the right port then you have hardware problems. Could be any of the following:
1. Monitior
2. Video Card
3. System memory
4. Motherboard
5. Powersupply
6. CPU

Try a different monitor and get back to me if you want troubleshooting tips.
Cheers

May 09, 2009 | ATI RADEON X1650 Graphic Card

1 Answer

My computer won't detect ATI RADEON SAPPHIRE X1550 256MB


go to bios and enable it to detect graphics cards most bios have an option for onboard only or onboard and external graphics adapters

May 04, 2009 | Sapphire ATI RADEON X1600Pro 512MB...

1 Answer

Install Used ATI 7000 graphics card on Dell Optiplex GX270


OK, I got into Dell. Your motherboard should support an AGP card.

GX270 System Boards

Is there something in the green slot?

That is the AGP slot. If there is something in it, remove it. The ATI card should work in it if it is an AGP card.

Feb 12, 2009 | ATI RADEON 7000 PCI Graphic Card

1 Answer

White screen with radeon x1300 pro agp 256m


Hi porkchop_66_ , if you uninstalled factory graphics drivers, chances are you uninstalled the motherboards built in graphics card driver. Since you haven't provided your motherboard model & manufactures name I can't be 100% your weren't using an onboard graphics card. So I'll cover both.
If you added the X1300 AGP card, (Not replacing an older AGP card), you'll need to enter the motherboards bios menu & set the bios to boot to the AGP slot. If you replaced an older AGP card, its possible you have the monitor plugged into the wrong VGA out-put on the Radeon. There are two ports. One DVI & one VGA. Try each & check for display. Lastly, the Radeon X1300 card you have
runs in an AGP port that supports 1.5volts. Check your, motherboard manual. Check if your motherboard supports AGP cards of 1.5v.
If all this does not make sense, post back with your motherboards model number & the manufacture name & I'll be able to help further. Post here.


Good luck porkchop_66_!
Thank you for using fixya.
Mike

Jan 14, 2009 | ATI RADEON X1300 PRO, (256 MB) AGP Graphic...

1 Answer

ATI Radeon 9600XT


Hi and welcome to FixYa,

Appreciate the direct "ask Me".

Some motherboards require a separate AGP port driver to be installed before the drivers of the AGP video card could be recognized. This is specially so for 8X. Perhaps the solution requires that you install the complete motherboard drivers including the AGP port before installing the ATI 9600XT drivers.

Good luck and Thank you for using FixYa. Happy Holidays.

Dec 17, 2008 | ATI RADEON 9600XT 256MB DDR DVI&TV Out...

1 Answer

GX270 with a ATI Radeon Sapphire x 1600 Pro Card machine not booting


Are you online now? and what time zone are you in? GMT

Sep 29, 2008 | Sapphire , AGP Video Card

2 Answers

Vga cards


No, the units will conflict with eachother. If you are using the add on card, you must disable the onboard card.

May 10, 2008 | Sapphire ATI RADEON X1600Pro 512MB...

Not finding what you are looking for?
Sapphire RADEON X1550 Graphic Card Logo

Related Topics:

284 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sapphire Graphics Cards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Brett Duxbury
Brett Duxbury

Level 3 Expert

2716 Answers

Are you a Sapphire Graphics Card Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...